#opendaylight-openflowplugin: OpenFlow Plugin Sept 14

Meeting started by abhijitkumbhare at 16:05:50 UTC (full logs).

Meeting summary

  1. Inventory/topology (abhijitkumbhare, 16:06:52)
    1. vishnoianil (vishnoianil, 16:07:27)
    2. michal_rehak checking if he will have spare cycles for this in October (abhijitkumbhare, 16:07:59)

  2. Moving openflow plugin to mature (abhijitkumbhare, 16:08:21)
    1. Introduced the concept of moving projects to mature state in project life cycle (abhijitkumbhare, 16:16:14)
    2. Will be discussed in more detail later - as to what specific actions we need to do to move OF plugin to mature (abhijitkumbhare, 16:17:01)

  3. OF extensions: circuit switch project requirements (abhijitkumbhare, 16:17:25)
    1. Will use multi part experimenter messages (abhijitkumbhare, 16:18:20)
    2. Need to get port DESC STATUS (abhijitkumbhare, 16:19:14)
    3. Currently PORT_DESC_STATUS not available as an RPC (abhijitkumbhare, 16:19:40)
    4. kamalr asks when PORT_DESC_STATUS gets put into operational DS - why can we not listen for notification? (abhijitkumbhare, 16:21:26)
    5. Aneesha says this is not available for circuit switch (which is a multi part experimental message) (abhijitkumbhare, 16:22:32)
    6. vishnoianil thinks if the multi part messages are OF 1.3 compliant - this should be handled as long as it is not proprietary (abhijitkumbhare, 16:23:47)
    7. vishnoianil plugin can dump the standard experimenter stuff into the Oper DS (using the current experimenter framework) - and after that the OFEXTENSIONS circuitsw should handle it (abhijitkumbhare, 16:26:06)
    8. Aneesha says for multi part experimenter message not present (abhijitkumbhare, 16:26:39)
    9. michal_rehak says we do not have models for multi part experimenter messages not present (abhijitkumbhare, 16:27:36)
    10. ACTION: abhijitkumbhare to create a Trello card for experimenter multi part message (abhijitkumbhare, 16:28:54)
    11. ACTION: michal_rehak will add details on the Trello card for experimenter multi part message (abhijitkumbhare, 16:29:30)
    12. bug 547 changes (getPortDescription on demand) were reverted because the multipart request/reply can result in stale port status ... not sure if it applies for Aneesha's requirement... (Hari_, 16:31:25)
    13. Aneesha does not have the cycles for picking up the task for experimenter multi part message, but will participate in the Beryllium release only if this support is added into OpenFlow plugin (abhijitkumbhare, 16:32:43)
    14. ACTION: abhijitkumbhare to send an email to the OpenFlow plugin mailing list seeking a volunteer for supporting experimenter multi part message (abhijitkumbhare, 16:35:29)

  4. Reconciliation (abhijitkumbhare, 16:37:04)
  5. Parity between Lithium and existing designs (abhijitkumbhare, 16:39:23)
    1. Bug 4117 : Li: Enable Yang notifications for backward compatibility (abhijitkumbhare, 16:39:47)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=4117 (abhijitkumbhare, 16:40:06)
    3. https://git.opendaylight.org/gerrit/#/c/25965/ (abhijitkumbhare, 16:40:25)
    4. vishnoianil says that the patch talks about deprecation of notifications (abhijitkumbhare, 16:42:12)
    5. vishnoianil says lot of folks are using notifications - and want to keep this path in the plugin for performance reasons (abhijitkumbhare, 16:43:21)
    6. vishnoianil thinks the language of deprecating notifications may not be acceptable for some applications (abhijitkumbhare, 16:49:12)
    7. michal_rehak says that applications needing higher performance can directly wait for the flow programming result (abhijitkumbhare, 16:50:18)
    8. kamalr says the patch provides backward compatibility - but there is a performance impact (abhijitkumbhare, 16:56:27)
    9. abhijitkumbhare asked michal_rehak if we could write a wiki / guide for application developers to migrate to Lithium design (abhijitkumbhare, 17:05:12)
    10. this will need to be taken to the mailing lists (abhijitkumbhare, 17:06:27)


Meeting ended at 17:06:37 UTC (full logs).

Action items

  1. abhijitkumbhare to create a Trello card for experimenter multi part message
  2. michal_rehak will add details on the Trello card for experimenter multi part message
  3. abhijitkumbhare to send an email to the OpenFlow plugin mailing list seeking a volunteer for supporting experimenter multi part message


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to create a Trello card for experimenter multi part message
    2. abhijitkumbhare to send an email to the OpenFlow plugin mailing list seeking a volunteer for supporting experimenter multi part message


People present (lines said)

  1. abhijitkumbhare (53)
  2. odl_meetbot (10)
  3. colindixon (4)
  4. Hari_ (2)
  5. vishnoianil (1)


Generated by MeetBot 0.1.4.