#opendaylight-openflowplugin: OpenFlow Plugin Jan 10

Meeting started by abhijitkumbhare at 17:05:08 UTC (full logs).

Meeting summary

    1. Happy New Year! (abhijitkumbhare, 17:05:23)
    2. M5 for the remaining (offset 2) projects - Jan 14 (this Thursday) (abhijitkumbhare, 17:08:35)
    3. Patches which need to be merged - need to be done before that (abhijitkumbhare, 17:08:54)
    4. https://git.opendaylight.org/gerrit/#/q/status%253Aopen+project%253Aopenflowplugin Patches to be merged (abhijitkumbhare, 17:09:18)
    5. Deadline for merging patches before branch off cutoff on Thursday Jan 14 (abhijitkumbhare, 17:11:16)
    6. vishnoianil will merge most of the patches for existing design; kamalrameshan should merge majority of patches for the Lithium design (abhijitkumbhare, 17:12:26)

  1. Hari’s patch for existing design clustering (abhijitkumbhare, 17:15:24)
    1. vishnoianil will help in breaking the patch into multiple patches (abhijitkumbhare, 17:15:57)
    2. vishnoianil will take over the existing design clustering patch (abhijitkumbhare, 17:18:44)

  2. Highlights of Beryllium (abhijitkumbhare, 17:20:38)
    1. Clustering support (abhijitkumbhare, 17:20:53)
    2. Reconciliation (abhijitkumbhare, 17:21:02)
    3. Nicira extensions added for OVSDB (abhijitkumbhare, 17:21:29)
    4. Table Features (abhijitkumbhare, 17:21:46)
    5. ACTION: vishnoianil will provide the Nicira extensions info (abhijitkumbhare, 17:22:44)
    6. ACTION: Kamal+vishnoianil+Muthu+Shuva+Michal document the new features (abhijitkumbhare, 17:24:08)
    7. Target date for documentation of new features - Jan 25 (abhijitkumbhare, 17:27:08)

  3. Graduation review for OpenFlow Plugin on Jan 14 TSC meeting (abhijitkumbhare, 17:28:16)
    1. Graduation proposal posted (abhijitkumbhare, 17:28:46)
    2. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Graduation_Proposal Graduation proposal (abhijitkumbhare, 17:28:55)
    3. Patches need to merged (abhijitkumbhare, 17:32:17)

  4. BUG-3774: 100k flows initial stats fail - logging (abhijitkumbhare, 17:33:38)
    1. Patch ready for code review and for merge (abhijitkumbhare, 17:33:53)
    2. https://git.opendaylight.org/gerrit/#/c/31604/2  (abhijitkumbhare, 17:35:31)
    3. https://git.opendaylight.org/gerrit/#/c/30968/5 (abhijitkumbhare, 17:35:50)

  5. Muthu/Shuva’s testing for OpenFlow clustering (abhijitkumbhare, 17:37:04)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=4919 (abhijitkumbhare, 17:37:19)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=4866 (abhijitkumbhare, 17:37:35)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=4576 (abhijitkumbhare, 17:37:45)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=4923 (abhijitkumbhare, 17:37:56)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=4823 (abhijitkumbhare, 17:38:08)
    6. https://bugs.opendaylight.org/show_bug.cgi?id=4925 (abhijitkumbhare, 17:38:19)
    7. Muthu will work with LuisGomez to integrate these test cases with the integration (abhijitkumbhare, 17:39:15)

  6. Tasks for next 2 weeks (abhijitkumbhare, 17:41:23)
    1. Push & merge any pending patches (abhijitkumbhare, 17:42:38)
    2. Bug scrub on Jan 18 meeting (abhijitkumbhare, 17:42:52)
    3. Finish docs by Jan 25 (abhijitkumbhare, 17:43:16)
    4. Fix bugs (abhijitkumbhare, 17:43:34)
    5. ACTION: Kamal help on merge patches for the Lithium design (abhijitkumbhare, 18:00:59)
    6. ACTION: vishnoianil merge patches for the existing design (abhijitkumbhare, 18:01:20)


Meeting ended at 18:02:08 UTC (full logs).

Action items

  1. vishnoianil will provide the Nicira extensions info
  2. Kamal+vishnoianil+Muthu+Shuva+Michal document the new features
  3. Kamal help on merge patches for the Lithium design
  4. vishnoianil merge patches for the existing design


People present (lines said)

  1. abhijitkumbhare (46)
  2. odl_meetbot (5)


Generated by MeetBot 0.1.4.