#opendaylight-openflowplugin: OpenFlow Plugin June 30, 2016

Meeting started by abhijitkumbhare at 15:04:06 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 15:04:55)
    1. Deprecation of Models (Miroslav) (abhijitkumbhare, 15:05:33)
    2. Feature reorganization (Andrej) (abhijitkumbhare, 15:06:17)
    3. Extensibility framework (time permitting - Manohar) (abhijitkumbhare, 15:07:25)
    4. M5 deadline July 21 (abhijitkumbhare, 15:07:41)

  2. Deprecation of Models (Miroslav) (abhijitkumbhare, 15:08:07)
    1. Bug/task to deprecate notifications (abhijitkumbhare, 15:08:53)
    2. shuva notes that we had decided to keep the flow removed notifications (needed by VTN & VPN services) (abhijitkumbhare, 15:10:18)
    3. jbacigal thinks that notifications could have problems regarding the performance and other issues, Vinayak thinks the lack of notifications can lead to performance problems (abhijitkumbhare, 15:16:49)
    4. One of the problems is that notifications can arrive out of order - which the applications need to handle. Vinayak thinks that is an acceptable tradeoff to the applications (abhijitkumbhare, 15:17:50)
    5. Vinayak says we already have a knob to have notifications or not (abhijitkumbhare, 15:19:52)
    6. Actually, it was decided to use the FLOW_MOD message flag to register for Flow Removal notification (ManoharSL, 15:21:40)
    7. If an particular NSF does not need the notification, then it has to not ask for flow removed notification (ManoharSL, 15:22:16)
    8. by setting the flag in FLOW_MOD message itself (ManoharSL, 15:22:27)
    9. The flag name is: OFPFF_SEND_FLOW_REM (abhijitkumbhare, 15:24:38)
    10. Miroslav says the reason for removing notifications is to have a clean API and only have a single channel (abhijitkumbhare, 15:24:49)
    11. need to measure the cost of turning notification off and turning statistics on for large use-cases liek a million flows (shuva, 15:31:03)
    12. AGREED: We will be going with the knob for Carbon (abhijitkumbhare, 15:33:59)

  3. Feature reorganization (abhijitkumbhare, 15:34:35)
    1. anleitne says nothing special with respect to feature reorganization (abhijitkumbhare, 15:35:03)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=5572 - FRM features.xml reorganize (abhijitkumbhare, 15:36:04)
    3. anleitne waiting for a patch merge in SDN-app (abhijitkumbhare, 15:36:24)
    4. after that patch merge - we should be good (abhijitkumbhare, 15:36:42)

  4. M5 deadline July 21 (abhijitkumbhare, 15:39:11)
    1. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Boron_Release_Plan (abhijitkumbhare, 15:39:18)
    2. ACTION: jbacigal to send an email to abhijitkumbhare , muthu, vishnoianil , shuva, anleitne, etc. about singleton clustering & what may not make it in Boron (abhijitkumbhare, 15:42:44)

  5. Extensibility framework (abhijitkumbhare, 15:45:01)
    1. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Backlog:Extensibility (shuva, 15:47:36)
    2. ManoharSL wants to know if any changes are planned in OpenFlow Library for extensibility (abhijitkumbhare, 15:47:45)
    3. https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Openflow_Protocol_Library%27s_extensibility (shuva, 15:47:49)
    4. ACTION: ManoharSL to send out an email starting discussion on this topic (abhijitkumbhare, 15:48:10)


Meeting ended at 15:50:12 UTC (full logs).

Action items

  1. jbacigal to send an email to abhijitkumbhare , muthu, vishnoianil , shuva, anleitne, etc. about singleton clustering & what may not make it in Boron
  2. ManoharSL to send out an email starting discussion on this topic


Action items, by person

  1. abhijitkumbhare
    1. jbacigal to send an email to abhijitkumbhare , muthu, vishnoianil , shuva, anleitne, etc. about singleton clustering & what may not make it in Boron
  2. jbacigal
    1. jbacigal to send an email to abhijitkumbhare , muthu, vishnoianil , shuva, anleitne, etc. about singleton clustering & what may not make it in Boron
  3. ManoharSL
    1. ManoharSL to send out an email starting discussion on this topic
  4. shuva
    1. jbacigal to send an email to abhijitkumbhare , muthu, vishnoianil , shuva, anleitne, etc. about singleton clustering & what may not make it in Boron
  5. vishnoianil
    1. jbacigal to send an email to abhijitkumbhare , muthu, vishnoianil , shuva, anleitne, etc. about singleton clustering & what may not make it in Boron


People present (lines said)

  1. abhijitkumbhare (34)
  2. odl_meetbot (7)
  3. ManoharSL (4)
  4. shuva (3)
  5. vishnoianil (1)
  6. jbacigal (0)


Generated by MeetBot 0.1.4.