#opendaylight-openflowplugin: OpenFlow Plugin Meeting Aug 18, 2016

Meeting started by abhijitkumbhare at 15:10:33 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 15:10:45)
    1. Documentation (abhijitkumbhare, 15:10:56)
    2. Test report from LuisGomez (abhijitkumbhare, 15:11:36)
    3. Bugs (abhijitkumbhare, 15:11:45)
    4. Integration with Singleton app on the master Status (abhijitkumbhare, 15:12:21)
    5. Bugzilla cleanup (abhijitkumbhare, 15:12:59)

  2. Bugzilla cleanup (abhijitkumbhare, 15:13:59)
    1. investigating, testing and closing bugs 6658, 5888, 6445, 2719, 1395, 4210, 1647, 3706, 4148, 2612, 1939, 1565, 521 (abhijitkumbhare, 15:14:45)
    2. investigating bugs 1462, 3208, 1810 (abhijitkumbhare, 15:15:04)
    3. Bugs (abhijitkumbhare, 15:16:15)
    4. jbacigal looking into https://bugs.opendaylight.org/show_bug.cgi?id=6465 raised by NetVirt (abhijitkumbhare, 15:16:34)
    5. Happens only on the master branch (abhijitkumbhare, 15:17:14)
    6. Patch for table features switched off (abhijitkumbhare, 15:18:30)
    7. https://git.opendaylight.org/gerrit/#/c/42821/ (andrejleitner, 15:18:39)
    8. This patch for table features needs to be merged - already reviewed by jbacigal (abhijitkumbhare, 15:19:48)
    9. https://bugs.opendaylight.org/show_bug.cgi?id=5173 (shuva, 15:22:06)
    10. Do we need individual bugs for too many logs? (abhijitkumbhare, 15:23:34)
    11. As per shuva, for bug 5173 with OVS 2.4 - by default table features switched off on master we will see less number of logs (abhijitkumbhare, 15:26:22)
    12. We will reopen https://bugs.opendaylight.org/show_bug.cgi?id=5173 (too many Karaf logs when connecting to OVS 2.4) (abhijitkumbhare, 15:29:44)
    13. https://bugs.opendaylight.org/show_bug.cgi?id=6146 - a blocker bug raised by NetVirt (abhijitkumbhare, 15:32:53)
    14. andrejleitner thinks 6146 is fixed, and netvirt has a workaround already (abhijitkumbhare, 15:33:56)
    15. ACTION: andrejleitner will email openflow plugin & netvirt mailing list about bug 6146 status (abhijitkumbhare, 15:34:36)
    16. https://bugs.opendaylight.org/show_bug.cgi?id=6459 - critical - [Li plugin] Reconciliation not triggering after a single node reboot in a non OFHA scenario (abhijitkumbhare, 15:36:02)
    17. Bug 6459 has been fixed in He design - needs to be fixed in the Li design (abhijitkumbhare, 15:39:09)
    18. Ideally reconciliation is independent of He or Li (abhijitkumbhare, 15:39:48)

  3. Test Report from LuisGomez (abhijitkumbhare, 15:41:34)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=6176 (abhijitkumbhare, 15:42:02)
    2. Cbench throughput test does not work in Boron: (abhijitkumbhare, 15:42:09)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=6176 (abhijitkumbhare, 15:42:19)
    4. jbacigal thinks this may be environment related (abhijitkumbhare, 15:42:37)
    5. LuisGomez will try to replicate locally to check if it is environment related (move to the cloud) (abhijitkumbhare, 15:43:17)
    6. He Plugin: Topology is not being discovered. (abhijitkumbhare, 15:43:43)
    7. vishnoianil will take a quick look at this (abhijitkumbhare, 15:46:22)
    8. https://bugs.opendaylight.org/show_bug.cgi?id=6456 (abhijitkumbhare, 15:46:38)
    9. Li PLUGIN: Modified flow does not reconcile in configuration (alien flow ID) (abhijitkumbhare, 15:47:41)
    10. https://bugs.opendaylight.org/show_bug.cgi?id=6458 (abhijitkumbhare, 15:48:38)
    11. shuva has a patch related to this waiting for review - needs to be merged (abhijitkumbhare, 15:50:31)
    12. Entity Owner not resolved properly after owner is isolated and rejoined (abhijitkumbhare, 15:52:07)
    13. https://bugs.opendaylight.org/show_bug.cgi?id=6177 (abhijitkumbhare, 15:52:30)
    14. Need to check if this issue happens on the master (abhijitkumbhare, 15:52:49)
    15. For master there are 92 failures for clustering; for the Boron branch there are 16 failures (abhijitkumbhare, 15:57:15)
    16. For master there are 92 failures for clustering; for the Boron branch there are 16 failures (abhijitkumbhare, 15:58:12)
    17. Need to check if the tests need to be updated for the singleton and whether some of the failures are expected but not real failures (abhijitkumbhare, 15:58:41)
    18. LuisGomez will disable tests that do not apply for singleton design (abhijitkumbhare, 15:59:43)
    19. Switch inventory remains when switch goes off (after owner restarts) (abhijitkumbhare, 16:00:35)
    20. This does not happen on the Carbon (master); but happens on Boron - singleton related (abhijitkumbhare, 16:01:58)
    21. Switch Disconnect+Connect to Ownership Candidate fails (abhijitkumbhare, 16:02:14)
    22. This also does not happen on the Carbon (master); but happens on Boron - singleton related (abhijitkumbhare, 16:02:40)
    23. Unstable Switch scalability (100 to 400 switches) (abhijitkumbhare, 16:03:02)
    24. https://bugs.opendaylight.org/show_bug.cgi?id=6178 Li plugin: Global peformance issues (abhijitkumbhare, 16:03:41)
    25. Test seems to work in Carbon as well as the Helium design for Boron; just fails Li design on Boron (abhijitkumbhare, 16:05:30)


Meeting ended at 16:12:10 UTC (full logs).

Action items

  1. andrejleitner will email openflow plugin & netvirt mailing list about bug 6146 status


Action items, by person

  1. andrejleitner
    1. andrejleitner will email openflow plugin & netvirt mailing list about bug 6146 status


People present (lines said)

  1. abhijitkumbhare (53)
  2. shuva (4)
  3. odl_meetbot (4)
  4. hideyuki (2)
  5. andrejleitner (1)


Generated by MeetBot 0.1.4.