#opendaylight-openflowplugin: OpenFlow Plugin Meeting August 11, 2016

Meeting started by abhijitkumbhare at 15:02:06 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 15:03:57)
    1. Status received over email (abhijitkumbhare, 15:04:38)
    2. RC0 & code merge status (abhijitkumbhare, 15:04:52)
    3. Bugs affecting other projects (abhijitkumbhare, 15:05:13)
    4. NSH patch (abhijitkumbhare, 15:06:06)
    5. Clustering Patch (abhijitkumbhare, 15:07:15)

  2. Status received over email (abhijitkumbhare, 15:07:47)
    1. Jozef is working on 5596 - Milestone: integrate with Singleton app. Controller multiphase – hope, it will be merged today. Miroslav is testing it. (abhijitkumbhare, 15:08:37)
    2. Jozef or Miroslav will send status and some logs from our testing (abhijitkumbhare, 15:08:58)
    3. Andrej has resolved 5 bugs (abhijitkumbhare, 15:09:18)
    4. Bug 6177 - Li Plugin (more frequent): Entity Owner not resolved properly after owner is isolated or rejoined - this should be solved within bug 5596. (using cluster singleton service instead of EOS) (abhijitkumbhare, 15:09:55)
    5. Tomas is working on blocker 6259 Flow doesn't show up in operational data with correct flow id (abhijitkumbhare, 15:10:13)
    6. 5596 ( integrate with Singleton app. Controller multiphase) - will be merged by Friday onto the master & later to the Boron branch (abhijitkumbhare, 15:13:43)
    7. Andrej 5 bugs are related to changing the apps to use data tree change listener instead of DCL (abhijitkumbhare, 15:15:17)

  3. Bugs affecting other projects (abhijitkumbhare, 15:17:52)
    1. hideyuki wants review for https://git.opendaylight.org/gerrit/#/c/40817/ (abhijitkumbhare, 15:18:20)
    2. Bug 6110 (shuva, 15:18:22)
    3. Bug 5822: Flow ID clash - vishnoianil is reviewing shuva’s changes (abhijitkumbhare, 15:19:26)

  4. Config parameters (abhijitkumbhare, 15:26:39)
    1. Key approach in Boron would be use a config file - and no syncing the parameters with the other members & will have to be done on all the members manually (abhijitkumbhare, 15:27:58)
    2. This may be improved in the future (abhijitkumbhare, 15:29:19)
    3. In production - most likely these parameters will not need to be synced dynamically (abhijitkumbhare, 15:29:50)
    4. https://git.opendaylight.org/gerrit/#/c/43276/ (vishnoianil, 15:32:44)
    5. Please update this documentation for the cfg file (abhijitkumbhare, 15:33:59)

  5. Documentation Update (abhijitkumbhare, 15:34:19)
    1. myself to take the cfg file with the parameters approach for table-features (shuva, 15:35:27)
    2. update the cfg file with the detailed desc (shuva, 15:36:08)
    3. ACTION: jbacigal, shuva, etc. Please update adocs for the new items in the Boron release (abhijitkumbhare, 15:36:53)
    4. Documentation will be updated (abhijitkumbhare, 15:37:20)
    5. Restructured text is being studied & implemented currently in the ODL docs project (abhijitkumbhare, 15:41:24)

  6. NSH patch (abhijitkumbhare, 15:42:05)
    1. This has been merged in OpenFlow Plugin (abhijitkumbhare, 15:42:18)

  7. Table Features (abhijitkumbhare, 15:43:02)
    1. Will be incorporating by next week based on the review comments (abhijitkumbhare, 15:43:36)
    2. https://git.opendaylight.org/gerrit/#/c/42821 (shuva, 15:44:19)


Meeting ended at 15:52:36 UTC (full logs).

Action items

  1. jbacigal, shuva, etc. Please update adocs for the new items in the Boron release


Action items, by person

  1. shuva
    1. jbacigal, shuva, etc. Please update adocs for the new items in the Boron release


People present (lines said)

  1. abhijitkumbhare (39)
  2. shuva (5)
  3. odl_meetbot (5)
  4. hideyuki (2)
  5. vishnoianil (1)


Generated by MeetBot 0.1.4.