#opendaylight-openflowplugin: OpenFlow Plugin Meeting Feb 22

Meeting started by abhijitkumbhare at 17:04:14 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 17:06:46)
    1. Developer Design Forum next Monday (Feb 29) - OpenFlow Plugin Agenda (abhijitkumbhare, 17:07:51)
    2. Outstanding issues of Li design to be fixed before migration (abhijitkumbhare, 17:10:27)
    3. Inventory to Topology Migration? (abhijitkumbhare, 17:10:49)
    4. Next steps in OFP (abhijitkumbhare, 17:11:21)

  2. Outstanding issues of Li design to be fixed before migration (abhijitkumbhare, 17:11:56)
    1. OpenFlow 1.0 issue - bug 5328 (abhijitkumbhare, 17:13:47)
    2. Mininet does not work with OpenFlow 1.0 with Li design (abhijitkumbhare, 17:14:45)
    3. ACTION: Jozef to check bug 5328 (abhijitkumbhare, 17:16:51)
    4. Cluster issues with Li design (abhijitkumbhare, 17:17:27)
    5. Jozef says he and his team are still investigating this (abhijitkumbhare, 17:18:14)
    6. Stability issues (longevity tests, etc.) (abhijitkumbhare, 17:21:33)
    7. https://bugs.opendaylight.org/show_bug.cgi?id=5271 (abhijitkumbhare, 17:21:57)
    8. https://bugs.opendaylight.org/show_bug.cgi?id=4925 (abhijitkumbhare, 17:22:17)
    9. Test whether projects break if we move to the Li design (using a patch not-to-be-merged just making a switch) (abhijitkumbhare, 17:25:29)
    10. This test is for identifying issues for migration (abhijitkumbhare, 17:26:08)
    11. ACTION: vishnoianil will push a patch to stable/beryllium for OpenFlow plugin to create a distribution that LuisGomez can test (abhijitkumbhare, 17:27:40)
    12. this patch was created before for reference: https://git.opendaylight.org/gerrit/#/c/33161/ (LuisGomez, 17:27:59)
    13. Stability issues (longevity tests, etc.) (abhijitkumbhare, 17:29:30)
    14. https://bugs.opendaylight.org/show_bug.cgi?id=5271 (abhijitkumbhare, 17:29:57)
    15. https://bugs.opendaylight.org/show_bug.cgi?id=4925 (abhijitkumbhare, 17:30:06)
    16. Need to monitor the longevity test - as it fails intermittently (abhijitkumbhare, 17:31:39)
    17. Bug 4925 - now in the CI test framework (abhijitkumbhare, 17:33:05)
    18. Bug 4925 - v_demcak looking at it (abhijitkumbhare, 17:35:02)
    19. ACTION: jbacigal will let know bug 4925 status the end of the week (abhijitkumbhare, 17:35:41)
    20. Looking at the issues - a good migration plan would be fix the outstanding blocker issues in Be SR1 (fix first in the master, then cherry pick after stable); and have the applications migrate in SR2 (abhijitkumbhare, 17:43:29)
    21. Assumption is that SR1 is on March 17 (abhijitkumbhare, 17:45:43)
    22. VTN is testing against the Li design; they are facing performance issues in the RPCs (abhijitkumbhare, 17:50:55)
    23. hideyuki to open bug on the performance issue (abhijitkumbhare, 17:52:39)
    24. VTN project has already made the change for the migration to OFP-Li. https://git.opendaylight.org/gerrit/#/c/35118/ (hideyuki, 17:54:16)


Meeting ended at 18:10:02 UTC (full logs).

Action items

  1. Jozef to check bug 5328
  2. vishnoianil will push a patch to stable/beryllium for OpenFlow plugin to create a distribution that LuisGomez can test
  3. jbacigal will let know bug 4925 status the end of the week


Action items, by person

  1. LuisGomez
    1. vishnoianil will push a patch to stable/beryllium for OpenFlow plugin to create a distribution that LuisGomez can test
  2. UNASSIGNED
    1. Jozef to check bug 5328
    2. jbacigal will let know bug 4925 status the end of the week


People present (lines said)

  1. abhijitkumbhare (38)
  2. odl_meetbot (6)
  3. hideyuki (1)
  4. LuisGomez (1)


Generated by MeetBot 0.1.4.