#opendaylight-openflowplugin: OpenFlow Plugin Meeting July 14

Meeting started by abhijitkumbhare at 15:10:58 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 15:12:08)
    1. Jozef and Andrej’s assignment change away from OpenFlow Plugin (abhijitkumbhare, 15:12:45)
    2. M5 status (abhijitkumbhare, 15:14:50)
    3. Open & Critical Issues (abhijitkumbhare, 15:16:29)
    4. Continuous Integration Issues (abhijitkumbhare, 15:16:47)
    5. Features XML breaking (abhijitkumbhare, 15:17:46)

  2. Feature XML breaking (abhijitkumbhare, 15:18:24)
    1. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:FeatureTree (anleitne, 15:18:46)
    2. No longer an issue - since colindixon has fixed this (abhijitkumbhare, 15:18:54)
    3. Good practice - please announce major changes to the community so there is no impact like the one colindixon had to fix (abhijitkumbhare, 15:20:12)

  3. M5 status - code freeze (abhijitkumbhare, 15:20:32)
    1. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Boron_Release_Plan (abhijitkumbhare, 15:22:02)
    2. Major items - resolving backward compatibility; stabilizing the clustering; reconciliation improvements (abhijitkumbhare, 15:23:44)
    3. Backward compatibility - flow removed notification is now supported as per jbacigal (abhijitkumbhare, 15:28:36)
    4. Error notification? (abhijitkumbhare, 15:28:57)
    5. Node added notification? (abhijitkumbhare, 15:29:28)
    6. ACTION: jbacigal ManoharSL to check what is the status of error notification and node added notification (abhijitkumbhare, 15:32:03)
    7. Bertrand Low is taking care of bug 5582 - needs feedback from the community (abhijitkumbhare, 15:33:27)
    8. https://lists.opendaylight.org/pipermail/openflowplugin-dev/2016-July/005496.html - Bertand’s email that needs to be responded (abhijitkumbhare, 15:34:27)
    9. From Spec: For modify requests (OFPFC_MODIFY or OFPFC_MODIFY_STRICT), if a matching entry exists in the table, the instructions field of this entry is replaced with the value from the request, whereas its cookie, idle_timeout, hard_timeout, flags, counters and duration fields are left unchanged (ManoharSL, 15:40:18)

  4. Usability of OpenFlow Plugin - Anil (abhijitkumbhare, 15:41:41)
    1. Not clear for apps to know when exactly flow installation failed - needs to be improved (abhijitkumbhare, 15:42:46)

  5. Agenda for meetings next 2 weeks (abhijitkumbhare, 16:03:27)
    1. July 21 meeting - bug scrub / walk thru (abhijitkumbhare, 16:03:55)
    2. July 25-29 - code walk thru sessions on Li plugin design (abhijitkumbhare, 16:04:37)


Meeting ended at 16:04:56 UTC (full logs).

Action items

  1. jbacigal ManoharSL to check what is the status of error notification and node added notification


Action items, by person

  1. ManoharSL
    1. jbacigal ManoharSL to check what is the status of error notification and node added notification


People present (lines said)

  1. abhijitkumbhare (29)
  2. odl_meetbot (5)
  3. anleitne (1)
  4. ManoharSL (1)


Generated by MeetBot 0.1.4.