#opendaylight-openflowplugin: OpenFlow Plugin Meeting Jun 16

Meeting started by abhijitkumbhare at 15:05:26 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 15:05:56)
    1. Li migration changing default (abhijitkumbhare, 15:06:47)
    2. Flow removed notification (abhijitkumbhare, 15:07:20)
    3. Code reviews (abhijitkumbhare, 15:07:54)

  2. Flow removed notification (abhijitkumbhare, 15:09:15)
    1. Manohar says some use cases depend on flow removed notification (abhijitkumbhare, 15:10:51)
    2. Previously yang notifications were present in the He design (abhijitkumbhare, 15:11:30)
    3. Can be worked around in Li design - but it depends currently on the stats collection being present (abhijitkumbhare, 15:12:21)
    4. In general Manohar agrees with having data tree change - but for the short term need to have the yang notification on a config parameter (default no yang notification) (abhijitkumbhare, 15:14:30)
    5. In general need we need to give more thought on this - on how to solve this (abhijitkumbhare, 15:15:28)
    6. vishnoianil asks why yang notification for flow removed is a bad idea - currently we already have pkt in & some other yang notifications (abhijitkumbhare, 15:16:55)
    7. vishnoianil says some apps using RPCs for flow programming; it would be odd for them to listen for data change notification (abhijitkumbhare, 15:26:04)
    8. vishnoianil says that stats manager based approach can be performance intensive (abhijitkumbhare, 15:26:54)
    9. vishnoianil says muthu, shuva and he were discussing we should add a verifier mode - which does not need stats mgr for operational data store update (abhijitkumbhare, 15:28:48)
    10. jbacigal concerned about the performance of yang notification - and thinks it needs to be characterized (abhijitkumbhare, 15:30:49)
    11. vishnoianil thinks even if we are not going with yang notification - to update to the data store we will need to process the flow removed notification to update the data store (abhijitkumbhare, 15:34:14)
    12. vinayak & vishnoianil think that yang based notification would be higher performance (abhijitkumbhare, 15:36:59)
    13. ACTION: Manohar to summarize why we need the flow removed notifications; and the cons and send the email to the list on June 17 (abhijitkumbhare, 15:44:11)

  3. Li migration changing default (abhijitkumbhare, 15:44:38)
    1. abhijitkumbhare to send the weather report (abhijitkumbhare, 15:48:00)

  4. Code reviews (abhijitkumbhare, 15:48:38)
    1. https://git.opendaylight.org/gerrit/39102 (hideyuki, 15:51:24)
    2. https://git.opendaylight.org/gerrit/39524 (hideyuki, 15:51:30)
    3. https://git.opendaylight.org/gerrit/40429 (hideyuki, 15:51:35)
    4. some patches needing reviews as per hideyuki (abhijitkumbhare, 15:52:07)
    5. https://git.opendaylight.org/gerrit/#/c/36452/ (hideyuki, 15:52:07)
    6. https://git.opendaylight.org/gerrit/#/c/35359/ (hideyuki, 15:52:11)
    7. https://git.opendaylight.org/gerrit/39102 (abhijitkumbhare, 15:52:20)
    8. https://git.opendaylight.org/gerrit/39524 (abhijitkumbhare, 15:52:30)
    9. https://git.opendaylight.org/gerrit/40429 (abhijitkumbhare, 15:52:42)
    10. https://git.opendaylight.org/gerrit/#/c/36452/ (abhijitkumbhare, 15:52:58)
    11. https://git.opendaylight.org/gerrit/#/c/35359/ (abhijitkumbhare, 15:53:10)
    12. https://git.opendaylight.org/gerrit/#/c/40346/ (hideyuki, 15:54:13)
    13. https://git.opendaylight.org/gerrit/#/c/40181/ (hideyuki, 15:54:25)


Meeting ended at 16:00:20 UTC (full logs).

Action items

  1. Manohar to summarize why we need the flow removed notifications; and the cons and send the email to the list on June 17


People present (lines said)

  1. abhijitkumbhare (32)
  2. hideyuki (7)
  3. odl_meetbot (4)
  4. ManoharSL (2)


Generated by MeetBot 0.1.4.