#opendaylight-openflowplugin: OpenFlow Plugin Meeting March 21

Meeting started by abhijitkumbhare at 16:03:55 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 16:04:17)
    1. Weather Report for projects to change to new design (abhijitkumbhare, 16:05:03)
    2. Release plan (abhijitkumbhare, 16:05:47)
    3. Topology inventory model change (abhijitkumbhare, 16:06:21)
    4. Meeting day and time (abhijitkumbhare, 16:06:48)
    5. Issues (abhijitkumbhare, 16:07:26)

  2. Weather Report for projects to change to new design (abhijitkumbhare, 16:08:55)
    1. Temporary patch to test the new plugin for projects, email sent - no response yet (abhijitkumbhare, 16:10:04)
    2. Hideyuki-san testing with the new design for VTN (abhijitkumbhare, 16:12:05)
    3. Stats RPC and add-flow RPC (immediate barrier) discussions going on over the mailing lists (abhijitkumbhare, 16:13:21)
    4. Backward compatibility changes - notifications (abhijitkumbhare, 16:14:51)
    5. Michal’s changes: https://git.opendaylight.org/gerrit/#/q/project:openflowplugin+branch:master+topic:BUG-4117 (abhijitkumbhare, 16:15:21)
    6. Flow removed notification needed by the VTN project (abhijitkumbhare, 16:16:55)
    7. ACTION: jbacigal to discuss with michal_rehak how to handle the backward compatibility changes (abhijitkumbhare, 16:19:34)

  3. Release plan (abhijitkumbhare, 16:25:46)
    1. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Boron_Release_Plan Draft Boron Release Plan (abhijitkumbhare, 16:27:19)
    2. Suggested names to tasks (abhijitkumbhare, 16:29:26)
    3. New (Lithium) Design Migration - jbacigal (abhijitkumbhare, 16:29:46)
    4. Clustering Performance - Kamal Rameshan and jbacigal (abhijitkumbhare, 16:30:30)
    5. Inventory to Topology model migration - Anil Vishnoi? (abhijitkumbhare, 16:31:05)
    6. Flow Programmer / Table Resource Manager - Yi Yang (abhijitkumbhare, 16:32:19)
    7. Reconciliation Improvements - eshuvka_ Muthu ? (abhijitkumbhare, 16:33:58)
    8. Muthu is also thinking of pushing a test applications to OpenFlow Plugin samples / applications; Bulk-o-matic (abhijitkumbhare, 16:35:55)
    9. This is enhancement of bulk-o-matic (abhijitkumbhare, 16:36:22)
    10. Anna and jbacigal have a few tasks as bugs targetted - they are filed as enhancements with milestone as Boron (abhijitkumbhare, 16:44:35)

  4. Meeting day and time (abhijitkumbhare, 16:49:51)
    1. Checking other options (abhijitkumbhare, 16:56:24)

  5. Issues (abhijitkumbhare, 16:56:29)
    1. https://git.opendaylight.org/gerrit/#/c/36035/ (eshuvka_, 16:57:07)
    2. Available for review (abhijitkumbhare, 16:58:37)
    3. https://git.opendaylight.org/gerrit/#/c/36035/ (abhijitkumbhare, 16:58:49)


Meeting ended at 16:58:56 UTC (full logs).

Action items

  1. jbacigal to discuss with michal_rehak how to handle the backward compatibility changes


People present (lines said)

  1. abhijitkumbhare (36)
  2. odl_meetbot (4)
  3. eshuvka_ (1)
  4. LuisGomez (1)


Generated by MeetBot 0.1.4.