#opendaylight-openflowplugin: OpenFlow Plugin Meeting May 16, 2016

Meeting started by abhijitkumbhare at 16:02:04 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 16:03:14)
    1. M3 deliverables (abhijitkumbhare, 16:03:25)
    2. New FRM (abhijitkumbhare, 16:03:39)
    3. Stats RPC - bug 5692 (abhijitkumbhare, 16:04:24)
    4. API compatibility with the old (Helium) design (abhijitkumbhare, 16:05:05)
    5. Miscellaneous (abhijitkumbhare, 16:05:28)

  2. M3 deliverables (abhijitkumbhare, 16:05:39)
    1. API compatibility (abhijitkumbhare, 16:07:03)
    2. Bug 4117 was added for this (notifications) (abhijitkumbhare, 16:08:21)
    3. There were a set of unmerged patches https://git.opendaylight.org/gerrit/#/q/project:openflowplugin+branch:master+topic:BUG-4117 (abhijitkumbhare, 16:10:06)
    4. ACTION: eshuvka_ to take over these patches and merge them (abhijitkumbhare, 16:10:25)

  3. Swap the default plugin design (abhijitkumbhare, 16:14:33)
    1. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=251530127 Tracking spreadsheet (abhijitkumbhare, 16:15:18)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=5867 Blocking bug for NetVirt to migrate (abhijitkumbhare, 16:15:43)
    3. 5867 blocking for netvirt (abhijitkumbhare, 16:15:59)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=5873 Not blocking for NetVirt migration - but fix needed (abhijitkumbhare, 16:16:49)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=4671 - VTN raised bug (abhijitkumbhare, 16:21:29)
    6. hideyuki need send Barrier flag - vishnoianil points that michal_rehak had responded that the RPC is already present (abhijitkumbhare, 16:24:30)
    7. hideyuki says it will take some time to implement the send barrier RPC in VTN project (abhijitkumbhare, 16:24:56)
    8. ACTION: hideyuki will check how long it will take to implement the send barrier RPC in VTN project (abhijitkumbhare, 16:26:14)
    9. hideyuki wonders if the patch https://bugs.opendaylight.org/show_bug.cgi?id=5574 will solve the 4671 bug (abhijitkumbhare, 16:28:40)
    10. ACTION: hideyuki & jbacigal to figure if the patch https://bugs.opendaylight.org/show_bug.cgi?id=5574 is related to https://bugs.opendaylight.org/show_bug.cgi?id=4671 (abhijitkumbhare, 16:29:27)
    11. https://bugs.opendaylight.org/show_bug.cgi?id=5602 VTN raised bug - patch available from eshuvka_ (abhijitkumbhare, 16:33:57)
    12. ACTION: hideyuki to test out eshuvka_ patch (https://git.opendaylight.org/gerrit/#/c/38639) for bug 5602 (abhijitkumbhare, 16:35:04)
    13. ACTION: jbacigal & co. to test out https://bugs.opendaylight.org/show_bug.cgi?id=5867 locally (abhijitkumbhare, 16:37:57)

  4. New FRM (abhijitkumbhare, 16:39:41)
    1. anleitne going thru the new FRM ideas (abhijitkumbhare, 16:42:18)
    2. Important changes: (abhijitkumbhare, 16:43:12)
    3. 1) Sending only the diffs (abhijitkumbhare, 16:43:29)
    4. 2) Batching the RPCs (abhijitkumbhare, 16:43:41)
    5. These optimizations transparent to the user (abhijitkumbhare, 16:45:24)
    6. eshuvka_ how is group chaining handled? (abhijitkumbhare, 16:46:42)
    7. anleitne says currently futures chained (abhijitkumbhare, 16:47:06)
    8. eshuvka_ asks the performance implications when large amount of data has to be diff’ed - anleitne says will need to check (abhijitkumbhare, 16:49:48)
    9. New FRM will be merged - but will monitor how this works and if things are working then switch the FRM (abhijitkumbhare, 16:51:49)
    10. The old FRM currently will remain the default - but post test we will change if things are working (abhijitkumbhare, 16:52:30)
    11. LuisGomez asks how to test this? Is there an new RESTCONF? The answer is no - this is transparent to the user. (abhijitkumbhare, 16:54:47)
    12. jbacigal would like to brainstorm with LuisGomez about how this could be tested (abhijitkumbhare, 16:55:18)
    13. jbacigal & LuisGomez agree more tests would be good to have (abhijitkumbhare, 16:56:07)
    14. abhijitkumbhare asks eshuvka_ if bulk-o-matic can be used for testing this (abhijitkumbhare, 16:57:37)
    15. eshuvka_ says probably (abhijitkumbhare, 16:57:54)
    16. https://wiki.opendaylight.org/view/Weekly_Project_Meeting_List (abhijitkumbhare, 17:00:41)


Meeting ended at 17:00:53 UTC (full logs).

Action items

  1. eshuvka_ to take over these patches and merge them
  2. hideyuki will check how long it will take to implement the send barrier RPC in VTN project
  3. hideyuki & jbacigal to figure if the patch https://bugs.opendaylight.org/show_bug.cgi?id=5574 is related to https://bugs.opendaylight.org/show_bug.cgi?id=4671
  4. hideyuki to test out eshuvka_ patch (https://git.opendaylight.org/gerrit/#/c/38639) for bug 5602
  5. jbacigal & co. to test out https://bugs.opendaylight.org/show_bug.cgi?id=5867 locally


Action items, by person

  1. eshuvka_
    1. eshuvka_ to take over these patches and merge them
    2. hideyuki to test out eshuvka_ patch (https://git.opendaylight.org/gerrit/#/c/38639) for bug 5602
  2. hideyuki
    1. hideyuki will check how long it will take to implement the send barrier RPC in VTN project
    2. hideyuki & jbacigal to figure if the patch https://bugs.opendaylight.org/show_bug.cgi?id=5574 is related to https://bugs.opendaylight.org/show_bug.cgi?id=4671
    3. hideyuki to test out eshuvka_ patch (https://git.opendaylight.org/gerrit/#/c/38639) for bug 5602
  3. jbacigal
    1. hideyuki & jbacigal to figure if the patch https://bugs.opendaylight.org/show_bug.cgi?id=5574 is related to https://bugs.opendaylight.org/show_bug.cgi?id=4671
    2. jbacigal & co. to test out https://bugs.opendaylight.org/show_bug.cgi?id=5867 locally


People present (lines said)

  1. abhijitkumbhare (57)
  2. odl_meetbot (12)
  3. vishnoianil (3)
  4. eshuvka_ (1)
  5. hideyuki (1)
  6. jbacigal (0)


Generated by MeetBot 0.1.4.