#opendaylight-openflowplugin: OpenFlow Plugin Meeting Oct 20, 2016

Meeting started by shuva at 15:08:21 UTC (full logs).

Meeting summary

    1. miro working on bug 6917, fix ix already in place, luis to test and get back (shuva, 15:09:20)
    2. Anil was doing some internal testing 10 switches with 20 groups and 50 flows pointing to the groups (shuva, 15:10:33)
    3. it worked for 3-4 times and then stopped after sometime, stopped to collect group statistics (shuva, 15:11:11)
    4. hashwheel timertask killed due to Transaction not ready (shuva, 15:11:44)
    5. Anil to open a bug on this, (shuva, 15:12:01)
    6. there are more exceptions in the logs (shuva, 15:12:50)
    7. BUG6956, BUG6575 are also blockers (shuva, 15:15:52)
    8. 6575 Luis is in conversation with l2switch folks (shuva, 15:16:36)
    9. https://bugs.opendaylight.org/show_bug.cgi?id=6575 (abhijitkumbhare, 15:16:42)
    10. Luis feels its not impacting functionality and hence can be downgraded (shuva, 15:16:57)
    11. l2switch folks still investigating (shuva, 15:17:16)
    12. LuisGomez can be downgraded to critical (abhijitkumbhare, 15:17:31)
    13. https://bugs.opendaylight.org/show_bug.cgi?id=6956 (shuva, 15:18:32)
    14. jbacigal feels its a l2switch bug not ofplugin (shuva, 15:19:21)
    15. Blocker bug raised by Alexis (abhijitkumbhare, 15:19:30)
    16. adelathouet to put the bug into l2switch bucket (shuva, 15:19:59)
    17. LuisGomez thinks we need l2switch involvement for 6575, more logs and understanding of the application logic (shuva, 15:21:42)
    18. https://bugs.opendaylight.org/show_bug.cgi?id=6917 (abhijitkumbhare, 15:22:34)
    19. Miroslav pushing a patch for this (abhijitkumbhare, 15:23:00)
    20. LuisGomez ran Miro's patch 3ce, passed 1nce, but failed 2ce (shuva, 15:25:39)
    21. LuisGomez feels that the patch is in good direction. but not sure if that is a problem with the patch or something else (shuva, 15:26:49)
    22. LuisGomez working on new set of tests on longevity, soak testing (shuva, 15:27:35)
    23. Bulk-o-matic PoC & testing required on it (abhijitkumbhare, 15:28:50)
    24. Performance in 3-node cluster (abhijitkumbhare, 15:29:32)
    25. Split connection layer proposal (abhijitkumbhare, 15:30:02)
    26. Discussions about the current test methodology (abhijitkumbhare, 15:31:09)
    27. Tomas tried to reuse the OpenFlow Java model directly in the bulk-o-matic tests (abhijitkumbhare, 15:34:54)
    28. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Bulk-o-matic_enhancements (shuva, 15:35:19)
    29. LuisGomez suggests expose bulk-o-matic bulk API (abhijitkumbhare, 15:37:05)
    30. LuisGomez suggests it may be useful to expose some bulk-o-matic bulk API (abhijitkumbhare, 15:37:30)
    31. ACTION: Tomas to send the wiki about the bulk-o-matic test using OpenFlow Java model directly (abhijitkumbhare, 15:42:52)
    32. ACTION: Tomas to send to the mailing list the wiki about the bulk-o-matic test using OpenFlow Java model directly - and we can see if it can be run on the ODL infra (abhijitkumbhare, 15:43:34)
    33. jbacigal was asking about the current tests - whether the performance tests are single node or cluster (abhijitkumbhare, 15:44:49)
    34. LuisGomez says most are single node test performance tests (abhijitkumbhare, 15:45:18)
    35. LuisGomez thinks that scalability and longevity tests need to be moved to cluster (abhijitkumbhare, 15:46:07)
    36. Prasanna feels that fixing statistics on lI is better that fixing li (shuva, 15:51:39)
    37. Prasanna offers to go though the test cases in a meeting to see where we can do apples to apples comparison (shuva, 15:52:29)
    38. Prasanna to present li-plugin test-findings in about a week's time (shuva, 15:53:10)
    39. Prasanna feels that if it really becomes problematic, we need to take a call (shuva, 15:54:06)
    40. have a community call on monday to discuss the connection handling part (shuva, 16:06:05)


Meeting ended at 16:06:26 UTC (full logs).

Action items

  1. Tomas to send the wiki about the bulk-o-matic test using OpenFlow Java model directly
  2. Tomas to send to the mailing list the wiki about the bulk-o-matic test using OpenFlow Java model directly - and we can see if it can be run on the ODL infra


People present (lines said)

  1. shuva (29)
  2. abhijitkumbhare (24)
  3. odl_meetbot (4)


Generated by MeetBot 0.1.4.