#opendaylight-ovsdb: OSVSDB weekly call

Meeting started by colindixon at 19:06:20 UTC (full logs).

Meeting summary

  1. OpenStack CI (colindixon, 19:06:30)
    1. flaviof and mestery have gotten the Tempest tests running reliably (although with failures) (colindixon, 19:08:27)
    2. there are some issues where are intermitent and might be related to tomcat issues (colindixon, 19:09:09)
    3. shague asks if this will go away with Lithium as we move away from tomcat (colindixon, 19:09:49)
    4. edwarnicke says that there should be no tomcat in servicing the neutron API in Lithium and so that might help some (colindixon, 19:11:48)
    5. the higher-level question is how easy it is to go from tempest test failures to a root cause (colindixon, 19:14:55)
    6. https://jenkins.opendaylight.org/releng/view/ovsdb/job/ovsdb-openstack-gerrit/ this is the job that runs the openstack CI for the ODL plugin (colindixon, 19:17:15)
    7. https://jenkins.opendaylight.org/sandbox/job/flavio-ovsdb-openstack-gerrit/ sample of openstack job where we pull in today's Lithuim snapshot (flaviof, 19:23:19)
    8. ACTION: flaviof to work with colindixon to work on getting the job to run so that we can test Lithium and track how we’re making progress (colindixon, 19:25:05)
    9. mohnish will help flaviof with tempest testing (the first part is to get the tempest tests to run as part of pushing patches) (colindixon, 19:29:44)

  2. MD-SAL migration (colindixon, 19:29:48)
    1. the removing of AD-SALisms from the netvirt code is essentially done (colindixon, 19:30:02)
    2. we’re mostly done with the MD-SAL SB API for OVSDB (colindixon, 19:30:14)
    3. we still have the overlay model that needs implementation (colindixon, 19:30:53)
    4. https://trello.com/b/ctunVAEr/ovsdb-mdsal-southbound (shague, 19:35:24)
    5. people should keep things up-to-date in trello to help newcomers (colindixon, 20:00:39)
    6. if you’re working on something and there’s not a card for it, add the card (colindixon, 20:00:56)
    7. if you finish a card, move it to done (colindixon, 20:01:05)
    8. if you finish part of card, then write a comment or somehow track it (colindixon, 20:01:43)


Meeting ended at 00:31:37 UTC (full logs).

Action items

  1. flaviof to work with colindixon to work on getting the job to run so that we can test Lithium and track how we’re making progress


Action items, by person

  1. colindixon
    1. flaviof to work with colindixon to work on getting the job to run so that we can test Lithium and track how we’re making progress
  2. flaviof
    1. flaviof to work with colindixon to work on getting the job to run so that we can test Lithium and track how we’re making progress


People present (lines said)

  1. colindixon (26)
  2. tbachman (14)
  3. mohnish (8)
  4. regXboi (7)
  5. odp-gerritbot (5)
  6. odl_meetbot (4)
  7. shague (3)
  8. flaviof (2)
  9. mestery (1)


Generated by MeetBot 0.1.4.