#opendaylight-ovsdb: ovsdb_weekly_call
Meeting started by tbachman at 20:01:11 UTC
(full logs).
Meeting summary
- agenda (tbachman, 20:01:32)
  - https://meetings.opendaylight.org/opendaylight-ovsdb/2014/ovsdb_weekly_call/opendaylight-ovsdb-ovsdb_weekly_call.2014-12-09-20.10.html
    Last meeting that had minutes (the previous meeting didn’t have
    minutes) (tbachman,
    20:02:08)
- shague says they’re trying to figure out if
    there are any gaps in what’s supported with neutron and
    OpenStack (tbachman,
    20:13:07)
- going thru L2/L3 to see what’s missing, then
    will move on to services (tbachman,
    20:13:21)
- L2 looks mostly good (tbachman,
    20:13:36)
- shague_ says that mestery and flaviof are
    pulling stuff out of neutron into stackforge (tbachman,
    20:13:56)
- shague_ wants to wait for mestery on this, as
    he has all the relevant status (tbachman,
    20:14:24)
- https://trello.com/b/ddIvDQE0/ovs-openstack
    link to OVSDB Trello Board (tbachman,
    20:15:07)
- shague_ says they’re looking into what it takes
    to move OVSDB to MD-SAL (tbachman,
    20:15:29)
- shague_ says there are a bunch of AD-SAL
    dependencies (tbachman,
    20:15:47)
- srini084 says that on the AD-SAL side, their
    netvirt uses AD-SAL OVSDB; srini asks how many projects are using
    the AD-SAL OVSDB? (tbachman,
    20:16:42)
- edwarnicke says he can find this answer
    (tbachman,
    20:16:49)
- shague_ says there are various components in
    OVSDB that need to be converted, the biggest being the plugin, which
    has a lot of AD-SAL dependencies (tbachman,
    20:17:15)
- edwarnicke says that it’s a big problem, b/c
    pulling in the AD-SAL pieces affects the performance of the
    controller (tbachman,
    20:18:33)
- shague_ says they’re going through the
    components over the next couple of weeks to see what it would take
    to remove some of those dependencies (tbachman,
    20:18:55)
- edwarnicke says that the projects using the
    AD-SAL plugin for OVSDB, he found (via grepping pom files), it’s
    VTN, Toolkit, OVSDB netvirt (tbachman,
    20:19:51)
- srini084 says they’ll have a conversation with
    the VTN project (tbachman,
    20:20:17)
- shague_ says that the MD-SAL adapter is only
    there to populate the MD-SAL with the OVSDB node (tbachman,
    20:22:26)
- shague_ says that converting all the DB stuff
    over would take quite a bit of work (tbachman,
    20:22:41)
- edwarnicke asks if the MD-SAL is just a
    read-only adapter (tbachman,
    20:23:01)
- srini084 says it looks like a read-only
    adapter (tbachman,
    20:23:11)
- shague_ says the adapter was written by
    dave_tucker, so that you could query the MD-SAL to find all the
    OVSDB nodes (tbachman,
    20:23:47)
- paulq_ asks if you can only query (tbachman,
    20:23:57)
- shague_ says that yes, it’s only for
    queries (tbachman,
    20:24:05)
- edwarnicke asks what kinds of things aren’t
    doable (tbachman,
    20:25:14)
- shague_ says everything — projects that want to
    query bridges, ports, interfaces, etc. these are all columns in the
    DB (tbachman,
    20:25:35)
- srini084 says that the columns are already
    predefined, and each info you insert can be a pointer to another
    table (tbachman,
    20:25:59)
- edwarnicke asks that in order to find a way
    forward, is there a way to get the 80% of what we need (tbachman,
    20:29:38)
- shague_ says that to go to MD-SAL, you have to
    go to a model, but they have this data stored internally; there’s a
    difference between creating an adapter on top of this, and moving
    all this to an MD-SAL model (tbachman,
    20:30:35)
- edwarnicke says he wonders if we need to
    migrate all of the data to the MD-SAL, or just the pieces that we
    need. (tbachman,
    20:31:16)
- srini084 says the bridge and the port were all
    that they were really using (tbachman,
    20:31:50)
- paulq_ says tunnel is a form of port and
    attributes of that (e.g. interfaces, tags, etc.) (tbachman,
    20:32:05)
- shague_ agrees it’s a smaller subset, but the
    problem is overall state management (tbachman,
    20:32:39)
- shague_ says port/bridge/controller are
    probably the main things that are important (tbachman,
    20:34:15)
- alagalah asks about QOS, etc. (tbachman,
    20:34:27)
- shague_ says that SFC probably doesn’t care
    about those, but he can see how GBP might (tbachman,
    20:34:41)
- alagalah says that anything in the data path,
    GBP may want to have CRUD access (tbachman,
    20:34:59)
- edwarnicke says he’d like to understand the
    timing of when things are needed, as that can affect what gets
    prioritized (tbachman,
    20:35:21)
- alagalah says if it’s a choice, he agrees it
    would be the three that shague_  mentioned (tbachman,
    20:35:55)
- edwarnicke says that the place he’d worry is
    how state works in a clustered environment (tbachman,
    20:37:34)
- paulq_ says they want a clear API that maps to
    service chain ops (build tunnel with following attributes,
    etc.) (tbachman,
    20:40:11)
- shague_ says that’s consistent with his
    understanding, and says that interface exists, but it’s an AD-SAL
    implementation (tbachman,
    20:40:38)
- paulq_ asks if there’s a place to look at this
    API, or do we have to look at the code (tbachman,
    20:40:51)
- shague_ says you kind of have to look at the
    code. VTN might be a good project to look at (tbachman,
    20:41:07)
- shague_ says you just insert rows into the
    schema tables to create things (tbachman,
    20:41:23)
- paulq_ asks if this assumes there’s something
    that renders this into the appropriate OVSDB info (tbachman,
    20:41:40)
- shague_  the question of MD-SAL is how quickly
    we can get this done (e.g. how can this work be done in time for the
    Li release)? (tbachman,
    20:45:33)
- shague_ asks if the project has to be full
    MD-SAL in order to support clustering (tbachman,
    20:46:09)
- those are questions we’d want answers to in
    order to schedule it all (tbachman,
    20:46:28)
- shague_ asks alagalah how important clustering
    support is to GBP (tbachman,
    20:46:57)
- alagalah says it’s not so much clustering, but
    it will become important (tbachman,
    20:47:39)
- alagalah says it’s more about getting the
    ability to do CRUD operations (tbachman,
    20:47:55)
- edwarnicke says projects have had issues when
    they keep certain local state (e.g. local hash-maps) (tbachman,
    20:49:20)
- shague_ says you can do all these CRUD
    operations today, as VTN uses it… just not MD-SAL (tbachman,
    20:50:01)
- paulq_ says they’d prefer not to drag AD-SAL
    along with SFC (tbachman,
    20:50:28)
- shague_ says it’s one thing to have the
    mirroring piece for the 3 tables; but all the stuff in hash maps
    that not in the MD-SAL is a lot (tbachman,
    20:51:30)
- edwarnicke asks what happens if more than one
    controller node talks to the OVSDB server (tbachman,
    20:56:57)
- shague_ says you’d have multiple managers
    writing to the database, and updates are reported up to the
    controllers (tbachman,
    20:57:13)
- https://lists.opendaylight.org/pipermail/discuss/2014-December/004153.html
    (paulq_,
    20:57:19)
- edwarnicke says that with the mirroring
    approach, they would probably be okay (tbachman,
    20:57:28)
- https://lists.opendaylight.org/pipermail/discuss/2014-December/004153.html
    email thread talking about MD-SAL (tbachman,
    21:02:57)
- edwarnicke says there’s also a question to
    separate out the netvirt pieces as well (tbachman,
    21:03:19)
- shague_  says that’s a whole different
    issue (tbachman,
    21:03:32)
- alagalah says that GBP would also prefer not to
    pull in the whole AD-SAL stuff (tbachman,
    21:03:46)
- shague_ says that’s the long-term goal, but
    more of a question on how to get there (tbachman,
    21:03:56)
- alagalah asks if there’s a postman collection
    to become familiar with the V3 APIs (tbachman,
    21:04:15)
- shague_ says that’s the NB v3 API, but the CRUD
    operations don’t have a good document (tbachman,
    21:04:45)
- shague_ says he’ll find some good code to point
    alagalah to for CRUD operations (tbachman,
    21:05:02)
- alagalah says it’s easy to start with something
    like the REST APIs to learn about what can be done (tbachman,
    21:05:34)
- shague_ says there’s a gdoc that shows the APIs
    from the V3 stuff (tbachman,
    21:05:45)
- shague_ says he thinks there are also postman
    scripts checked in to resources dir (tbachman,
    21:06:05)
- ACTION: shague_ to
    capture what was said and try to work on a plan on how to get these
    pieces done (tbachman,
    21:06:48)
- shague_ asks if  resource that edwarnicke
    mentioned can reach out to shague_ (tbachman,
    21:07:18)
- edwarnicke to talk to the person to reach
    out (tbachman,
    21:07:34)
- alagalah asks about the email from colin_dixon
    re: MD-SAL and OVSDB (tbachman,
    21:07:51)
- edwarnicke says that we’re trying to work out
    times, and notes that the OVSDB meeting time is tough for Europe and
    Asia (tbachman,
    21:08:10)
- regXboi says you’d need to walk through the
    deprecation process in order get this done in time for the Boron
    release (tbachman,
    21:10:17)
- edwarnicke says that he believes that ghall was
    interested in moving to an MD-SAL ML2 mechanism driver (tbachman,
    21:11:00)
- regXboi says that the code reference in the
    email does that, which he feels is a bad idea (tbachman,
    21:11:19)
 
Meeting ended at 21:12:13 UTC
(full logs).
Action items
  - shague_ to capture what was said and try to work on a plan on how to get these pieces done
People present (lines said)
  - tbachman (94)
- odl_meetbot (4)
- shague (3)
- alagalah (2)
- mestery (1)
- Swami (1)
- paulq_ (1)
Generated by MeetBot 0.1.4.