#opendaylight-ovsdb: ovsdb_weekly_call

Meeting started by tbachman at 20:00:11 UTC (full logs).

Meeting summary

  1. Agenda (tbachman, 20:00:24)
    1. https://meetings.opendaylight.org/opendaylight-ovsdb/2015/ovsdb_weekly_call/opendaylight-ovsdb-ovsdb_weekly_call.2015-01-20-20.00.html Minutes from last week’s meeting (tbachman, 20:00:34)
    2. It's my birthday today (mestery, 20:02:08)
    3. shague suggests the "50 Cent" version of "It's Your Birthday" for mestery's song. (mestery, 20:04:04)

  2. trello board (tbachman, 20:06:11)
    1. shague finished getting all the IT tests into the integration directory (tbachman, 20:06:52)
    2. shague and edwarnicke have been coordinating on getting neutron into it’s own MD-SAL piece (tbachman, 20:07:15)
    3. plaurin_ has finished porting of L3 services, and is now working on creating the UT for the services (tbachman, 20:07:51)
    4. mestery is hoping that Swami can set up a call to go over the testing (tbachman, 20:08:12)
    5. ACTION: Swami to set up a call to go over UT, possibly on Friday (tbachman, 20:08:30)
    6. DPDK integration with Eric Multanen, Sharad, and edwarnicke is ongoing — working on the models (tbachman, 20:09:03)
    7. Eric asks if the capability to support DPDK ports is going to be in the stackforge effort (tbachman, 20:10:10)
    8. shague says that the OVS L2 agent is what’s talking to OVSDB — the agent is being replaced by ODL integration (tbachman, 20:10:42)
    9. mestery says that ODL is effectively doing the work that the agent was doing (tbachman, 20:11:02)
    10. mestery says that before the kilo release, the entire plugin was upstream in neutron, and did contain back-end logic to talk to ODL. As part of the decomposition in neutron, there will be a super-thin plugin that pulls in the stackforge project (tbachman, 20:11:41)
    11. Eric asks where the openstack folks are going to get the DPDK port information (tbachman, 20:12:08)
    12. shague says there are some neutron calls that talk to the OVS agent, which goes back into nova so it can use DPDK ports; since the L2 agent isn’t there any more, where would that belong/go with ODL? (tbachman, 20:12:47)
    13. Eric says that they want to know if the given host and bridge can support a DPDK port type, so that nova can go and spawn that VM (tbachman, 20:13:30)
    14. mestery says those VIFs are created by Nova (tbachman, 20:14:08)
    15. mestery asks if this can be as simple as a check of OVS versions? (tbachman, 20:14:24)
    16. shague says he doesn’t think the version matters, b/c when the VIF gets spun up, they need to query to see if it is a DPDK supported port; shague thinks blp added some support to bridge tables to indicate this (tbachman, 20:15:36)
    17. mestery says this would have to be exposed in ODL (tbachman, 20:15:53)
    18. mestery asks who’s doing this query (tbachman, 20:15:58)
    19. shague says it’s in openstack - they come down thru neutron L2 agent (tbachman, 20:16:14)
    20. mestery says that even if we put the data in the database, that’s not going to work (tbachman, 20:16:28)
    21. shague asks if the ODL stackforge stuff can address this (tbachman, 20:16:36)
    22. mestery says we might have to expose those details as part of the port binding (tbachman, 20:16:51)
    23. mestery says that requires some coordination in the back-end ODL side, as the ML2 driver doesn’t have anything running on the host (tbachman, 20:17:08)

  3. stackforge efforts (tbachman, 20:17:43)
    1. recording started 20-minutes into the meeting (tbachman, 20:20:29)
    2. as part of the kilo development work, blueprint was approved where all of the plugins and drivers are going through the decomposition process (tbachman, 20:21:04)
    3. there was a lot of code in neutron dealing with proprietary or opensource backends, where reviewers didn’t understand the backends (tbachman, 20:21:24)
    4. https://launchpad.net/networking-odl "OpenDaylight backend controller integration with Neutron" (flaviof, 20:21:25)
    5. there are over 25 plugins and drivers in neutrons, and only 14 reviewers (tbachman, 20:21:39)
    6. The result is that everyone can have a thin shim in neutron which is a pass thru (tbachman, 20:21:55)
    7. the back-ends can live in stackforge, github, etc., and can iterate much faster (tbachman, 20:22:17)
    8. there are still CI requirements on the backends (tbachman, 20:22:25)
    9. The ODL mechanism driver is the first to be fully decomposed upstream (tbachman, 20:22:36)
    10. https://github.com/stackforge/networking-odl Stackforge ODL project (tbachman, 20:23:59)
    11. Users will be able to use pip to install, or setup.py to install locally as well (tbachman, 20:24:28)
    12. https://review.openstack.org/gitweb?p=stackforge/networking-odl.git networking-odl gerrit (flaviof, 20:24:43)
    13. mestery says there’s been a good confluence of people who are new to either OpenStack or OpenDaylight that have been jumping in (tbachman, 20:25:37)
    14. Swami, plaurin_, et. al. have joined in the development (tbachman, 20:26:09)
    15. mestery says that once this infra is in place, the tempest testing can be addressed (tbachman, 20:26:59)
    16. mestery filed a bunch of bugs on them, some of which are hard to replicate (tbachman, 20:27:10)
    17. flaviof says ODL also has an effort to take neutron out of the controller, which will isolate it and help with other efforts (tbachman, 20:28:21)
    18. mestery says that CI is pretty hosed at the moment, but it didn’t make sense to work on CI until the stackforge stuff was set up (tbachman, 20:28:50)
    19. mestery and colindixon says that a small, focused, sprint can happen via hangout/bluejeans/!webex (tbachman, 20:29:24)
    20. edwarnicke asks if this is connected with the ODL integration team (tbachman, 20:29:40)
    21. edwarnicke says that’s the right place for the CI to live, as that’s the thing that always gets checked for every bug fix release (tbachman, 20:30:01)
    22. vishnoianil_ says there’s a plan to integration neutron to the integration team (tbachman, 20:30:24)
    23. mestery says he’d like to move the jenkins config into Jenkins Job Builder as well (tbachman, 20:30:40)
    24. mestery says he doesn’t think the neutron tempest ever ran against the jobs on the OVSDB side (tbachman, 20:31:01)
    25. edwarnicke asks where integration stands on migrating their jobs into Jenkins Job Builder (tbachman, 20:31:15)
    26. shague says moving their stuff into JJB is kind of hard; wonders if integration doing this will help out here (tbachman, 20:31:47)
    27. edwarnicke says he knows this is a high priority for the integration group (tbachman, 20:32:01)
    28. flaviof asks if ovsdb needs a CI in openstack that doesn’t use OVS, would that be better when the neutron has moved out of the controller (tbachman, 20:33:56)
    29. edwarnicke says all the providers would live downstream; everything meets in the integration project, which makes it the optimal place to do this stuff (tbachman, 20:34:14)
    30. flaviof says there are a lot of hooks into OVS, and isn’t sure how much of that could be “faked out" (tbachman, 20:34:35)
    31. colindixon says the distribution selected could run the respective tests against that distribution; that could be part of the hack-fest work (tbachman, 20:35:10)
    32. mestery says he feels these jobs need to live in OVSDB; configuring things like VTN and OpenDove is outside the scope of what we’d want to do (tbachman, 20:36:04)
    33. colindixon says we shouldn’t take on resposibility for that as part of the OVSDB project (tbachman, 20:36:17)
    34. edwarnicke says the multiple implementations of neutron stuff makes it more efficient to have this in integration (tbachman, 20:36:50)
    35. flaviof asks how agnostic tempest is of OVS (tbachman, 20:37:33)
    36. mestery says it’s pretty agnostic; however, things have to be configured for ODL; if OpenDove and VTN folks need to drive this testing, they’d have to provide this configuration (tbachman, 20:38:05)
    37. mestery says right now they’re pulling released versions of ODL; the matrix gets complex quickly, which is one reason for just using released versions (tbachman, 20:38:38)
    38. mestery wants to make sure the upstream openstack CI stuff is in OVSDB (tbachman, 20:39:11)


Meeting ended at 20:41:28 UTC (full logs).

Action items

  1. Swami to set up a call to go over UT, possibly on Friday


People present (lines said)

  1. tbachman (86)
  2. mestery (11)
  3. odl_meetbot (5)
  4. flaviof (3)
  5. shague (2)
  6. plaurin_ (1)
  7. colindixon (1)
  8. abhijitkumbhare (1)


Generated by MeetBot 0.1.4.