#opendaylight-ovsdb: Netvirt Weekly 2/14/17

Meeting started by shague at 16:01:29 UTC (full logs).

Meeting summary

    1. shague (shague, 16:01:34)
    2. Everyone please #info in (shague, 16:01:50)
    3. vthapar (vthapar, 16:01:52)
    4. alonko (alonko, 16:02:04)
    5. vpickard (vpickard, 16:03:11)
    6. jamoluhrsen (jamoluhrsen, 16:03:19)
    7. (mattw4, 16:03:34)
    8. aswinsuryan (aswinsuryan, 16:03:37)
    9. Marcus Williams (mgkwill, 16:03:43)
    10. Andre Fredette (afredette, 16:03:45)
    11. Matt Welch (mattw4, 16:03:50)

  1. previous actions (shague, 16:04:06)
    1. daya was have network connection issues, dialed into last mtg (vpickard, 16:04:52)
    2. ACTION: daya, yamahata: come up with spec for dhcp port (shague, 16:05:20)
    3. action review the current csit, find where coverage is lacking (shague, 16:06:16)
    4. openflowplugin patch causing problems (shague, 16:06:31)
    5. thsi patch is breaking csit: https://git.opendaylight.org/gerrit/#/c/50153 (shague, 16:08:01)
    6. revert is in https://git.opendaylight.org/gerrit/#/c/51814 (shague, 16:08:18)
    7. Sridhar Gaddam (sridharg, 16:08:19)
    8. ACTION: shague folowup with anil on openflowplugin patches (shague, 16:09:59)
    9. ACTION: jamoluhrsen to add bocking bug (shague, 16:10:47)
    10. ACTION: : alonko daya_k vthapar shague start list of test overage (shague, 16:11:04)
    11. vivek has a test lead in team that cna review test coverage (shague, 16:13:01)
    12. vthapar: asks about coverage for different config options (shague, 16:13:59)
    13. need to add tests for different configs (shague, 16:14:21)
    14. ACTION: vthapar to compile list of current configuration flags (vthapar, 16:14:45)

  2. compile csit test list (shague, 16:15:10)
    1. ACTION: alonko, shague vivek vthapar : after adding csit test list work on adding new tests (shague, 16:17:42)
    2. ACTION: alonko, shague work with vivek on adding sandbox setuo (shague, 16:18:43)

  3. action tomer to contact vivek about pnf spec (shague, 16:20:02)
    1. vivek reviewed pnf spec, waiting on next review (shague, 16:20:35)

  4. : jamoluhrsen look at quick scaling tests (shague, 16:21:04)
    1. jamoluhrsen no progress yet (shague, 16:21:29)
    2. mgkwill, mattw4: info on scale tests (shague, 16:22:12)
    3. current setup uses docker containers (shague, 16:26:27)
    4. current to make this consumable upstream and increase scale to 500 nodes (shague, 16:29:01)
    5. https://github.com/matt-welch/docker-devstack (shague, 16:29:54)
    6. extend setup to add quagga (shague, 16:30:30)
    7. IDEA: everyone add notes as needed (shague, 16:38:03)
    8. try to add scale setup to csit (shague, 16:39:45)
    9. S3P working on docker environment, loading devstack computes for scale testing (alonko, 16:40:19)
    10. https://github.com/dileepranganathan/ODLRallyPlugin (alonko, 16:40:24)
    11. Ideally, we could run it on a regular basis to track whether functional changes affect scale and performance (afredette, 16:40:26)
    12. https://github.com/matt-welch/docker-devstack (alonko, 16:41:06)
    13. ACTION: mgkwill connect with trozet about the opnfv snapshots (shague, 16:41:15)
    14. mgkwill says this would be good to find home in opnfv cperf (shague, 16:42:35)

  5. shague check with trozet on opnfv scale testing and someone to find out what/how/where for rally (shague, 16:43:23)
    1. jamoluhrsen thinks current work doesn;t apply (shague, 16:44:03)
    2. https://jira.opnfv.org/browse/CPERF-5 (mgkwill, 16:44:17)

  6. get peri +1 for parentRef specs (shague, 16:44:19)
    1. gerrits merged, looking good. (shague, 16:44:47)
    2. some bfd tests with auto tunnels have problems (shague, 16:44:58)
    3. ACTION: alonko still looking at failures (shague, 16:45:44)

  7. : (shague, 16:46:07)
  8. vthapar to merge genius and netvirt patches (shague, 16:46:12)
    1. : many waiting on OpenStack Summit CFP's getting accepted (shague, 16:48:53)

  9. Roll call for OpenStack summit 5/8/17-5/11/17 and ODL DDF 5/31 (shague, 16:49:25)
    1. HPE and E/// leaning more towards DDF, soem might go to Os if CFP's accepted (shague, 16:50:48)
    2. most likely will go to OpenStack Summit. would likely go to DDF if there is good turn-out (afredette, 16:51:08)
    3. above comment was about /me (afredette, 16:51:27)

  10. genius DataChange deprecations (shague, 16:52:12)
    1. mdsal has deprecated DatachangeListener but genius /netvirt still uses them (shague, 16:53:11)
    2. there are performance issues (shague, 16:53:40)
    3. ACTION: vthapar and faseela to add patches for removing the depracted code and replace with asyncdatatree (shague, 16:54:58)
    4. weather page has been created (shague, 16:55:05)
    5. ACTION: vhtapar and faseela to present datajob and other improvements in next meeting (shague, 16:56:41)
    6. https://wiki.opendaylight.org/view/Weather#Genius_AbstractDataChangeListener_clean-up (vthapar, 16:57:17)

  11. specs (shague, 16:57:38)
    1. ACTION: Daya to add netvirt spec for dhcp changes, there are pipeline updates (shague, 16:58:32)
    2. most specs are ready for next round of reviews: vni, bgp, counters and statictics (shague, 17:00:04)
    3. also review evpn rt2 and multiple vxlan specs, qos-alerts (shague, 17:01:00)

  12. Hairpinning patches, VXLAN VNI patches (shague, 17:02:34)
    1. pacthes are ready, need to be reviewed (shague, 17:03:12)
    2. ACTION: vivek to review patches laster this week (shague, 17:03:42)


Meeting ended at 17:05:30 UTC (full logs).

Action items

  1. daya, yamahata: come up with spec for dhcp port
  2. shague folowup with anil on openflowplugin patches
  3. jamoluhrsen to add bocking bug
  4. : alonko daya_k vthapar shague start list of test overage
  5. vthapar to compile list of current configuration flags
  6. alonko, shague vivek vthapar : after adding csit test list work on adding new tests
  7. alonko, shague work with vivek on adding sandbox setuo
  8. mgkwill connect with trozet about the opnfv snapshots
  9. alonko still looking at failures
  10. vthapar and faseela to add patches for removing the depracted code and replace with asyncdatatree
  11. vhtapar and faseela to present datajob and other improvements in next meeting
  12. Daya to add netvirt spec for dhcp changes, there are pipeline updates
  13. vivek to review patches laster this week


Action items, by person

  1. alonko
    1. : alonko daya_k vthapar shague start list of test overage
    2. alonko, shague vivek vthapar : after adding csit test list work on adding new tests
    3. alonko, shague work with vivek on adding sandbox setuo
    4. alonko still looking at failures
  2. jamoluhrsen
    1. jamoluhrsen to add bocking bug
  3. mgkwill
    1. mgkwill connect with trozet about the opnfv snapshots
  4. shague
    1. shague folowup with anil on openflowplugin patches
    2. : alonko daya_k vthapar shague start list of test overage
    3. alonko, shague vivek vthapar : after adding csit test list work on adding new tests
    4. alonko, shague work with vivek on adding sandbox setuo
  5. trozet
    1. mgkwill connect with trozet about the opnfv snapshots
  6. vthapar
    1. : alonko daya_k vthapar shague start list of test overage
    2. vthapar to compile list of current configuration flags
    3. alonko, shague vivek vthapar : after adding csit test list work on adding new tests
    4. vthapar and faseela to add patches for removing the depracted code and replace with asyncdatatree
  7. UNASSIGNED
    1. daya, yamahata: come up with spec for dhcp port
    2. vhtapar and faseela to present datajob and other improvements in next meeting
    3. Daya to add netvirt spec for dhcp changes, there are pipeline updates
    4. vivek to review patches laster this week


People present (lines said)

  1. shague (58)
  2. mgkwill (4)
  3. alonko (4)
  4. afredette (4)
  5. vthapar (3)
  6. odl_meetbot (3)
  7. mattw4 (3)
  8. vpickard (2)
  9. jamoluhrsen (2)
  10. odp-gerritbot (2)
  11. trozet (2)
  12. aswinsuryan (1)
  13. sridharg (1)


Generated by MeetBot 0.1.4.