#opendaylight-ovsdb: NetVirt Weekly 2/21/17

Meeting started by shague at 16:01:44 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 16:01:53)
  2. Review existing action items (shague, 16:02:12)
    1. skitt (skitt, 16:05:14)
    2. Anil Vishnoi (vishnoianil, 16:05:15)
    3. Victor Pickard (vpickard, 16:05:20)
    4. Alon Kochba (alonko, 16:05:42)
    5. Matt Welch (mattw4, 16:06:12)

  3. switch to #opendaylight-netvirt (shague, 16:06:16)
    1. Aswin Suryanarayanan (aswinsuryan, 16:06:16)
    2. switch to opendaylight-netvirt going forward (shague, 16:06:47)
    3. Sridhar Gaddam (sridharg, 16:07:13)
    4. daya, yamahata: come up with spec for dhcp port (shague, 16:07:23)
    5. ACTION: daya, peri to write spec end of week (shague, 16:08:02)
    6. [DONE} shague folowup with anil on openflowplugin patches (shague, 16:08:30)
    7. [DONE] jamoluhrsen to add bocking bug (shague, 16:08:45)
    8. alonko daya_k vthapar shague start list of test overage (shague, 16:09:02)
    9. ACTION: alonko daya_k vthapar shague start list of test coverage (shague, 16:09:11)
    10. ACTION: : shague start a thread on the test coverage (shague, 16:09:31)
    11. ACTION: vthapar to compile list of current configuration flags (shague, 16:09:52)
    12. alonko, shague vivek vthapar : after adding csit test list work on adding new tests (shague, 16:10:16)
    13. ACTION: alonko, shague vivek vthapar : after adding csit test list work on adding new tests (shague, 16:10:35)
    14. ACTION: : alonko, shague work with vivek on adding sandbox setup, send docs to vivek (shague, 16:11:26)
    15. vthapar and faseela to add patches for removing the depracted code and replace with asyncdatatree (shague, 16:11:44)
    16. [DONE] vthapar and faseela to add patches for removing the depracted code and replace with asyncdatatree (shague, 16:12:09)
    17. [DONE] vhtapar and faseela to present datajob and other improvements in next meeting (shague, 16:12:39)
    18. patches are raised and need to be reviewed (shague, 16:13:01)
    19. Daya to add netvirt spec for dhcp changes, there are pipeline updates (shague, 16:13:15)
    20. [DONE] vivek to review patches laster this week (shague, 16:13:47)

  4. M4 - 3/2/17 - API Spec freeze (shague, 16:14:33)
    1. alonko: DHCP spec review (shague, 16:18:07)

  5. DHCP server spec (shague, 16:20:25)
    1. does ipv6 work also (shague, 16:20:35)
    2. ACTION: check if proposed DHCP server allocation works for IPv6, and also if we are adding neutron IPv6 port support (alonko, 16:20:46)

  6. SFC spec (shague, 16:21:20)
    1. spec to provide high-level design (shague, 16:21:43)
    2. need help from others to implement (shague, 16:21:52)
    3. vishnoianil networking-sfc v2 driver has been merged (shague, 16:23:33)
    4. https://review.openstack.org/#/c/389081/ (vishnoianil, 16:25:43)
    5. sfc translator code can be moved to new netvirt (shague, 16:25:46)

  7. csit:exceptions (shague, 16:30:12)
    1. : https://trello.com/c/OynhbCPa/133-csit-exceptions-in-logs (shague, 16:30:17)
    2. patches will be out for review (shague, 16:32:13)
    3. ACTION: run in sandbox with fail on exception, see what happens (alonko, 16:33:57)

  8. : when to switch to ocata? (shague, 16:37:09)
    1. alonko: ocata needed for coe csit (shague, 16:37:42)
    2. : ocata has deprecated some apis and fails tests (shague, 16:38:09)
    3. : vivek: mitaka is default and needs to be supported (shague, 16:40:19)
    4. : alonk thinks maybe the reclone workarounds might fix the mitaka jobs (shague, 16:41:31)
    5. ACTION: : jamoluhrsen to talk with venkat about reclone (shague, 16:41:49)
    6. ACTION: : shague make sure there is a mitaka gate job (shague, 16:43:34)
    7. mitaka gate job exists with stateful (alonko, 16:44:26)
    8. ACTION: : [DONE] shague make sure there is a mitaka gate job - job already exists (shague, 16:45:32)


Meeting ended at 16:45:41 UTC (full logs).

Action items

  1. daya, peri to write spec end of week
  2. alonko daya_k vthapar shague start list of test coverage
  3. : shague start a thread on the test coverage
  4. vthapar to compile list of current configuration flags
  5. alonko, shague vivek vthapar : after adding csit test list work on adding new tests
  6. : alonko, shague work with vivek on adding sandbox setup, send docs to vivek
  7. check if proposed DHCP server allocation works for IPv6, and also if we are adding neutron IPv6 port support
  8. run in sandbox with fail on exception, see what happens
  9. : jamoluhrsen to talk with venkat about reclone
  10. : shague make sure there is a mitaka gate job
  11. : [DONE] shague make sure there is a mitaka gate job - job already exists


Action items, by person

  1. alonko
    1. alonko daya_k vthapar shague start list of test coverage
    2. alonko, shague vivek vthapar : after adding csit test list work on adding new tests
    3. : alonko, shague work with vivek on adding sandbox setup, send docs to vivek
  2. jamoluhrsen
    1. : jamoluhrsen to talk with venkat about reclone
  3. shague
    1. alonko daya_k vthapar shague start list of test coverage
    2. : shague start a thread on the test coverage
    3. alonko, shague vivek vthapar : after adding csit test list work on adding new tests
    4. : alonko, shague work with vivek on adding sandbox setup, send docs to vivek
    5. : shague make sure there is a mitaka gate job
    6. : [DONE] shague make sure there is a mitaka gate job - job already exists
  4. UNASSIGNED
    1. daya, peri to write spec end of week
    2. vthapar to compile list of current configuration flags
    3. check if proposed DHCP server allocation works for IPv6, and also if we are adding neutron IPv6 port support
    4. run in sandbox with fail on exception, see what happens


People present (lines said)

  1. shague (44)
  2. odp-gerritbot (7)
  3. alonko (4)
  4. odl_meetbot (3)
  5. jamoluhrsen (3)
  6. vishnoianil (2)
  7. vpickard (1)
  8. sridharg (1)
  9. skitt (1)
  10. aswinsuryan (1)
  11. mattw4 (1)


Generated by MeetBot 0.1.4.