#opendaylight-ovsdb: NetVirt Weekly 3/14/17

Meeting started by shague at 15:01:48 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:01:50)
  2. Review existing action items (shague, 15:01:51)
    1. [DONE] vthapar: to compile list of current configuration flags - add to test spreadsheet (shague, 15:02:39)
    2. moved actions for RECLONE and ovs version to topics (shague, 15:03:23)
    3. jamoluhrsen (jamoluhrsen, 15:03:37)

  3. M4 - yang changes still outstanding? (shague, 15:05:03)
    1. janki (janki, 15:05:30)
    2. still need update for new specs config settings (shague, 15:05:36)
    3. still need yang changes to merge (shague, 15:06:44)
    4. spec yang owners should reach out to get reviews finished (shague, 15:11:05)

  4. open specs (shague, 15:11:27)
    1. send out refresher email with spec queries (shague, 15:15:40)

  5. devstack RECLONE flag (shague, 15:16:24)
    1. cannot remove RECLONE flag (shague, 15:16:35)
    2. leave the flag as is and fix when it breaks (shague, 15:17:39)

  6. ovs2.6 in CSIT (shague, 15:18:24)
    1. 2.6 works fine with newton, has problems with mitaka (shague, 15:18:57)
    2. ovs2.6 works for both mitaka and newton. (jamoluhrsen, 15:19:00)
    3. workaround is available for mitaka and 2.6 (shague, 15:19:42)
    4. would like to keep the mitaka 2.5 job to show coverage for both 2.5 and 2.6 (shague, 15:20:12)
    5. ACTION: jamoluhrsen to get 2.6 running with newton and keep mitaka at 2.5 (jamoluhrsen, 15:20:22)
    6. support 3 releases of openstack (shague, 15:21:29)
    7. look into deprecating transparent (shague, 15:22:53)

  7. ipv6 in CSIT (shague, 15:23:01)
    1. ipv6 tests in tempest are close to being ready (jamoluhrsen, 15:23:14)
    2. main failure in v6 is because we dont have a ping responder (jamoluhrsen, 15:23:35)
    3. tempest fix for IPv6 CSIT failures - https://review.openstack.org/#/c/443444/ (sridharg, 15:23:50)
    4. related Netvirt fix - https://git.opendaylight.org/gerrit/#/c/53137/ (sridharg, 15:24:04)
    5. we could use some basic ping tests in l2/l3 connectivity suites (jamoluhrsen, 15:27:20)
    6. HELP: write ipv6 csit test while waiting for arp responder fix (shague, 15:29:11)
    7. janki might be able to help with csit tests (shague, 15:29:47)

  8. Ocata in CSIT (shague, 15:30:41)
    1. putting ocata in CSIT is going to add a ton of new jobs. (jamoluhrsen, 15:31:11)
    2. https://git.opendaylight.org/gerrit/#/c/52302/ needs merge first (shague, 15:33:00)
    3. https://git.opendaylight.org/gerrit/#/c/52308/ second patch (shague, 15:33:23)
    4. https://git.opendaylight.org/gerrit/#/c/52894/ ocata version of cli's (shague, 15:33:51)
    5. ACTION: jamoluhrsen shague review refactor patch (shague, 15:35:51)
    6. discussion around jenkins resources by netvirt jobs (shague, 15:36:45)

  9. CSIT 1node sporadic failures - update? (shague, 15:37:14)
    1. two major issues: dhcp race, vm reboot/race conditions (shague, 15:38:23)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=7866 (shague, 15:39:27)
    3. faseela pushed patch for dhcp failure (shague, 15:40:14)
    4. faseela has pushed https://git.opendaylight.org/gerrit/#/c/52925/ (daya_k, 15:40:53)
    5. mac spoofing bug needs to be assigned (shague, 15:44:26)
    6. https://bugs.opendaylight.org/show_bug.cgi?id=7885 (shague, 15:44:31)
    7. ACTION: jamoluhrsen shague triage and assign top priority bugs (shague, 15:45:54)

  10. l3 hwvtep - ovs 2.6 spec updates (shague, 15:47:12)
    1. should they be included for carbon or push to nitrogen (shague, 15:47:34)
    2. try to push the 1.6 schema changes, backend might not make it (shague, 15:52:50)
    3. everyone please review ashvin's document and let us know if we should do a call to discuss ipv6 options (daya_k, 15:53:53)


Meeting ended at 16:48:59 UTC (full logs).

Action items

  1. jamoluhrsen to get 2.6 running with newton and keep mitaka at 2.5
  2. jamoluhrsen shague review refactor patch
  3. jamoluhrsen shague triage and assign top priority bugs


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to get 2.6 running with newton and keep mitaka at 2.5
    2. jamoluhrsen shague review refactor patch
    3. jamoluhrsen shague triage and assign top priority bugs
  2. shague
    1. jamoluhrsen shague review refactor patch
    2. jamoluhrsen shague triage and assign top priority bugs


People present (lines said)

  1. shague (39)
  2. odp-gerritbot (8)
  3. jamoluhrsen (8)
  4. odl_meetbot (3)
  5. sridharg (2)
  6. daya_k (2)
  7. janki (1)


Generated by MeetBot 0.1.4.