#opendaylight-ovsdb: NetVirt Weekly 4/18/17

Meeting started by shague at 15:02:32 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:02:34)
    1. Alon Kochba (alonko, 15:03:07)
    2. https://meetings.opendaylight.org/opendaylight-ovsdb/2017/netvirt_weekly_4_11_17/opendaylight-ovsdb-netvirt_weekly_4_11_17.2017-04-11-15.02.html last weeks minutes (shague, 15:04:36)
    3. [in progress] shague start thread to define tags (shague, 15:05:03)
    4. https://lists.opendaylight.org/pipermail/netvirt-dev/2017-April/004229.html (shague, 15:05:18)
    5. Aswin Suryanarayanan (aswinsuryan, 15:06:08)
    6. [DONE] shague vivek offline thread to triage bugs - vivek sent email (shague, 15:07:03)
    7. Sridhar Gaddam (sridharg, 15:07:13)

  2. vni patches (shague, 15:07:58)
    1. need to add option to configure vni (shague, 15:08:12)
    2. alonko to review vni patches (shague, 15:08:57)

  3. pnf patches (shague, 15:09:27)
  4. evpn and ipv6 vpn patches (shague, 15:11:55)
    1. ACTION: vivek to send out list of patches for evpn and ipv6 that can be reviewed (shague, 15:16:57)

  5. csit stability (shague, 15:17:35)
    1. looks like infra issues (shague, 15:17:43)
    2. tempest failure needs to be looked (shague, 15:21:24)

  6. clustering csit (shague, 15:25:03)
    1. need to start lkooking at the 3node (shague, 15:25:17)

  7. CSIT ocata (shague, 15:26:06)
    1. venkat found issues with needing cell groups config (shague, 15:26:19)
    2. daya is hostconfig needed? (shague, 15:27:14)

  8. SNAT conntarck enabled as default? (shague, 15:28:00)
    1. aswinsuryan still some open bugs, not ready yet to be default (shague, 15:28:32)
    2. aswinsuryan dpdk not supported (shague, 15:29:01)
    3. aswinsuryan thinks there shoudl be bgp changes to support the snat conntrack (shague, 15:30:36)
    4. ACTION: aswinsuryan to send email with bgp changes needed (shague, 15:30:56)

  9. sfc integration (shague, 15:32:41)
    1. alonko adding csit tests for sfc (shague, 15:33:07)
    2. csit will use networking-sfc apis to be translated to sfc models (shague, 15:35:54)
    3. vishnoianil: need work to support mac chaining (shague, 15:36:32)

  10. ocato default port binding (shague, 15:39:20)
    1. hostconfig and psuedoport need to be supported (shague, 15:39:44)

  11. karaf 4 tests (shague, 15:40:53)
    1. skitt: need to start real karaf 4 testsing (shague, 15:41:56)
    2. Karaf 4 distro patch: https://git.opendaylight.org/gerrit/55160 (skitt, 15:42:16)
    3. that patch is legacy netvirt, need patch for new netvirt (shague, 15:42:43)
    4. ovsdb external_id updates captured in https://review.openstack.org/#/c/433283/ for host_config feature (daya_k, 15:44:36)
    5. need integration changes to enable the karaf 4 features for csit (shague, 15:47:54)
    6. ACTION: shague skitt work on changes needed to enable in netvirt csit (shague, 15:48:59)

  12. using tls (shague, 15:53:03)
    1. need csit tests to verify (shague, 15:53:15)
    2. vishnoianil: feels it shoudl work (shague, 15:53:24)


Meeting ended at 16:06:23 UTC (full logs).

Action items

  1. vivek to send out list of patches for evpn and ipv6 that can be reviewed
  2. aswinsuryan to send email with bgp changes needed
  3. shague skitt work on changes needed to enable in netvirt csit


Action items, by person

  1. aswinsuryan
    1. aswinsuryan to send email with bgp changes needed
  2. shague
    1. shague skitt work on changes needed to enable in netvirt csit
  3. skitt
    1. shague skitt work on changes needed to enable in netvirt csit


People present (lines said)

  1. shague (41)
  2. odl_meetbot (3)
  3. odp-gerritbot (2)
  4. sridharg (1)
  5. skitt (1)
  6. daya_k (1)
  7. aswinsuryan (1)
  8. alonko (1)


Generated by MeetBot 0.1.4.