#opendaylight-ovsdb: NetVirt Weekly 4/4/17

Meeting started by alonko at 14:59:39 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (alonko, 15:00:22)
    1. Alon Kochba (alonko, 15:00:26)
    2. Vic Pickard (vpickard, 15:02:16)
    3. skitt (skitt, 15:02:35)

  2. Review previous week action items (alonko, 15:03:02)
    1. Aswin Suryanarayanan (aswinsuryan, 15:03:15)
    2. [DONE] sent mail to openflowplugin about open bugs (alonko, 15:04:36)
    3. daya_k joined (daya_k, 15:05:01)
    4. ACTION: vivekn to follow up with Hema on the openflowplugin issues (alonko, 15:05:34)
    5. [DONE] Started bug scrubbing, will continue this week (alonko, 15:06:48)
    6. Request assignees make sure to update bugs they are working on, and assign them to themselves (alonko, 15:07:17)

  3. Bugzilla bug scrubbing (alonko, 15:11:08)
    1. ACTION: vthapar need to compile a list of modules we want to add to bugzilla components and send out helpdesk request for easier filtering (alonko, 15:11:36)
    2. Sridhar Gaddam (sridharg, 15:14:17)

  4. stable/carbon to be pulled next week (alonko, 15:14:30)
    1. current planned date is 04-10 (alonko, 15:15:53)
    2. we should push to wrap up all feature activity this week before branch is cut (alonko, 15:16:11)

  5. Review remaining patches (alonko, 15:16:30)
    1. only several small patches remaining for HPE blueprints - alonko to send list to wrap up this week (alonko, 15:18:13)
    2. from E/// side there are a few patches for 3 remaining features - EVPN, L3VNI and ECMP (alonko, 15:18:48)
    3. vni-based-l2-l3-nat still missing two new patches yet to be raised (alonko, 15:20:33)
    4. this flag will be enabled to check CSIT once all patches are in (alonko, 15:20:47)
    5. EVPN and ECMP have a few more patches too - trying to wrap everything up this week (alonko, 15:25:11)
    6. requesting more peer reviews between companies wherever possible, especially on core features (alonko, 15:31:42)
    7. VNI final patches will be prioritized to enable HPE reviews this week (alonko, 15:33:15)

  6. CSIT stability efforts (alonko, 15:36:33)
    1. a lot of the latest exceptions and bugs have been handled, scrubbing continues (alonko, 15:37:05)
    2. Tali's fix for the dispatcher remaining flows came in that should fix a lot of the remaining DHCP issues (alonko, 15:37:29)
    3. we need to aim for 100% passing CSIT to prepare for Carbon release (alonko, 15:38:03)
    4. a few known bugs remain to be handled - the rest need to be rescrubbed if they still happen (alonko, 15:41:00)
    5. for SNAT fix - need to consider the RPC fix to flow configuration for SNAT (alonko, 15:42:15)
    6. another option is to start trying to test the new SNAT code (alonko, 15:43:24)

  7. adding of new CSIT tests after stabilization (alonko, 15:46:27)
    1. will go over blueprints and start adding in new CSITs for new features during the following month (alonko, 15:48:45)

  8. SFC integration (alonko, 15:49:39)
    1. SFC integration almost done, one final patch remaining and then testing should begin (alonko, 15:49:50)
    2. we should be able to support SFC in Carbon both using SFC direct API and using openstack-sfc (alonko, 15:50:11)

  9. HWVTEP cards moved to netvirt trello (alonko, 15:50:18)
    1. HWVTEP decided to use the netvirt board to help sync between netvirt and HWVTEP (alonko, 15:51:16)
    2. CSIT tests were added for HWVTEP (alonko, 15:51:25)

  10. Upgrade-ability discussions (alonko, 15:51:51)
    1. mvorburger interested in setting up a bi-weekly call for discussing upgrade-ability, across ODL and also specifically for netvirt (alonko, 15:52:23)
    2. interest in this both for netvirt specific problems and general ODL issues, should set up discussions before DDF and continue in session there (alonko, 15:58:12)


Meeting ended at 15:58:14 UTC (full logs).

Action items

  1. vivekn to follow up with Hema on the openflowplugin issues
  2. vthapar need to compile a list of modules we want to add to bugzilla components and send out helpdesk request for easier filtering


People present (lines said)

  1. alonko (41)
  2. odl_meetbot (3)
  3. vpickard (2)
  4. daya_k (2)
  5. sridharg (1)
  6. skitt (1)
  7. aswinsuryan (1)
  8. odp-gerritbot (1)


Generated by MeetBot 0.1.4.