#opendaylight-sfc: sfc_weekly

Meeting started by tbachman at 17:00:07 UTC (full logs).

Meeting summary

    1. https://meetings.opendaylight.org/opendaylight-sfc/2015/sfc_weekly/opendaylight-sfc-sfc_weekly.2015-02-12-17.00.html Last week’s meeting minutes (tbachman, 17:00:22)

  1. agenda (tbachman, 17:00:29)
    1. ebrjohn_ asks if we can get a POC in time for M3 (tbachman, 17:04:08)
    2. ebrjohn_ says repenno has updated the functional spec (tbachman, 17:04:08)
    3. edwarnicke says that SFC is delegating the classification (tbachman, 17:04:49)
    4. ebrjohn_ says that’s been the assumption — GBP decides what traffic goes into SFC (tbachman, 17:05:02)
    5. edwarnicke says you might need to put a new classifier type into the model (tbachman, 17:05:15)
    6. ebrjohn_ asks how GBP and SFC are going to work (tbachman, 17:07:03)
    7. https://git.opendaylight.org/gerrit/#/c/15491/ gerrit in SFC to provide API to GBP (tbachman, 17:07:35)
    8. edwarnicke says we have a new action in GBP, which specifies the service function chain name (tbachman, 17:09:24)
    9. edwarnicke says just getting the service chain name, that should should be enough to handle the ingress (tbachman, 17:10:19)
    10. paulq and ebrjohn_ say yes (tbachman, 17:10:27)
    11. paulq wants to make sure that SFC is handing back everything GBP needs (tbachman, 17:10:40)
    12. edwarnicke asks how modular is the thing that handles the SFC action (tbachman, 17:11:01)
    13. tbachman asks what edwarnicke means by modular (tbachman, 17:12:37)
    14. edwarnicke also asks who might be contributing to things like MPLS encap (tbachman, 17:13:05)
    15. ebrjohn_ had mentioned the possibility of doing the MPLS part in GBP (tbachman, 17:13:34)
    16. edwarnicke says he’d like to see integration soon as possible, as that’s when we find issues (tbachman, 17:14:28)
    17. edwarnicke says M3 is also coming up, which is functionality freeze (tbachman, 17:14:36)
    18. ebrjohn_ agrees — says we have about 1 month (tbachman, 17:14:54)
    19. ebrjohn_ asks if we can shoot for getting commits merged by Monday (tbachman, 17:17:16)
    20. tbachman says we can shoot for Monday (tbachman, 17:17:26)
    21. ebrjohn_ asks if there’s anything else that needs to be discussed about integrating GBP and SFC (tbachman, 17:18:11)
    22. paulq says there’s a question on the next hop. In a perfect world, the packet would pop-out and the tunnel would be in place. However, you don’t always know where you’re going to pop out, as services move, etc. (tbachman, 17:18:52)
    23. paulq says having an API to query an overlay API for this info would be helpful (tbachman, 17:19:09)
    24. ebrjohn_ says that’s more of a long-term item (tbachman, 17:19:17)
    25. paulq is fine with preconfigured tunnels for the POC (tbachman, 17:19:34)
    26. mickey_spiegel says there’s one issue he doesn’t understand yet — if we have multiple ways in through classifiers (e.g. 2 different L4 ports into the same chain), how do we get it to go through the same set of nodes; reuse a service path? two different paths? (tbachman, 17:20:30)
    27. paulq says he’s not sure if it matters for phase 1; using NSH as an example, for a given path ID, SFC programs the data plane appropriate to go to the same nodes — so it’s consistent (tbachman, 17:21:12)
    28. mickey_spiegel asks if GBP should be asking for only 1 rendered service path? (tbachman, 17:21:27)
    29. ebrjohn_ says rendered service paths can be symmetric — you’re going to have to have two service paths (tbachman, 17:21:48)
    30. mickey_spiegel says he wasn’t referring to direction - should be a pair instead of one; is curious what that API looks like (tbachman, 17:22:07)
    31. mickey_spiegel says GBP has EPGs 1 & 2, with classifier where port 80 needs SFC and port 8080 does as well. Does GBP ask for two service paths? If so, does that make different service function instances? (tbachman, 17:23:03)
    32. ebrjohn_ says last week we spoke about asking a service chain in a more abstract way — we want a FW, DPI, etc. (tbachman, 17:23:24)
    33. mickey_spiegel says it’s a simpler question; If port 80 and port 8080 are different rules in GBP, and we want them to go thru the same service function instances, does GBP ask for one chain or two? (tbachman, 17:24:15)
    34. paulq says it comes down to what the meaning of a service function path is; for POC, let’s keep it simple (tbachman, 17:24:54)
    35. paulq says that for now, when you request a chain from SFC, SFC constrains it to return the same path (tbachman, 17:25:19)
    36. mickey_spiegel says that’s a work-around for short term, but is interested in the long term solution (tbachman, 17:25:47)
    37. ebrjohn_ says that the service path has already been created, so should be there; if you ask multiple times, should be the same thing returned (tbachman, 17:26:35)
    38. mickey_spiegel asks if the chain is created by name, or by ID (tbachman, 17:27:06)
    39. ebrjohn_ says the path should be created by the time GBP asks for it; the API just returns the ID (tbachman, 17:27:28)
    40. paulq asks if mickey_spiegel can put his question to the mailling list — also since repenno isn’t here for today’s call (tbachman, 17:28:22)
    41. ACTION: tbachman and repenno to get patches merged by monday (tbachman, 17:31:14)
    42. ACTION: ebrjohn_ to send email to lists asking for folks to review the patches (tbachman, 17:31:33)


Meeting ended at 17:32:14 UTC (full logs).

Action items

  1. tbachman and repenno to get patches merged by monday
  2. ebrjohn_ to send email to lists asking for folks to review the patches


Action items, by person

  1. ebrjohn_
    1. ebrjohn_ to send email to lists asking for folks to review the patches
  2. tbachman
    1. tbachman and repenno to get patches merged by monday


People present (lines said)

  1. tbachman (48)
  2. odl_meetbot (4)
  3. ebrjohn_ (1)
  4. alagalah (1)


Generated by MeetBot 0.1.4.