#opendaylight-sfc: sfc_weekly

Meeting started by tbachman at 17:02:00 UTC (full logs).

Meeting summary

  1. Agenda (tbachman, 17:02:23)
    1. https://lists.opendaylight.org/pipermail/sfc-dev/2015-February/000943.html Agenda for today’s meeting (tbachman, 17:02:29)
    2. https://meetings.opendaylight.org/opendaylight-sfc/2015/sfc_weekly/opendaylight-sfc-sfc_weekly.2015-02-19-17.00.html Minutes from last week’s meeting (tbachman, 17:02:40)

  2. Status of GBP+SFC integration (tbachman, 17:03:17)
    1. https://git.opendaylight.org/gerrit/#/c/15759 gerrit from reinaldo to support SFC+GBP integration (tbachman, 17:03:58)
    2. tbachman says GBP has merged a patch on GBP’s side — working on a new patch based on repenno’s latest gerrit (tbachman, 17:05:32)
    3. repenno says that the changes in the latest gerrit are mostly backwards compatible (tbachman, 17:05:54)
    4. repenno says this one supports different encaps. Construction of the RSP includes the SFF data plane locator of how to reach the SFF used to enter the RSP (tbachman, 17:06:19)
    5. repenno says you theoretically could have an SFF with vxlan, another with MPLS, etc. (tbachman, 17:06:35)
    6. repenno says that doesn’t change much from the way things work — just additions to existing code (tbachman, 17:06:50)
    7. repenno says in the Service Function Path, the user can provide the name of the encap to be used on the RSP (tbachman, 17:07:18)
    8. the default is vxlan + NSH, but supports other types provided by user (tbachman, 17:07:41)
    9. repenno this allows GBP to ask SFC for the first hop of the RSP and get back a Java RSP hop object (tbachman, 17:08:08)
    10. repenno says GBP can get the appropriate values needed from the RSP object (tbachman, 17:08:27)
    11. ebrjohn says GBP needs the first hop to set up the tunnel to SFC (tbachman, 17:08:51)
    12. ebrjohn says if the path is symmetric, GBP will have to call twice (tbachman, 17:09:02)
    13. repenno says this is the first integration. repenno says that GBP really doesn’t want to know the encap, and symmetric (tbachman, 17:09:32)
    14. repenno says that for now, for the POC, this will be sufficient (tbachman, 17:09:49)
    15. ebrjohn says the previously the RSP was created internally when the SFP was configured; now that’s not the case any more — RPC needs to be called explicitly (tbachman, 17:10:19)
    16. repenno says that was already the case with the UI; if you came through RESTCONF to create an SFP, it did that internally (tbachman, 17:10:43)
    17. repenno says multi-encap use case leads us down the road of doing this internally (tbachman, 17:11:05)
    18. ebrjohn says we probably can get that merged in today (tbachman, 17:11:34)
    19. ACTION: tbachman to review and provide comments on the patch (tbachman, 17:11:43)

  3. SFC OVS (tbachman, 17:12:15)
    1. ebrjohn says there was an email sent on this (tbachman, 17:13:28)
    2. https://lists.opendaylight.org/pipermail/sfc-dev/2015-February/000935.html email on this (tbachman, 17:13:32)
    3. ebrjohn provided a patch to support MPLS (tbachman, 17:15:13)
    4. https://git.opendaylight.org/gerrit/#/c/15501/ gerrit that added this (tbachman, 17:15:18)

  4. M3 Milestone (tbachman, 17:15:22)
    1. ebrjohn says M3 is just 3 weeks away (tbachman, 17:15:29)


Meeting ended at 17:17:01 UTC (full logs).

Action items

  1. tbachman to review and provide comments on the patch


Action items, by person

  1. tbachman
    1. tbachman to review and provide comments on the patch


People present (lines said)

  1. tbachman (35)
  2. odl_meetbot (4)
  3. ebrjohn (0)


Generated by MeetBot 0.1.4.