#opendaylight-sfc: sfc_weekly

Meeting started by tbachman at 16:00:00 UTC (full logs).

Meeting summary

    1. https://lists.opendaylight.org/pipermail/sfc-dev/2015-March/001014.html Agenda for today’s meeting (tbachman_, 16:03:22)
    2. https://meetings.opendaylight.org/opendaylight-sfc/2015/sfc_weekly/opendaylight-sfc-sfc_weekly.2015-03-05-17.01.html Minutes from last week’s meeting (tbachman_, 16:03:25)

  1. status (tbachman, 16:04:31)
    1. repenno says we’re reaching a point in SFC where a lot of stuff is working well and stable, but we need to improve unit tests and make them work reliably (tbachman, 16:06:31)
    2. repenno ran the unit tests yesterday and said there are a lot of problems (tbachman, 16:06:47)
    3. repenno reached out to some folks to clean these up, but encourages others to run the unit tests themselves and resolve the issues (tbachman, 16:07:20)
    4. ebrjohn says the unit tests should be run in jenkins — asks why these NPEs aren’t causing the tests cases to fail (tbachman, 16:07:57)
    5. repenno also discovered that different team members tests in different configurations — e.g. with things “connected”, without things “connected”, etc. (tbachman, 16:09:11)
    6. ebrjohn says we should create some tasks — the first task should be that any exception thrown from a test case should cause the test case to fail (tbachman, 16:09:41)
    7. ebrjohn says then each responsible party can clean up the exceptions (tbachman, 16:10:03)
    8. ebrjohn says repenno mentioned that there are some tasks related to the RPC that was recently deprecated (tbachman, 16:10:28)
    9. ebrjohn says the team may want to consider using the Trello board to track the growing list of items (tbachman, 16:10:45)
    10. ACTION: ebrjohn to set up a Trello board for SFC (tbachman, 16:10:58)
    11. ACTION: ebrjohn john will create Trello card for unit tests to fail on exceptions (tbachman, 16:11:27)
    12. ebrjohn says when you start karaf and look at the logs, there are some exceptions in the logs that should be cleaned up as well (e.g. 6-7 or exceptions about not being able to create bundles) (tbachman, 16:13:19)

  2. OPNFV (tbachman, 16:14:54)
    1. ChrisPriceAB says there’s a proposal for OPNFV function chaining waiting for some action (tbachman, 16:15:18)
    2. ChrisPriceAB says in parallel, there’s a discussion with GBP, as GBP is providing a level of abstraction that OpenStack can communicate through in order to do SFC (tbachman, 16:15:44)
    3. ChrisPriceAB says after the first release of OPNFV in April, looking to bring in ODL trunk, and start to run and deploy that (tbachman, 16:16:12)
    4. ChrisPriceAB says he’d like to wrap that in an OPNFV recognized activity (tbachman, 16:16:27)
    5. ChrisPriceAB wants to see where we are in response to that, and if the late April/early May time frame looks okay to do this (tbachman, 16:17:16)
    6. ebrjohn says this is absolutely beneficial for ODL and SFC to participate in OPNFV — unless someone objects, recommends doing that (tbachman, 16:17:40)
    7. ebrjohn says by end of April/beginning of May, should be able to export that out to OPNFV (tbachman, 16:18:00)
    8. repenno says we need to fix the deliverables; the Intel folks had an interest in the project (tbachman, 16:21:12)
    9. ChrisPriceAB says the Qosmos team is coming on board and also has expressed an interest (tbachman, 16:21:29)
    10. repenno says from the ODL/GBP perspective, we can show something, but from OPNFV perspective, there’s some packaging/installation questions (tbachman, 16:22:19)
    11. repenno says that doesn’t stop us from showing GBP + SFC (tbachman, 16:22:38)
    12. ChrisPriceAB says there might be a number of installers, but the endpoint is a stable state of OpenStack and OpenDaylight (tbachman, 16:22:59)
    13. ebrjohn says if we have an API freeze on 4/16, and code freeze on 5/14 (tbachman, 16:25:01)
    14. ebrjohn says we can also create a branch to pull if needed (tbachman, 16:25:11)
    15. ChrisPriceAB says we do this work on the Lithium main branch so that when it’s released, it’s coupled with the OpenStack “L” release (tbachman, 16:25:34)
    16. ebrjohn is more concerned about the API freezes (tbachman, 16:25:58)
    17. repenno would prefer not to hinge the SFC project on the requirements (tbachman, 16:28:05)
    18. ebrjohn asks how Andrej how his effort is progressing (tbachman, 16:29:49)
    19. Andrej says he hasn’t had a chance to look at the documentation (tbachman, 16:30:00)
    20. ACTION: ebrjohn to touch base with Andrej on all of the things that are being worked on (tbachman, 16:30:53)
    21. ACTION: ebrjohn to touch base with ContexStream and Intel folks on Monday, re: M3 (tbachman, 16:33:16)
    22. repenno says the Intel guys did the new SFC/GBP API, which allows GBP to pass a list of service functions (tbachman, 16:33:49)
    23. repenno had a discussion with Intel yesterday, and they’re going to try to do a generic SFC Netconf implementation (tbachman, 16:34:27)
    24. repenno says if this goes well, we should include that in our M3 (tbachman, 16:34:44)


Meeting ended at 16:35:13 UTC (full logs).

Action items

  1. ebrjohn to set up a Trello board for SFC
  2. ebrjohn john will create Trello card for unit tests to fail on exceptions
  3. ebrjohn to touch base with Andrej on all of the things that are being worked on
  4. ebrjohn to touch base with ContexStream and Intel folks on Monday, re: M3


People present (lines said)

  1. tbachman (51)
  2. tbachman_ (4)
  3. odl_meetbot (4)
  4. ChrisPriceAB (3)


Generated by MeetBot 0.1.4.