#opendaylight-sfc: sfc_weekly

Meeting started by tbachman at 16:00:03 UTC (full logs).

Meeting summary

    1. https://lists.opendaylight.org/pipermail/sfc-dev/2015-March/001053.html email providing the agenda for today’s meeting (tbachman, 16:00:43)
    2. https://meetings.opendaylight.org/opendaylight-sfc/2015/sfc_weekly/opendaylight-sfc-sfc_weekly.2015-03-19-16.03.html Link to last week’s meeting minutes (tbachman, 16:01:00)

  1. SFCOFL2 patch (tbachman, 16:02:56)
    1. https://git.opendaylight.org/gerrit/#/c/17074 Gerrit that get encapsulation details for the SFCOFL2 renderer (tbachman, 16:03:27)
    2. ebrjohn says he’d rather hold off any decisions on the patch until paulq and repenno have a chance to look at the patch (tbachman, 16:07:58)
    3. ebrjohn says we can discuss the patch today if folks are interested (tbachman, 16:08:13)
    4. ebrjohn says the SFCOFL2 renderer is the openflow renderer in SFC; was present in the Helium release, but lacked encapsulation and only supported very simple/basic topologies (tbachman, 16:08:56)
    5. ebrjohn says he’s refactored it to support “normal” SFC topologies, and added VLAN and MPLS encapsulations (tbachman, 16:09:15)
    6. ebrjohn says the openflowpipeline (the easy part) is done (tbachman, 16:09:26)
    7. ebrjohn says the hard part - writing configuration information into the SFCOFL2 plugin - still needs to be done (tbachman, 16:09:42)
    8. ebrjohn provides an example with a service chain with two SFFs — problem is you need to know the encap info between SFF1 and SFF2: ingress to SFF1 and egress from SFF2; asks “where do you specify this information?" (tbachman, 16:10:28)
    9. ebrjohn says you could specify this on the individual SFF — on ingress and egress — providing things like VLAN 100 and VLAN 200, but that won’t work: need to specify a unique VLAN per RSP (tbachman, 16:11:14)
    10. ebrjohn says as an example, given 3 RSPs, with RSP1 using VLAN 100, RSP2 using VLAN 200,a nd RSP3 using VLAN 300. Do you need to create a data plane locator per path? (won’t scale) (tbachman, 16:11:54)
    11. ebrjohn says you could put this in the service path, and then the RSP is created by merging the SFC and SFP (tbachman, 16:13:07)
    12. ebrjohn says we need to discuss this in more detail — need repenno and paulq involved in that discussion (tbachman, 16:14:09)
    13. repenno noted that we need some sort of function, where there is a pair of SFFs and the path ID, and provides encap info for that hop (tbachman, 16:15:11)
    14. ebrjohn asks Andrej how they do this with NSH? (tbachman, 16:15:58)
    15. ACTION: ebrjohn to schedule a separate meeting with paulq and repenno on that topic (tbachman, 16:18:16)

  2. Other Items (tbachman, 16:18:24)
    1. ebrjohn says he’s on vacation next week (Easter week in Spain) (tbachman, 16:18:41)
    2. ebrjohn asks if anyone is available to host the meeting next Thursday (tbachman, 16:18:57)
    3. ACTION: ebrjohn to send email to the SFC mailing list, asking if anyone can host the meeting (tbachman, 16:19:21)
    4. ebrjohn says the M4 is on April 16th; This is the API freeze, so we need to have those finalized by then (tbachman, 16:20:08)
    5. ebrjohn says that all of the documentation needs to be at “draft” quality for M4 (tbachman, 16:20:42)
    6. ebrjohn set up tasks for M4 in the Trello board (tbachman, 16:20:57)
    7. ebrjohn says we need a simple set of System Tests for M4 as well (tbachman, 16:22:12)
    8. ebrjohn says there’s a hackathon between M4 and M5 milestones (tbachman, 16:24:48)
    9. ebrjohn says anyone interested in going is more than welcome (tbachman, 16:25:12)
    10. http://www.opendaylight.org/events/2015-04-15/opendaylight-hackfest-april-2015 web page on the hackfest (tbachman, 16:25:54)
    11. ebrjohn says Ricardo Noriega is joining the team from Ericsson (tbachman, 16:26:26)
    12. Ricardo will be joining the SFC project after Easter; has some experience with ODL in Helium (tbachman, 16:26:53)
    13. ebrjohn says that ChrisPrice talked a few weeks ago about SFC being integrated into OPNFV; ChrisPriceAB suggested ebrjohn nominate himself in OPNFV as well as the SFC project lead (tbachman, 16:28:34)
    14. ebrjohn says the bulk of the tasks will be to pull from the ODL git repo, build it, and test it in an integration environment with OpenStack (tbachman, 16:29:36)
    15. ebrjohn says OPNFV will likely push use cases back into ODL (tbachman, 16:29:58)


Meeting ended at 16:30:35 UTC (full logs).

Action items

  1. ebrjohn to schedule a separate meeting with paulq and repenno on that topic
  2. ebrjohn to send email to the SFC mailing list, asking if anyone can host the meeting


Action items, by person

  1. ebrjohn
    1. ebrjohn to schedule a separate meeting with paulq and repenno on that topic
    2. ebrjohn to send email to the SFC mailing list, asking if anyone can host the meeting


People present (lines said)

  1. tbachman (39)
  2. odl_meetbot (4)
  3. ebrjohn (0)


Generated by MeetBot 0.1.4.