#opendaylight-sfc: sfc_weekly

Meeting started by tbachman at 16:04:39 UTC (full logs).

Meeting summary

    1. https://meetings.opendaylight.org/opendaylight-sfc/2015/sfc_weekly/opendaylight-sfc-sfc_weekly.2015-07-09-16.00.html Minutes from last week’s meeting (tbachman, 16:04:51)
    2. https://lists.opendaylight.org/pipermail/sfc-dev/2015-July/001397.html Agenda for today’s meeting (tbachman, 16:06:39)

  1. SFC Demo from Ricky (tbachman, 16:06:45)
    1. https://docs.google.com/presentation/d/1VYaL2lDV4HGj0qIfUHWXbRDUbXx-0z0RYlKmQ6lpq3U/edit?usp=sharing Link to document describing the demo (tbachman, 16:07:34)
    2. ericano_ presents demo on SFC that uses an HTTP proxy (SQUID) to show traffic traversing different chains (tbachman, 16:08:54)
    3. The motivation for the demo is to be able to easily set up and use ODL SFC (tbachman, 16:09:14)
    4. The demo graphically shows which service chain a client is using; this is done using a client talking to an apache web server, which traverses different chains that add HTTP headers to change the color of a web page (tbachman, 16:10:03)
    5. ACTION: ebrjohn to send an email to the SFC ML with a link to today’s presentation (tbachman, 16:10:58)
    6. The demo uses two classifiers, two SFFs, and two SFs (tbachman, 16:11:13)
    7. The demo uses 3 service chains. (tbachman, 16:11:33)
    8. Chain #1 just traverses SF1, which colors the web page blue (tbachman, 16:11:46)
    9. Chain #2 just traverses SF2, which colors the web page red (tbachman, 16:11:56)
    10. Chain #3 traverses SF1 and SF2, which colors the web page purple (tbachman, 16:12:11)
    11. The demo uses a vagrant setup, which makes it easy to stand up and use (tbachman, 16:13:21)
    12. ericano_ says the script starts the controller, which runs in one of the VMs (tbachman, 16:13:50)
    13. lmcdasm asks what’s been defined by the demo (tbachman, 16:21:37)
    14. ericano_ says it defines the SF types, SFFs, etc. (tbachman, 16:21:50)
    15. ericano_ says that instead of using the gui, the configuration is pushed using REST calls (tbachman, 16:22:10)
    16. the demo has some tools to help — such as a tool to show clients, list rendered service paths, and assign paths to clients (tbachman, 16:24:51)
    17. lmcdasm asks if the reason that you need the classifier function is that you never know what the classifier is until you have a client (tbachman, 16:25:33)
    18. ebrjohn says that this demo doesn’t use NSH, so there’s a bit of a workaround for the classifier for the demo (tbachman, 16:25:55)
    19. meenakshi asks if the RSPs is information from ODL (tbachman, 16:26:36)
    20. ebrjohn says yes (tbachman, 16:26:39)
    21. meenakshi asks if the RSP IDs are a result of RSP creation (tbachman, 16:26:55)
    22. ebrjohn says yes (tbachman, 16:26:58)
    23. ebrjohn says the REST sender tool can be used to query the datastore to query/list the RSPs, if desired (tbachman, 16:27:17)
    24. lmcdasm asks if this informed mininet about the RSPs that were assigned to the client (tbachman, 16:28:19)
    25. ericano_ says yes (tbachman, 16:28:21)
    26. ericano_ says the header enrichment isn’t yet running — need to open consoles on the SFs and start the process for header enrichment (tbachman, 16:28:57)
    27. ericano_ says there are scripts in the demo to do that (tbachman, 16:29:05)
    28. lmcdasm asks if we’re using an SFF at this point (tbachman, 16:31:12)
    29. ericano_ says yes (tbachman, 16:31:16)
    30. lmcdasm asks if you have to unassociate with the first chain before associating the second chain, or is this done automatically (tbachman, 16:34:33)
    31. ebrjohn says the client tool is just setting up the classifier — the RSPs are there (tbachman, 16:35:06)
    32. ebrjohn says in a big scenario, you could have a DPI or PCRF (Policy Control Routing Function) controlling the classifier (tbachman, 16:36:34)
    33. meenakshi asks where the classifier flows are programmed in the demo? Is it at the client? At the SFF? (tbachman, 16:37:55)
    34. ebrjohn says there is an ingress and egress classifier switch — and those are where the classifiers are programmed (tbachman, 16:38:26)
    35. ebrjohn says the classifier switches are separate from the SFs and SFFs (tbachman, 16:38:40)
    36. ebrjohn says the only thing the classifier does is an L2 to L4 classification and assigns the RSP (tbachman, 16:42:58)
    37. ebrjohn says he’d like to discuss Beryllium planning, but probably not enough time in today’s meeting (tbachman, 16:44:31)

  2. other items (tbachman, 16:44:32)
    1. ebrjohn added a new section to the SFC wiki — SFC configuration in a nutshell (tbachman, 16:44:41)
    2. https://wiki.opendaylight.org/view/Service_Function_Chaining:Main#The_SFC_Configuration_in_a_nutshell SFC in a nutshell on the SFC wiki (ebrjohn, 16:45:24)
    3. ebrjohn says the IETF hackfest starts this week and continues into next week (tbachman, 16:46:08)
    4. ebrjohn says the week after that (July 27th-31st) is the ODL summit in Santa Clara (tbachman, 16:46:28)
    5. ebrjohn says he’ll try to host the meeting during the summit, if it’s feasable (tbachman, 16:48:02)


Meeting ended at 16:49:20 UTC (full logs).

Action items

  1. ebrjohn to send an email to the SFC ML with a link to today’s presentation


Action items, by person

  1. ebrjohn
    1. ebrjohn to send an email to the SFC ML with a link to today’s presentation


People present (lines said)

  1. tbachman (83)
  2. ebrjohn (14)
  3. repenno (10)
  4. odl_meetbot (8)
  5. lmcdasm (2)
  6. alagalah (1)


Generated by MeetBot 0.1.4.