#opendaylight-sfc: weekly ODL SFC meeting

Meeting started by ebrjohn at 17:00:28 UTC (full logs).

Meeting summary

    1. Brady Johnson (ebrjohn, 17:00:45)
    2. Diego Granados (dgranados, 17:01:38)
    3. Jaime CaamaƱo (jaicaa, 17:03:02)

  1. Non-NSH encapsulation for SFC Carbon (ebrjohn, 17:05:19)
    1. Andre Fredette (afredette, 17:05:25)
    2. Ericsson will start working on a different alternative for NSH encapsulation than NSH (not abandoning NSH, just need something pure open source for its products) (dgranados, 17:08:01)
    3. Juanma Fernandez (juanmafg, 17:08:08)
    4. for that alternative, transport between classifier and the first SFF, and also in the transport trunk (i.e. between SFFs) will be vxlan (dgranados, 17:09:30)
    5. for traffic coming back from the SF to the SFF, the plan is to do reclassification (dgranados, 17:10:21)
    6. some discussion between afredette and ebrjohn follows on alternative ways (transport-based) to avoid/support reclassification (dgranados, 17:15:22)
    7. afredette describes a simple use case (virtual CPE) on which SFs only participate in one chain, allowing to avoid reclassification (dgranados, 17:18:49)
    8. this approach, given a working netvirt classificator, would uses vxlan VNIs in the trunk as SFC encapsulation (dgranados, 17:24:25)
    9. @ebrjohn mentions the possibility to incorporate that SF behaviour ("single-chain mode") to the model in the SF type (dgranados, 17:27:07)
    10. @juanmafg states that tricky details about this approach. Other protocols traffic (e.g. dhcp) would use the same service chain, and would end reaching SF's not really expecting it (dgranados, 17:31:41)
    11. https://wiki.opendaylight.org/view/Service_Function_Chaining:Carbon_Release_Plan SFC Carbon release plan (ebrjohn, 17:34:56)
    12. @afredette mentions a mechanism which uses different ports in the SF for handling multiple chains (dgranados, 17:37:23)
    13. ACTION: afredette will send the requirement to netvirt to support the vxlan transport/encapsulation (ebrjohn, 17:37:59)
    14. some discussion follows regarding the "single-chain mode" for SFs. It is clear that the main use case is virtual CPE (dgranados, 17:42:39)


Meeting ended at 17:46:06 UTC (full logs).

Action items

  1. afredette will send the requirement to netvirt to support the vxlan transport/encapsulation


Action items, by person

  1. afredette
    1. afredette will send the requirement to netvirt to support the vxlan transport/encapsulation


People present (lines said)

  1. dgranados (12)
  2. ebrjohn (7)
  3. odl_meetbot (4)
  4. juanmafg (1)
  5. jaicaa (1)
  6. afredette (1)


Generated by MeetBot 0.1.4.