#opendaylight-spectrometer: spectrometer meeting

Meeting started by anipbu at 16:01:22 UTC (full logs).

Meeting summary

  1. agenda bashing (anipbu, 16:01:41)
    1. https://trello.com/b/fIVlZ0M5/opendaylight-spectrometer <- trello board (anipbu, 16:02:11)
    2. nodejs (anipbu, 16:07:14)
    3. agenda items discussion:An suggested agenda to wrap up node.js issues, how we collect issues from git/gerrit, trello board discussion followed by open discussion (tnadeau_, 16:08:29)
    4. (tnadeau_, 16:08:29)

  2. node.js (tnadeau_, 16:08:52)
    1. issue: where to host the node.js server. do we use it just for dev? package management or just to make things easier for dev. Afterwards we compiler the entire thing into a .js script file and serve it that way. (tnadeau_, 16:10:12)
    2. advantages to node.js native is isomorphic code execution (tnadeau_, 16:11:04)
    3. npm package management is an advantage (tnadeau_, 16:11:23)
    4. @Vasu and @tom agreed that the standalone node.js option was preferred (tnadeau_, 16:12:48)
    5. Are there any issues in the ODL backend to pushing a precompiled JS versus a node.js? (tnadeau_, 16:14:28)
    6. ACTION: @Tom to ask Andrew Grimberg about preferences (or security issues) of node.js versus complete package (tnadeau_, 16:15:03)
    7. @an assumes we push a binary to production (tnadeau_, 16:15:32)
    8. ACTION: @tom to contact Andrew@lf and CC our distro list to get his inputs (tnadeau_, 16:20:11)

  3. multi language project support (tnadeau_, 16:21:27)
    1. ACTION: @an to send out email w information about how to access the existing java-based backend (tnadeau_, 16:38:59)
    2. AGREED: all code except for the back end is python (tnadeau_, 16:43:26)
    3. AGREED: investigate the existing java-based data store/back end to see if its worth recycling, or redoing a new one (tnadeau_, 16:43:51)
    4. https://trello.com/b/fIVlZ0M5/opendaylight-spectrometer <- trello board (anipbu, 16:44:26)
    5. we modified the trelllo board to update things (tnadeau_, 16:53:27)

  4. cookies (anipbu, 16:55:35)


Meeting ended at 16:55:36 UTC (full logs).

Action items

  1. @Tom to ask Andrew Grimberg about preferences (or security issues) of node.js versus complete package
  2. @tom to contact Andrew@lf and CC our distro list to get his inputs
  3. @an to send out email w information about how to access the existing java-based backend


People present (lines said)

  1. tnadeau_ (33)
  2. anipbu (10)
  3. odl_meetbot (6)
  4. mohzah (1)
  5. zxiiro (0)


Generated by MeetBot 0.1.4.