#opendaylight-spectrometer: spectrometer meeting

Meeting started by anipbu at 16:06:16 UTC (full logs).

Meeting summary

  1. agenda bashing (anipbu, 16:06:25)
    1. commit initial ui code to a repo (vasya10, 16:07:28)
    2. propose using material-ui as ui theme (vasya10, 16:08:00)
    3. discuss requirements on what type of stats to show (vasya10, 16:08:58)
    4. short demo of what material-ui is and how it will look (vasya10, 16:09:57)

  2. initial code (anipbu, 16:10:36)
    1. trello card for adding inital code (anipbu, 16:10:56)
    2. vasya10 to add initial code (anipbu, 16:11:17)
    3. https://git.opendaylight.org/gerrit/#/admin/projects/spectrometer (anipbu, 16:12:40)
    4. Provide a make file to create binaries for spectrometer project to push to Rackspace infrastructure , new trello card (vasya10, 16:14:40)

  3. design theme (anipbu, 16:15:30)
    1. propose using material-ui as ui theme (anipbu, 16:15:44)
    2. Material Design is by Google (vasya10, 16:15:57)
    3. MD is just a spec, material-ui is an implementation (vasya10, 16:16:30)
    4. http://www.material-ui.com/ (vasya10, 16:21:36)
    5. another option http://materializecss.com/ (vasya10, 16:23:23)
    6. another implementation of MD https://github.com/PearlVentures/Essence (vasya10, 16:23:52)
    7. proposal: React based D3 charts by https://github.com/FormidableLabs/victory (vasya10, 16:26:09)
    8. @anipbu asks if timeseries can be added (vasya10, 16:31:33)
    9. @vasya10 victory doesnt provide one yet, but doesnt preculde another react=based-d3 timeline series (vasya10, 16:32:03)
    10. question on what kind of color/theme to use ? is there any std opendaylight color/theme ? (vasya10, 16:34:53)
    11. @anipbu prefers use of odl theme.. but we dont have Thanh, TomN, lets wait for next week (vasya10, 16:35:32)
    12. Need TomN to help with requirements for statistics etc. (vasya10, 16:36:10)
    13. ACTION: tnadeau to help with requirements for statistics etc. (anipbu, 16:36:27)

  4. cookies (anipbu, 16:43:15)


Meeting ended at 16:43:31 UTC (full logs).

Action items

  1. tnadeau to help with requirements for statistics etc.


Action items, by person

  1. tnadeau
    1. tnadeau to help with requirements for statistics etc.


People present (lines said)

  1. vasya10 (16)
  2. anipbu (12)
  3. odl_meetbot (4)
  4. tnadeau (2)


Generated by MeetBot 0.1.4.