#opendaylight-spectrometer: spectrometer meeting

Meeting started by zxiiro at 16:00:09 UTC (full logs).

Meeting summary

  1. python support (anipbu, 16:06:52)
    1. tnadeau says multiple versions of python makes the code convoluted (anipbu, 16:09:21)
    2. tnadeau says multiple versions makes testing difficult (anipbu, 16:09:43)
    3. AGREED: project decides to use Py 3 (latest) (anipbu, 16:11:51)
    4. AGREED: project decides to use Py 3 (latest) (tnadeau, 16:12:31)
    5. ACTION: ask Ryan about getting on the agenda for the TWC (tnadeau, 16:19:20)

  2. Trello Board review (tnadeau, 16:19:56)
    1. https://trello.com/b/fIVlZ0M5/opendaylight-spectrometer (tnadeau, 16:20:45)
    2. AGREED: We will use spynx for documentation and integrate into the spectrometer UX for ease of use (tnadeau, 16:24:14)
    3. ACTION: all: Please review the initial commit on gerrit (tnadeau, 16:26:06)
    4. https://git.opendaylight.org/gerrit/#/c/35524/1/ (vasya10, 16:26:09)
    5. https://docs.google.com/presentation/d/1YfnMFyK0uS65WER6fa7D4u95d-4VJk1ebBykUndBVAU/edit#slide=id.p (anipbu, 16:34:43)
    6. https://git.opendaylight.org/gerrit/#/c/35524/1 (vasya10, 16:39:42)
    7. https://git.opendaylight.org/gerrit/#/c/35525/1 (vasya10, 16:39:54)
    8. https://git.opendaylight.org/gerrit/#/q/project:spectrometer+status:open <-- Open Patches (anipbu, 16:40:14)
    9. AGREED: user 4 spaces instead of tabs in our code (tnadeau, 16:41:54)
    10. AGREED: use usual coding guidelines (i.e.: pep8 for py) (tnadeau, 16:42:09)
    11. AGREED: 2 spaces for JS (not a tab) (tnadeau, 16:42:32)
    12. ACTION: add the above to our README (tnadeau, 16:42:59)
    13. AGREED: html code use spaces instead of tabs too (tnadeau, 16:44:44)

  3. Vasu asks: is there a place to find charts that we need for spectrometer? (tnadeau, 16:45:22)
    1. ACTION: vasu adds some cards on what visuals to create. others in team please do so too. (tnadeau, 16:48:40)

  4. cookies (anipbu, 17:00:48)


Meeting ended at 17:01:05 UTC (full logs).

Action items

  1. ask Ryan about getting on the agenda for the TWC
  2. all: Please review the initial commit on gerrit
  3. add the above to our README
  4. vasu adds some cards on what visuals to create. others in team please do so too.


People present (lines said)

  1. tnadeau (22)
  2. anipbu (9)
  3. odl_meetbot (6)
  4. vasya10 (3)
  5. zxiiro (3)
  6. mohzah (0)


Generated by MeetBot 0.1.4.