#opendaylight-unimgr: UNI Manager

Meeting started by KLuehrs at 20:02:29 UTC (full logs).

Meeting summary

    1. (grmontpetit, 20:02:45)
    2. adetalhouet (adetalhouet, 20:02:47)
    3. grmontpetit (grmontpetit, 20:02:51)
    4. Kevin Luehrs (KLuehrs, 20:03:02)

  1. Current Project Status (KLuehrs, 20:10:27)
    1. WIP to add UNI under network-topology (adetalhouet, 20:12:18)
    2. SB plugin of OVSDB is supported but this is not the end goal, it was more a POC (adetalhouet, 20:12:47)
    3. Currently developing UNI and EVC YANG model. An initial prototype model exists. (KLuehrs, 20:12:51)
    4. the purpose is now to migrate to netconf (adetalhouet, 20:12:57)
    5. Mufaddal says yang model is ready to migrate UNI and EVC under network topology (adetalhouet, 20:13:55)
    6. An updated YANG model integrating UNI Manager with ODL topology manager is ready to be incorporated (KLuehrs, 20:14:11)
    7. Gabriel will integrate new YANG model with integration with Topology by Monday October 12 (KLuehrs, 20:16:38)
    8. We would like to change YANG model but that will be targeted for Boron release (KLuehrs, 20:18:43)
    9. For the Beryllium release we will make a small change to YANG model to add incorporation with ODL Topology Manager. This YANG model is ready for incorporation. The goal is incorporate the new YANG model by October 12. (KLuehrs, 20:20:47)
    10. After incorporating the YANG model the effort will be to implement full CRUD functionality for UNI and EVC (KLuehrs, 20:21:38)
    11. How can we make tasks to be done visible to other resources? (KLuehrs, 20:24:38)
    12. Mufaddal will create a UNI Manager Trello board and start adding tasks and users to it. Alexi and team will also add tasks. (KLuehrs, 20:25:46)
    13. ACTION: Mufaddal will create UNI Manager Trello board and add users. (KLuehrs, 20:26:45)
    14. ACTION: Mufaddal and Alexi will add tasks to the UNI Manager board (KLuehrs, 20:27:04)

  2. UNI Manager M3 Status for Beryllium release (KLuehrs, 20:27:43)
    1. Feature/Functionality Freeze: This refers to karaf features. Example ODL UNI Manager NetConf (KLuehrs, 20:29:34)
    2. ACTION: Gabriel will update UNI Manager with updated YANG model. Goal is to incorporate the YANG model by October 12. (KLuehrs, 20:30:22)
    3. Karaf Features Defined: Refers to features in the karaf feature file. This is already defined. No more is needed for UNI Manager, for Beryllium release (KLuehrs, 20:31:22)
    4. For Karaf Features - deliverable is Jenkins job (KLuehrs, 20:32:20)
    5. Any project must have (1) verify job (push a patch), (2) merge job, (3) installation job. Refer to 'Karaf step by step guide'. (KLuehrs, 20:34:17)
    6. https://jenkins.opendaylight.org/releng/view/unimgr/ (adetalhouet, 20:35:14)
    7. Link to where verify and merge jobs are posted (KLuehrs, 20:35:31)
    8. https://jenkins.opendaylight.org/releng/view/unimgr/ (KLuehrs, 20:35:46)
    9. Documentation Started - Mufaddal posted documentation in UNI Manager Docs project (KLuehrs, 20:36:41)
    10. ACTION: Gabriel and team will review document patch (KLuehrs, 20:37:11)
    11. Feature Test Started: Is this needed given that UNI Manager is an incubation project? Gabriel feels we should create a Robot job. Alexi confirmed we need System test for M3. (KLuehrs, 20:38:54)
    12. ACTION: Gabriel and team will develop a Robot job to create two UNIs and tunnel between them (KLuehrs, 20:40:07)
    13. Test Plan - contains test suites. The test suites are the Robot files. This is documented in the ODL wiki testing page. (KLuehrs, 20:40:47)
    14. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:System_Test:Step_by_Step_Guide System Test How To (adetalhouet, 20:41:09)
    15. some more context about robot: https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Using_Robot_Framework (adetalhouet, 20:41:52)
    16. some more context about CSIT: https://wiki.opendaylight.org/view/CrossProject:Integration_Group:CSIT (adetalhouet, 20:42:03)
    17. Tasks to be completed before the end of the M3: integrate the new YANG file with ODL Topology Manager integration, retain Create and Read for EVC and UNI, and add Delete for EVC and UNI. If possible also add Update for EVC and UNI. (KLuehrs, 20:46:58)

  3. Future Tasks and Direction (KLuehrs, 20:47:53)
    1. Support for additional MEF attributes, including UNI attributes (e.g., MTU size), Class of Service attributes, and Bandwidth Profile attributes (KLuehrs, 20:48:39)
    2. Support for multiple service provider connections: OVC, ENNI (KLuehrs, 20:49:01)
    3. Kevin informed the group about the MEF LSO Hackathon that is scheduled to occur in conjunction with MEF GEN 15 conference (KLuehrs, 20:54:57)
    4. https://wiki.mef.net/display/LH/MEF+LSO+Hackathon (KLuehrs, 20:55:20)
    5. Primary project focus now is to complete the remaining requirements for Beryllium M3 milestone October 15. We estimate we are 60% - 70% complete with the tasks at this point. (KLuehrs, 20:57:17)


Meeting ended at 20:57:23 UTC (full logs).

Action items

  1. Mufaddal will create UNI Manager Trello board and add users.
  2. Mufaddal and Alexi will add tasks to the UNI Manager board
  3. Gabriel will update UNI Manager with updated YANG model. Goal is to incorporate the YANG model by October 12.
  4. Gabriel and team will review document patch
  5. Gabriel and team will develop a Robot job to create two UNIs and tunnel between them


Action items, by person

  1. Mufaddal
    1. Mufaddal will create UNI Manager Trello board and add users.
    2. Mufaddal and Alexi will add tasks to the UNI Manager board
  2. UNASSIGNED
    1. Gabriel will update UNI Manager with updated YANG model. Goal is to incorporate the YANG model by October 12.
    2. Gabriel and team will review document patch
    3. Gabriel and team will develop a Robot job to create two UNIs and tunnel between them


People present (lines said)

  1. KLuehrs (39)
  2. adetalhouet (22)
  3. odl_meetbot (6)
  4. grmontpetit (4)
  5. Mufaddal (0)
  6. Makati (0)


Generated by MeetBot 0.1.4.