#opnfv-armband: armbandMarch25

Meeting started by bobmonkman at 14:14:06 UTC (full logs).

Meeting summary

    1. Alex Avadanii (Enea) (AlexAvadanii1, 14:14:20)
    2. latest ISO built from our repos deploys and passes ostf (self-tests) on non-HA setup, with ODL; HA setup is currently redeployed, seems to work fine too so far (AlexAvadanii1, 14:15:46)
    3. Can Enea give an update on B-release deployment (bobmonkman, 14:15:51)
    4. we are able to able launch VMs without any manual intervention (AlexAvadanii1, 14:16:25)
    5. still refining some UX stuff, like web-browser VNC, or misleading failing tests (AlexAvadanii1, 14:16:53)
    6. Joe, please confirm that Brahameputr deploy HA scenario with SDN works fine (bobmonkman, 14:17:01)
    7. the HA deploy has ODL, does it not? (joekidder, 14:17:19)
    8. there are some expected fails with HA self-tests, since gic v3 does not yet support migrate (not upstream in kernel, nor in qemu for now) (AlexAvadanii1, 14:17:25)
    9. joekidder: yes, HA deploy with ODL, what is left testing there is ceph (AlexAvadanii1, 14:17:41)
    10. thanks, alex. (joekidder, 14:17:53)
    11. wel I think HA is orthogonal to ODL or no ODL (bobmonkman, 14:18:05)
    12. team, i believe this means we can declare that Brahamutra reference stack on ARM officially deploys!!! (bobmonkman, 14:18:52)
    13. if you were to grab the latest armband git repo and the latest linux.enea.com packages, you should get a fully working ISO; some minor patches are still refined, but they do not prevent a succeful deploy with Fuel (AlexAvadanii1, 14:19:04)
    14. Testing phase now and congrats to the team (bobmonkman, 14:19:27)
    15. yes, we still need to run functest and assess the results, but the deloy is working. Great milestone (bobmonkman, 14:20:13)
    16. the rest of the team may not have known this earlier (bobmonkman, 14:20:34)
    17. so what does pushing to gerrit mean? Please elaborate (bobmonkman, 14:21:27)
    18. Currently we are working on gitlab repository that I've created. From time to time we're pushing to opnfv gerrit when we have quasi-stable state (StanKardach, 14:22:15)
    19. we used an internal repo, which we migrated to armband repo (gerrit) as squashed patch-sets (AlexAvadanii1, 14:22:25)
    20. current armband repo is 2-3 commits behind internal repo, mostly fixing UX issues (AlexAvadanii1, 14:22:47)
    21. OK, so bringing into an opnfv established repo...thank you (bobmonkman, 14:23:08)
    22. yes, please give Stan rights to armband, this is why gerrit is lagging :) (AlexAvadanii1, 14:23:13)
    23. bob - do you need me to re-send you and aric (?) the committer votes? I have them in my inbox (the votes were all public, so I'm not sure what the issue is). (joekidder, 14:23:58)
    24. apologies. I have opened to ticket to reflect the vote, but the project has asked for the email approval trail, which I will do today, then Stan will be official committer along with other two (bobmonkman, 14:24:29)
    25. anyone using linux.enea.com: keep in mind this is Amazon EC2, if you can use a local mirror of that, we would greatly appreciate it, thank you (AlexAvadanii1, 14:24:33)
    26. We'd need official space to host all the packages that we've prepared. EC2 is not the most cost-effective way (StanKardach, 14:25:18)
    27. Can I please get an update on connecting to Jenkins? How is that process going? (bobmonkman, 14:26:48)
    28. josep: can you give jenkins update? (joekidder, 14:28:00)
    29. bobmonkman: there are two tracks, deploy and buiild. I have been looking at the different configuration files required for deployments, but I am not there yet (josep, 14:29:28)
    30. Josep: So do you have what you need to keep going or is there a blocker? (bobmonkman, 14:30:54)
    31. bobmonkman: I'll need help from fuel (josep, 14:31:49)
    32. bobmonkman: but I don't see any obvious blockers (except maybe that the deploy script uses ipmitool, which won't work great on some targets) (josep, 14:32:34)
    33. but I have not come that far yet to tell (josep, 14:33:01)
    34. OK, Joe I assume can help facilitate that and then do we have any idea of how long we expect the process to be to get started tetsing under Jenkins? (bobmonkman, 14:33:03)
    35. some aarch64 "servers" do not support out-of-band power control - e.g. APM (AlexAvadanii1, 14:33:14)
    36. @Alex: so is there a way around such limiitations as cannot run ipmi on a given box? (bobmonkman, 14:34:18)
    37. I want to get some sort of estimate as to when we could be ready with Jenkins, please (bobmonkman, 14:36:05)
    38. simple workaround is a network power switch, as that's what most of ipmi is used for (I believe) in this setup - to reboot machines. (joekidder, 14:36:11)
    39. Can we get a Functest update as well? (bobmonkman, 14:36:23)
    40. bobmonkman: in our case, we might have something, as we use some powercontrollers that support SNMP, and we can power-on/off the targets with those, but it's not a universal solution (AlexAvadanii1, 14:36:56)
    41. bobmonkman: as far as I've seen, the deploy script powers on/off the targets, and uses ipmi for that. It also sets the default boot order this way (josep, 14:37:06)
    42. for virtual deployments it uses libvirt, though (there is a class abstracting all this) (josep, 14:37:59)
    43. , so it appears we wil have to request a change to the deploy scripts for targets that do not support ipmi (bobmonkman, 14:38:00)
    44. this is something we could contribute if necessary, I believe (josep, 14:38:50)
    45. there is no workaround for boot order though, not without adding a serial controller to the setup, which again, we do have in our lab, but not an universal solution (AlexAvadanii1, 14:38:53)
    46. ...ok something to note as to how to work with Octopus team or whomever to decide how to handle power cycle and boot order more generically (bobmonkman, 14:40:16)
    47. bobmonkman: hard to give a time estimate for jenkins, but not by next week (josep, 14:40:48)
    48. OK, josep....we will revisit in 2 weeks. No meeting next week due to holiday break. (bobmonkman, 14:41:29)
    49. ,, Ciprian please use #info so we capture in minutes bot (bobmonkman, 14:45:58)
    50. unfortunately I had near zero success in running on Fuel 8, I had multiple problems in my way (ciprian-barbu, 14:46:16)
    51. I encountered a few bugs as well, I had to spent time debugging (ciprian-barbu, 14:46:23)
    52. I had a problem with the network setup in the lab, I could only run functest on POD1, which turns out has a problem with libvirt (ciprian-barbu, 14:46:33)
    53. I thought the libvirt problem was solved? (bobmonkman, 14:47:05)
    54. yesterday Magnus from IT solved the connectivity problem to POD2, so I managed to actually start working on that (ciprian-barbu, 14:47:09)
    55. I am continuing with this, I've been delayed so far (ciprian-barbu, 14:48:22)
    56. to be clear, Ciprian, you are seeing failures on Functest, when running Fuel 8 based deploy, that you were not seeing before on Fuel 6? (bobmonkman, 14:48:33)
    57. no, there were a few minor things, keystone client has been deprecated and that was an easy fix (ciprian-barbu, 14:49:26)
    58. but in fact I wasn't able to run functest at all on Fuel 8 (ciprian-barbu, 14:49:48)
    59. in fact, I tried to run, but I bumped into this issue that seems like libvirt related (ciprian-barbu, 14:50:52)
    60. I'm not 100% sure about it, could be something else (ciprian-barbu, 14:51:04)
    61. OK, team, lets cme up with a plan for the next 2 weeks to help find out why Functest will not run. This is central to connecting to Jenkins and being in CI loop (bobmonkman, 14:51:57)
    62. Joe, can you please work with the team to get on top of this? (bobmonkman, 14:52:49)
    63. yep. (joekidder, 14:52:56)
    64. ACTION: Bob will send IT the committer vote log and committer drop confirmations (bobmonkman, 14:54:09)
    65. ACTION: Joe will work with the team to get over Functest issues (bobmonkman, 14:54:40)
    66. Next team meeting will be 2 weeks from today. I will be out for the holiday week and will check in early in the week of April 4 (bobmonkman, 14:56:06)
    67. we would need a bit of help with DHA/DEA files (StanKardach, 14:56:12)
    68. we can't seem to find documentation on them and they seem vital in understanding how the deployment testing works (StanKardach, 14:56:40)
    69. @StanK: Could this be an Octopus item? Fuel? (bobmonkman, 14:57:26)
    70. I'm almost sure it's not Mirantis related but rather OPNFV-Fuel related (StanKardach, 14:58:03)
    71. I'm not sure if it's present in other installers as I'm not familiar with them (StanKardach, 14:58:24)
    72. OK, I suggest sending a question to the list asking for help. (bobmonkman, 14:58:47)
    73. ACTION: Stan to ask Fuel team for help on documentation of DHA/DEA procedures (bobmonkman, 15:00:17)


Meeting ended at 15:02:00 UTC (full logs).

Action items

  1. Bob will send IT the committer vote log and committer drop confirmations
  2. Joe will work with the team to get over Functest issues
  3. Stan to ask Fuel team for help on documentation of DHA/DEA procedures


People present (lines said)

  1. bobmonkman (44)
  2. AlexAvadanii1 (18)
  3. ciprian-barbu (16)
  4. joekidder (12)
  5. josep (12)
  6. StanKardach (11)
  7. bin_ (4)
  8. collabot` (3)


Generated by MeetBot 0.1.4.