#opnfv-armband: armband-weekly

Meeting started by joekidder at 14:02:26 UTC (full logs).

Meeting summary

  1. roll-call (joekidder, 14:02:58)
    1. Joe Kidder (joekidder, 14:03:04)
    2. Josep Puigdemont (joseppc, 14:03:06)
    3. Florin Dumitrascu (florind, 14:03:17)
    4. we are on the go to meeting setup if anyone wants to join. I didn't realize (or forgot) that Bob indicated we might not have the meeting, although he asked me to chair today. (joekidder, 14:04:39)
    5. so I didn't send out a reminder. (joekidder, 14:04:57)

  2. status of ISO (joekidder, 14:07:43)
    1. currently the velocity of changes to the Fuel ISO for armband has decreased significantly indicating a level of stability (joekidder, 14:08:19)
    2. there was a change last week to support mongodb (a feature needed for ceilometer) (joekidder, 14:08:43)
    3. we are currently making some changes related to interface ordering that are needed for predictable/reproducible behavior in automated deployments under Jenkins. (joekidder, 14:09:26)
    4. all of the work is being done in the public repo (for packages, etc retrieved by Fuel) and in the opnfv-armband git repo. (joekidder, 14:10:07)

  3. status of Functest (joekidder, 14:10:24)
    1. Currently debugging vping-ssh issues. Sometimes this passes, but after it has run, we see some network misbehavior. We are still characterizing this and investigating. (joekidder, 14:11:17)
    2. Alexandru Avadanii (Enea) (AlexAvadanii, 14:11:32)
    3. we are looking at both ODL-L2 and ODL-L3 scenarios to see if there's any difference. (joekidder, 14:11:48)
    4. Mike Rooke (NokMikeR, 14:11:52)
    5. Mike Holmes (MikeHolmes, 14:13:29)
    6. tempest passes all tests in nosdn scenario. Investigating failures (between 2 and 25 failures out of 200) on L2 and L3 scenarios. (joekidder, 14:13:51)
    7. rally much better...failling heat (seems like an administrative problem) nova (2 out of 12, but migration-related...see following comment), and VM tests related to networking that may be due to network problems introduced by vping-ssh. (joekidder, 14:15:02)
    8. there are issues with migration due to some support not yet upstreamed, and therefore not consistent across all server platforms. We do not expect to pass migration tests at this time in a generic setting such as we're aiming for. (joekidder, 14:16:01)
    9. we can discuss migration and issues if desired. (joekidder, 14:16:14)

  4. status CI/Jenkins (joekidder, 14:16:34)
    1. we arer stabilizing an all-CaviumThunder pod (due to IPMI availability and its requirement for CI integration). (joekidder, 14:17:14)
    2. this is up and we're testing manual deployment prior to running automated jenkins deployment. (joekidder, 14:17:47)
    3. half the commits in armband repo (gerrit) are now rebases due to upstream repo changes (AlexAvadanii, 14:20:16)
    4. a jenkins build script is ready for discussion/review with fatih from octopus to answer a few questions as well as do some review, as it needs to go to the octopus git rather than armband. (joekidder, 14:22:50)
    5. the perceived risk/concern around the build script is low - it seems pretty straightforward, and we're focusing on the deploy script. (joekidder, 14:23:24)

  5. migration (joekidder, 14:24:04)
    1. Mike Holmes and Alex discussed the normalization and consolidation of migration needs in the kernel and whether Linaro kernel folks can help with this. (joekidder, 14:24:59)
    2. AP Alex (Enea) + Stan (Cavium) to talk with Linaro about GICv3 migration support in upstream kernel / qemu (AlexAvadanii, 14:25:00)
    3. ACTION: Alex (Enea) + Stan (Cavium) to talk with Linaro about GICv3 migration support in upstream kernel / qemu (AlexAvadanii, 14:25:31)


Meeting ended at 14:27:42 UTC (full logs).

Action items

  1. Alex (Enea) + Stan (Cavium) to talk with Linaro about GICv3 migration support in upstream kernel / qemu


People present (lines said)

  1. joekidder (25)
  2. AlexAvadanii (5)
  3. collabot (3)
  4. joseppc (1)
  5. MikeHolmes (1)
  6. florind (1)
  7. NokMikeR (1)


Generated by MeetBot 0.1.4.