#opnfv-armband: armband 02Sept2016

Meeting started by bobmonkman at 14:05:23 UTC (full logs).

Meeting summary

    1. Alexndru Avadanii (Enea) (AlexAvadanii, 14:05:30)
    2. Dan Lilliehorn and Thomas Lundström (Enea) (dali`, 14:05:45)
    3. Florin Dumitrascu (Enea) (florind, 14:06:25)
    4. Ciprian Barbu (Enea) (ciprian-barbu, 14:07:06)
    5. http://artifacts.opnfv.org/armband/docs/index.html and http://artifacts.opnfv.org/armband/docs.pdf (AlexAvadanii, 14:07:33)
    6. Bob Monkman (bobmonkman, 14:10:10)
    7. status on Functest (bobmonkman, 14:10:37)
    8. https://build.opnfv.org/ci/view/armband/job/functest-fuel-arm-pod1-daily-master/34/console (ciprian-barbu, 14:11:18)
    9. the only failure is Doctor test introduced which has the same x86 hard coded cirrus issue (bobmonkman, 14:13:10)
    10. https://git.opnfv.org/cgit/doctor/tree/tests/run.sh (ciprian-barbu, 14:13:48)
    11. should be straightforward to solve this and in being worked on. (bobmonkman, 14:13:50)
    12. Mike Holmes (mikeH, 14:14:12)
    13. there has been a general Parser issues (all archs) and this test scenario has been removed and is being worked on by Parser team (bobmonkman, 14:16:58)
    14. CI Loop configuration (bobmonkman, 14:17:51)
    15. https://build.opnfv.org/ci/view/armband_section (AlexAvadanii, 14:18:18)
    16. https://build.opnfv.org/ci/view/armband_sections/ (AlexAvadanii, 14:18:31)
    17. reworking the CI Loop configuration to be flexible to invoke on any pod (bobmonkman, 14:18:34)
    18. goal is to run same CI jobs on 3 different pods with hardware from Cavium, AMD and Applied Micro servers (bobmonkman, 14:20:04)
    19. improving dramatically the deploy scripts and ios builds (bobmonkman, 14:20:47)
    20. Fuel merge update (bobmonkman, 14:20:56)
    21. Fuel team merged many of our Armband patches previously created and that means we have fewer patches to maintain in our own repo (bobmonkman, 14:21:45)
    22. fixed a long running bug on extra backup operation and this allowed us to clean up workarounds and remove documentation extras steps (bobmonkman, 14:22:58)
    23. Yardstick was pretty hard coded for x86 and a major patch to allow ARM64 has been merged now on master branch and when it passes all tests it will be much easier to run Yardtsick on ARM servers (bobmonkman, 14:25:36)
    24. ACTION: Bob to connect ARM engineers to Paul/Yardsticke work to see if additional help can be made available to assess Yardstciks tests that are not meeting all the thresholds (bobmonkman, 14:28:27)
    25. Yardstick release criteria wiki page is still incomplete. Does not seem ready to prime time. (bobmonkman, 14:32:15)
    26. ACTION: tech leads will bring this up in release meeting and seek to gain agreement that this cannot be a release criteris in this late stage. (bobmonkman, 14:34:37)
    27. JIRA open/unassigned tickets discussions (bobmonkman, 14:36:24)
    28. 4 open tickets only that we consider bugs to be fixed before release (bobmonkman, 14:36:48)
    29. the rest are merely tasks tracking (bobmonkman, 14:37:00)
    30. we believe we are on track to close these out for 15 Spet deadline (bobmonkman, 14:38:56)


Meeting ended at 14:39:46 UTC (full logs).

Action items

  1. Bob to connect ARM engineers to Paul/Yardsticke work to see if additional help can be made available to assess Yardstciks tests that are not meeting all the thresholds
  2. tech leads will bring this up in release meeting and seek to gain agreement that this cannot be a release criteris in this late stage.


People present (lines said)

  1. bobmonkman (23)
  2. AlexAvadanii (4)
  3. ciprian-barbu (3)
  4. collabot (3)
  5. florind (1)
  6. dali` (1)
  7. mikeH (1)


Generated by MeetBot 0.1.4.