#opnfv-cperf: cperf

Meeting started by dfarrell07 at 19:03:51 UTC (full logs).

Meeting summary

    1. Lots of ODL perf testing going on this week to prep whitepaper for ONS (dfarrell07, 19:04:41)
    2. https://docs.google.com/document/d/10bYHHnMU5pSBJvNON9uVheRq-E1pqGjqp-fIIRZX_yo/edit?usp=sharing ODL perf whitepaper being created for ONS (dfarrell07, 19:05:20)
    3. Al LuisGomez and dfarrell07 will be at ONS next week (dfarrell07, 19:17:16)
    4. Nikos suggested a "what is sdn perf; which metrics; which tools" panel for OPNFV summit (dfarrell07, 19:17:46)
    5. ACTION: dfarrell07 will submit a OPNFV panel CFP for perf topics (dfarrell07, 19:18:10)
    6. LuisGomez points out that ODL perf is about the same as other SDN controllers (lessons from this week's whitepaper efforts) (dfarrell07, 19:18:54)
    7. dfarrell07 and LuisGomez point out that a big diff b/t ODL and other controllers is how many features ODL supports - ODL openflow plugin is about the same as other controllers (dfarrell07, 19:19:32)
    8. Al and LuisGomez talk about getting CPerf feedback to IETF group Al leads (dfarrell07, 19:19:52)
    9. Marcus is working on perf testing intensely this week, not on call (dfarrell07, 19:20:09)
    10. jamoluhrsen has been working on clustering and a bit of perf stuff for ONS (dfarrell07, 19:20:22)
    11. ACTION: dfarrell07 needs to get CPerf in OPNFV C release (dfarrell07, 19:21:53)
    12. https://tools.ietf.org/html/draft-bhuvan-bmwg-of-controller-benchmarking-00 (LuisGomez, 19:22:38)
    13. Nikos and Al have continued email-based discussion about perf testing methods/metrics/extensions to tools (dfarrell07, 19:23:28)
    14. Nikos has been working on next paper - will compare Li vs Be perf (dfarrell07, 19:26:52)
    15. Nikos is seeing much better switch scale data li->be (dfarrell07, 19:27:23)
    16. discussion about OVS versions - 2.3 is fine, but ODL upstream is seeing issues with 2.4 and 2.5 (scale) (dfarrell07, 19:35:25)
    17. upstream ODL is working on >2.3 scale issues, LuisGomez will raise hell about it on OFP call next week to encourage progress (dfarrell07, 19:36:00)
    18. discussion about NB tests Nikos is using, LuisGomez points out that they are likely more realistic/useful than reactive flow programming from SB (dfarrell07, 19:36:26)
    19. we may not meet next week due to ONS (dfarrell07, 19:36:41)


Meeting ended at 19:36:45 UTC (full logs).

Action items

  1. dfarrell07 will submit a OPNFV panel CFP for perf topics
  2. dfarrell07 needs to get CPerf in OPNFV C release


Action items, by person

  1. dfarrell07
    1. dfarrell07 will submit a OPNFV panel CFP for perf topics
    2. dfarrell07 needs to get CPerf in OPNFV C release


People present (lines said)

  1. dfarrell07 (24)
  2. collabot` (4)
  3. LuisGomez (2)
  4. jamoluhrsen (1)


Generated by MeetBot 0.1.4.