#opnfv-cperf: cperf

Meeting started by dfarrell07 at 18:16:44 UTC (full logs).

Meeting summary

    1. dfarrell07 has been helping Veryx people make progress on PktBlaster test (dfarrell07, 18:19:08)
    2. dfarrell07 wrote docs about how to define jobs, add tests to CPerf (dfarrell07, 18:19:21)
    3. https://wiki.opnfv.org/display/cperf/Adding+Tests new CPerf docs about adding tests (dfarrell07, 18:19:50)
    4. Al has updated his JIRA with info about IETF draft updates/progress relevant to us (dfarrell07, 18:20:28)
    5. Al talks about draft, and test about path creation. We don't do this he thinks. Idea is to create a path and test path in dataplane. (dfarrell07, 18:23:25)
    6. Nikos can/should use the adding test docs dfarrell07 wrote as well (dfarrell07, 18:23:47)
    7. Can imagine this path test as a perf test, how fast can we create paths between OVSs (dfarrell07, 18:25:22)
    8. dfarrell07 and jamoluhrsen think we have the basic keywords required to do such a test in ODL CSIT already, wouldn't be crazy hard to add (dfarrell07, 18:26:20)
    9. Al clarifies that switches would be connected to ODL already, then to ODL NB we say "make this path", then time how long until pings work (dfarrell07, 18:26:49)
    10. Would also want to take away protocol details, don't really care if OF (dfarrell07, 18:27:42)
    11. Black box: Two hosts connected, tell controller to make path, how long until they can talk to each other (dfarrell07, 18:27:59)
    12. So, I guess we're looking for someone to take this TODO, write this test (dfarrell07, 18:28:16)
    13. Discussion about sharing POD (dfarrell07, 18:35:43)
    14. dfarrell07 talks about idea of federating dev pods, allowing them to be checked out (dfarrell07, 18:35:58)
    15. AGREED: We are okay with sharing our POD in this federated way, as long as we can check it out for long periods of time to do dev work (like with broken deployments) (dfarrell07, 18:36:28)
    16. mgkwill reports progress on ODL with OpenStack full deploy, many compute nodes, Rally for testing (dfarrell07, 18:37:30)
    17. this OpenStack test is making progress, but contractor's work needs some review from mgkwill (dfarrell07, 18:37:59)
    18. jamoluhrsen has given some CPerf cycles to getting job running, standard run, see a fairly normal problem, fix, re-run (dfarrell07, 18:40:05)
    19. Job is running for ~10 mins now before failing, so good (dfarrell07, 18:40:22)
    20. Question about OS on boxes, none have OS except jumphost, this is how it's supposed to be says mgkwill, Apex will install OS once we get that far in deploy (dfarrell07, 18:41:01)
    21. https://build.opnfv.org/ci/view/All/job/apex-runner-cperf-colorado/ <--- cperf parent job (jamoluhrsen, 18:41:27)
    22. Build with Params that^ (dfarrell07, 18:41:44)
    23. https://build.opnfv.org/ci/job/apex-deploy-baremetal-os-odl_l2-nofeature-ha-colorado/ <--- cperf deploy job (jamoluhrsen, 18:41:49)
    24. To kick off this job^ (dfarrell07, 18:41:58)
    25. mgkwill et all can help by doing that process, finding whatever's failing, fixing and rerunning (dfarrell07, 18:42:21)
    26. Al reports that Jack had said he would be moving Intel POD after OpenStack summit, so they will likely break us next week (dfarrell07, 18:43:30)


Meeting ended at 18:44:03 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. dfarrell07 (26)
  2. collabot (3)
  3. jamoluhrsen (2)


Generated by MeetBot 0.1.4.