#opnfv-doctor: doctor

Meeting started by r-mibu at 12:55:58 UTC (full logs).

Meeting summary

  1. roll call (r-mibu, 12:56:06)
    1. Ryota Mibu (r-mibu, 12:56:11)
    2. Tomi Juvonen (tojuvone, 12:58:30)
    3. Ildiko Vancsa (ildikov, 13:00:16)
    4. Gerald Kunzmann (GeraldK, 13:01:09)
    5. Bertrand Souville (bertys, 13:01:34)
    6. Maryam Tahhan (maryamtahhan, 13:03:27)
    7. Bryan Sullivan (bryan_att, 13:03:59)
    8. Tommy Lindgren (TommyL, 13:04:04)
    9. https://review.openstack.org/#q,topic:bp/event-alarm-evaluator,n,z (GeraldK, 13:05:39)
    10. last week 2 patches got merged; one additional patch proposed 3 days ago (already merged today) (GeraldK, 13:06:51)
    11. Ceilometer blueprint approved (GeraldK, 13:07:15)
    12. Dan Druta (dandruta, 13:07:39)
    13. we can again focus on specification / documentation (GeraldK, 13:07:51)

  2. Nova BP (r-mibu, 13:08:09)
    1. https://blueprints.launchpad.net/nova/+spec/robustify-evacuate (GeraldK, 13:08:27)
    2. this BP has relation to our work. currently for Liberty, but Tomi has doubts it will be accepted for Liberty (GeraldK, 13:08:52)
    3. there might be situations where bad decisions could be made and data could be deleted (GeraldK, 13:09:30)
    4. this BP is trying to fix this bug which is related to Doctor (GeraldK, 13:09:58)
    5. Tomi is currently working on documentation of mark-host (GeraldK, 13:10:50)
    6. plan is to make documentation available for Doctor and maybe also for OpenStack (GeraldK, 13:12:01)
    7. ACTION: Tomi to create Jira ticket for this documentation work on the mark-host-down (GeraldK, 13:12:22)
    8. the BP is related to Doctor some point, no action as doctor project so far (r-mibu, 13:14:51)
    9. https://review.openstack.org/#/c/192246/ (GeraldK, 13:15:38)
    10. ACTION: Tomi to create Jira ticket for "Get valid server state" (GeraldK, 13:16:28)

  3. Pinpoint project (GeraldK, 13:17:13)
    1. https://wiki.opnfv.org/pinpoint/pinpoint_project_proposal (GeraldK, 13:17:32)
    2. Adi is presenting the proposal; seems there is overlap between Pinpoint and Doctor (GeraldK, 13:18:21)
    3. project is currently focusing on "NFV networking" and is related to RCA and fault localization (GeraldK, 13:19:51)
    4. goal is to find root cause for several problems being observed (GeraldK, 13:20:36)
    5. different APIs proposed: NB I/F to user/system; SB I/Fs to OAM tools, Fault information DB, System configuration DB, system model DB (GeraldK, 13:21:32)
    6. interfaces to Neutron, Nova, Ceilometer, Monasca, Cinder, ... (GeraldK, 13:23:13)
    7. proposal is to have Fault Correlator for NFVI collecting and correlating faults in virtual and physical infrastructure (GeraldK, 13:25:00)
    8. focus on offline network state analytics (GeraldK, 13:25:30)
    9. Ryota: in Doctor project there are 4 functional blocks: Ceilometer is used as Notifier (GeraldK, 13:28:27)
    10. Adi: Pinpoint has different focus than Doctor; e.g. find configuration mistake (GeraldK, 13:29:57)
    11. Gerald: RCA is important project, but concern is that new NB I/F is not aligned with ETSI NFV (GeraldK, 13:33:07)
    12. Tommy: what is the use case here? help the tenant/cloud to extract root cause from a huge number of logs; help IP manager (GeraldK, 13:33:57)
    13. Tommy: in the shown MANO architecture most of the arrows in the proposal go to the OSS side (GeraldK, 13:35:37)
    14. Ryota: for Doctor project we are providing NB I/F to user that cannot see the infrastructure, whereas in PinPoint the user can see the infrastructure, thus the NB I/F might be different. PinPoint may extend the Doctor inspector. (GeraldK, 13:37:37)
    15. we can work together on how to learn about events and send notifications about faults (GeraldK, 13:38:09)
    16. Bryan: what's relationship to Predictor? Adi: Prediction is another analyticts using similar input, but running different algorithms and producing differnet output (predict failures vs analyze existing failures) (GeraldK, 13:41:25)
    17. Bryan: there is commonality between the data sources used. which project would work on the data sources side? (GeraldK, 13:42:02)
    18. Bryan: what is common for Pinpoint, Doctor, Predictor is what data sources are being used. (GeraldK, 13:44:25)
    19. Bryan: we should not have OPNFV projects that are so close that people should join multiple projects on similar topic (GeraldK, 13:44:54)
    20. Gerald: isn't there big overlap in fault correlation in the above projects? (GeraldK, 13:46:45)
    21. Adi: different information type is needed to predict fault. (GeraldK, 13:47:10)
    22. Adi: regarding Pinpoint and Doctor there is similarity. Pinpoint is more offline analytics. proposal that fault correlation can be worked in Doctor. Fault correlation is not the main topic in both projects. (GeraldK, 13:49:17)
    23. Larry: in practise in a real system only few faults should occur (GeraldK, 13:50:17)
    24. Larry: analytics should not be run by the entity detecting the fault, but some entity in a higher layer having a wider view and understanding of the system (GeraldK, 13:54:22)
    25. Al Morton: it would be good to differentiate transient and steady-state failures. (GeraldK, 13:55:24)
    26. Ryota: wants to see use case of Pinpoint to better understand motivation of the project and difference to Doctor (GeraldK, 13:56:03)
    27. Adi: plan is to start with use cases (GeraldK, 13:57:12)
    28. we'll continue discussion on the mailing list (r-mibu, 14:03:33)


Meeting ended at 14:03:38 UTC (full logs).

Action items

  1. Tomi to create Jira ticket for this documentation work on the mark-host-down
  2. Tomi to create Jira ticket for "Get valid server state"


People present (lines said)

  1. GeraldK (48)
  2. r-mibu (10)
  3. collabot (8)
  4. ildikov (1)
  5. tojuvone (1)
  6. bryan_att (1)
  7. TommyL (1)
  8. bertys (1)
  9. maryamtahhan (1)
  10. dandruta (1)


Generated by MeetBot 0.1.4.