#opnfv-doctor: doctor

Meeting started by r-mibu at 13:59:27 UTC (full logs).

Meeting summary

    1. Carlos Goncalve (cgoncalves, 14:00:11)
    2. Tomi Juvonen (tojuvone, 14:00:24)

  1. roll call (r-mibu, 14:00:46)
    1. Ryota Mibu (r-mibu, 14:00:51)
    2. Ildiko Vancsa (ildikov, 14:01:05)
    3. https://etherpad.opnfv.org/p/doctor_meetings (r-mibu, 14:03:06)
    4. Gerald Kunzmann (GeraldK, 14:04:02)
    5. Dan Druta (dandruta, 14:06:39)

  2. OPNFV Summit Report (r-mibu, 14:08:16)
    1. https://wiki.opnfv.org/meetings/doctor#nov_9-10_2015 (r-mibu, 14:08:33)
    2. Tommy Lindgren (TommyL, 14:08:47)
    3. Doctor presentation was attended by 40-50 people (cgoncalves, 14:12:26)
    4. https://wiki.opnfv.org/_media/doctor/opnfv_doctor_20151111.final.pptx (cgoncalves, 14:12:46)
    5. Around 200 people visit us at the NTT DOCOMO booth (cgoncalves, 14:13:12)
    6. Doctor project also had a demo (cgoncalves, 14:13:26)
    7. https://wiki.opnfv.org/_media/opnfv_doctordemo_20151111.final.pptx (cgoncalves, 14:13:33)

  3. Functest (r-mibu, 14:14:19)
    1. https://jira.opnfv.org/browse/DOCTOR-22 (r-mibu, 14:14:34)
    2. DOCTOR-22 was updated based on discussion with functest team in OPNFV Summit (GeraldK, 14:15:40)
    3. discussion on detailed functest process. if someone else is uploading a new patch/code and this breaks Doctor functests, the other persons should be responsible to fix the issue with help by Doctor team (GeraldK, 14:34:07)
    4. Carlos proposes a similar procedure as in OpenStack where each new commit will trigger code/functionality validation (GeraldK, 14:35:01)
    5. Bryan suggests the intended process should be captured in some document (GeraldK, 14:39:06)
    6. Carlos suggests adding OPNFV CI to upstream projects (e.g. OpenStack, OpenDaylight) as Jenkins slave. Such slave would run OPNFV validation tests and report back to upstream projects and OPNFV about some test failure/requirement violation. If new commit in upstream breaks OPNFV requirements, the contribution should not be rejected (cgoncalves, 14:39:07)
    7. action ryota to update test responsibility with functest team (r-mibu, 14:39:28)
    8. action carlos to check OPNFV CI against upstream (OpenStack) (r-mibu, 14:41:40)
    9. ACTION: Doctor team to help review Cinder mark-down blueprint https://review.openstack.org/#/c/238832/ (cgoncalves, 14:43:47)

  4. Puppet Script for Congress Integration (r-mibu, 14:44:14)
    1. https://etherpad.opnfv.org/p/doctor_use_case_for_b_release (r-mibu, 14:46:21)
    2. https://jira.opnfv.org/browse/GENESIS-59 (r-mibu, 14:48:15)
    3. ACTION: Ildiko to check if Aodh is also included (GeraldK, 14:48:37)
    4. Bryan is concerned that a Jira ticket does not mean someone will actually work on this task (GeraldK, 14:49:46)
    5. Bryan had talked to Installer team and seems they do not have resources to work on all requirement components of all projects, so it would require Doctor team to work on this (GeraldK, 14:52:41)
    6. Carlos is assuming that Genesis team will take care; at least this would be preferred (GeraldK, 14:53:13)

  5. JIRA Issue check (r-mibu, 14:54:27)
    1. https://jira.opnfv.org/browse/DOCTOR-46?jql=project%20%3D%20DOCTOR%20and%20duedate%20%3C%20now() (r-mibu, 14:55:10)
    2. Projects bringing requirements to OPNFV installers would also need to learn about each installer and that's time-consuming. a collaborative task force from both sides is of paramount (cgoncalves, 14:55:27)


Meeting ended at 14:59:37 UTC (full logs).

Action items

  1. Doctor team to help review Cinder mark-down blueprint https://review.openstack.org/#/c/238832/
  2. Ildiko to check if Aodh is also included


People present (lines said)

  1. r-mibu (19)
  2. cgoncalves (9)
  3. GeraldK (9)
  4. collabot` (6)
  5. ildikov (2)
  6. tojuvone (1)
  7. TommyL (1)
  8. dandruta (1)


Generated by MeetBot 0.1.4.