#opnfv-doctor: doctor

Meeting started by r-mibu at 14:00:24 UTC (full logs).

Meeting summary

  1. roll call (r-mibu, 14:00:32)
    1. Carlos Goncalves (cgoncalves, 14:00:35)
    2. Tomi Juvonen (tojuvone, 14:00:37)
    3. Ildiko Vancsa (ildikov, 14:03:02)
    4. Tommy L (TommyL, 14:04:11)
    5. Maryam Tahha (mtahhan, 14:04:54)

  2. agenda bashing (r-mibu, 14:04:58)
    1. Gerald Kunzmann (GeraldK, 14:04:59)
    2. https://etherpad.opnfv.org/p/doctor_meetings (r-mibu, 14:05:07)
    3. Dan Druta (dandruta, 14:05:11)

  3. doctor docs (r-mibu, 14:07:12)
    1. reminder: next milestone for Brahmaputra is in one month (GeraldK, 14:07:21)
    2. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-December/006948.html (r-mibu, 14:08:37)
    3. https://jira.opnfv.org/browse/DOCTOR-3 (r-mibu, 14:09:47)
    4. https://gerrit.opnfv.org/gerrit/#/c/856/ (r-mibu, 14:10:13)
    5. ACTION: Carlos to finish by MS-E (GeraldK, 14:13:17)
    6. https://jira.opnfv.org/browse/DOCTOR-11 (r-mibu, 14:13:22)
    7. ACTION: Bertrand to create rst file, preferrably by MS-E, but latest by next OPNFV Summit (GeraldK, 14:14:52)
    8. https://wiki.opnfv.org/_media/doctor/opnfv_doctor_20151013.pptx current version of the flow (GeraldK, 14:16:10)
    9. https://jira.opnfv.org/browse/DOCTOR-17 (r-mibu, 14:16:55)
    10. Ryota will work on this task within this year to ensure it is included in Brahmaputra (GeraldK, 14:18:14)

  4. Cinder BP (r-mibu, 14:19:51)
    1. https://review.openstack.org/#/c/238832/ (r-mibu, 14:21:26)
    2. ZTE last week has had discussion with Cinder core reviewer (GeraldK, 14:21:52)
    3. mark host down in Cinder seems to make no sense (GeraldK, 14:22:10)
    4. https://github.com/openstack/cinder-specs/blob/master/specs/mitaka/cinder-volume-active-active-support.rst (r-mibu, 14:22:20)
    5. https://github.com/openstack/cinder-specs/blob/master/specs/mitaka/ha-aa-tooz-locks.rst (r-mibu, 14:22:41)
    6. new approach is change to "service group BP" (GeraldK, 14:24:12)
    7. Ryota is asking whether one BP is sufficient? (GeraldK, 14:25:49)
    8. other areas like active-active-volumnes are addressed by other Cinder members? (GeraldK, 14:26:52)
    9. yes (GeraldK, 14:31:02)
    10. is there any deadline for the Cinder BP proposal? (GeraldK, 14:31:18)
    11. http://lists.openstack.org/pipermail/openstack-dev/2015-November/078222.html (r-mibu, 14:31:38)
    12. Larry Lamers (ljlamers, 14:31:39)
    13. deadline for BP approval in cinder is Jan 19 (r-mibu, 14:32:11)
    14. ZTE currently is investigating how to best start this new BP (GeraldK, 14:32:53)

  5. Neutron RFE (r-mibu, 14:34:11)
    1. https://bugs.launchpad.net/neutron/+bug/1513144 (r-mibu, 14:34:30)
    2. core reviewers have different idea to realize the feature than we had implemented for Nova (GeraldK, 14:36:43)
    3. new idea is to allow admins to evacuate the agents. (GeraldK, 14:37:30)
    4. seems there is now some agreement from some core reviewers. Carlos would like to discuss this in Doctor meeting. (GeraldK, 14:37:59)
    5. Ildiko: is this automated reaction (evacuation) in scope of Doctor project? (GeraldK, 14:38:43)
    6. Neutron already has this evacuation action in place. this is available for Layer-3 and HCP agents. (GeraldK, 14:39:43)
    7. Zabbix could report issues to the admin and admin could call this new API to evacuate the node. (GeraldK, 14:40:22)
    8. what would be end result of a network evacuation? would be transparent to the user; e.g. a router software may be moved to a different phyiscal host (GeraldK, 14:43:05)
    9. but also just could mean moving the agent (GeraldK, 14:43:18)
    10. you may have ACT-SBY or just ACT configuration (GeraldK, 14:44:02)
    11. this step would be related to the recovery actions (GeraldK, 14:45:50)
    12. Neutron can already do fail-over in case of network issues. (GeraldK, 14:46:55)
    13. Ildiko thinks this BP belongs more to HA project, than Doctor. (GeraldK, 14:47:22)
    14. we are taking about agents belonging to Neutron, so Tommy agrees this is more HA than Doctor. (GeraldK, 14:48:10)
    15. we are taking about agents belonging to Neutron, so Tommy agrees this may be more HA than Doctor. (GeraldK, 14:48:33)
    16. continue discussion offline (r-mibu, 14:51:29)

  6. JIRA Issues (r-mibu, 14:51:45)
    1. https://jira.opnfv.org/browse/DOCTOR-46?jql=project%20%3D%20DOCTOR%20and%20duedate%20%3C%20now() (r-mibu, 14:51:58)
    2. https://jira.opnfv.org/browse/DOCTOR-46?jql=project%20%3D%20DOCTOR%20and%20duedate%20%3C%20now() (GeraldK, 14:51:58)
    3. list of open Jira issues (GeraldK, 14:52:22)
    4. https://jira.opnfv.org/browse/DOCTOR-16 (r-mibu, 14:52:29)
    5. Inspector: detailed gap analysis with Monasca; prio changed to minor as we may use Congress (GeraldK, 14:53:07)
    6. another candidate is Vitrage (GeraldK, 14:54:04)
    7. another issue is limited resources (GeraldK, 14:57:37)
    8. it would be good to start table with gap analysis and results (GeraldK, 14:58:07)
    9. Ryota will work on this task, but on high-level (GeraldK, 14:59:16)
    10. we'll handle this topic next week (r-mibu, 15:00:28)


Meeting ended at 15:00:31 UTC (full logs).

Action items

  1. Carlos to finish by MS-E
  2. Bertrand to create rst file, preferrably by MS-E, but latest by next OPNFV Summit


People present (lines said)

  1. GeraldK (37)
  2. r-mibu (28)
  3. collabot (5)
  4. ildikov (1)
  5. tojuvone (1)
  6. cgoncalves (1)
  7. mtahhan (1)
  8. ljlamers (1)
  9. TommyL (1)
  10. dandruta (1)


Generated by MeetBot 0.1.4.