#opnfv-doctor: doctor

Meeting started by r-mibu at 13:00:17 UTC (full logs).

Meeting summary

  1. roll call (r-mibu, 13:00:23)
    1. Ryota Mibu (r-mibu, 13:00:29)
    2. yujunz (yujunz, 13:00:33)
    3. Tomi Juvonen (tojuvone, 13:00:39)
    4. Gerald Kunzmann (GeraldK, 13:03:20)
    5. Maryam Tahhan (mtahhan, 13:03:21)
    6. Carlos Goncalves (cgoncalves, 13:03:26)
    7. Bryan Sullivan (bryan_att, 13:03:36)
    8. Ifat Afek (ifat, 13:03:54)
    9. Larry Lamers (ljlamers, 13:04:27)

  2. PoC status (GeraldK, 13:05:14)
    1. Rajen (Yuanzhen, 13:05:23)
    2. cgoncalves summarizes the PoC: extended booth; want to send clear msg what has been done in Doctor project (GeraldK, 13:06:01)
    3. we need to prepare poster for the booth; only 1 screen per booth -> 2 screens (GeraldK, 13:06:47)
    4. PoC booth schedule: https://etherpad.opnfv.org/p/summit2016_doctor_booth (r-mibu, 13:07:02)
    5. pls add your name for the booth duty (GeraldK, 13:07:21)
    6. Tuesday: setup (from 12) and dry-run (at 14) (GeraldK, 13:07:51)
    7. "Tommy Lindgren" (tommyL, 13:08:59)
    8. ACTION: Gerald will reach out to team for poster preparation (GeraldK, 13:09:40)
    9. nameboard will show company logos (and name of the PoC?) (GeraldK, 13:10:32)
    10. Gerald has contacted LF for clarification (GeraldK, 13:11:27)

  3. "congress-demo" (GeraldK, 13:12:06)
    1. Takahashi-san presents the demo description (shared via email) (GeraldK, 13:13:34)
    2. two requirements; service-availability is shown by video broadcast service (GeraldK, 13:14:49)
    3. demo scenario: pull cable for NIC-1 -> port down observed (GeraldK, 13:15:55)
    4. event is triggered if (option 1) both NICs are down or (option 2) at least 1 NIC is down (GeraldK, 13:17:07)
    5. collectd will get status from DPDK -> post Doctor-event to congress (incl. type; hostname) (GeraldK, 13:18:11)
    6. bryan_att: what host name? host name of compute host server (GeraldK, 13:19:12)
    7. Congress evaluates policies and finds fix to the failure; Congress needs to know which server's port is down. (GeraldK, 13:20:01)
    8. Congress can identify the Neutron port that has become unavailable. (GeraldK, 13:21:22)
    9. API extension for port state update is needed (GeraldK, 13:21:49)
    10. bryan_att is interested to see the Congress policy (GeraldK, 13:22:10)
    11. r-mibu explains that demo development is still ongoing. (GeraldK, 13:22:50)
    12. r-mibu: Doctor plugin with collectd is just posting the event (GeraldK, 13:23:27)
    13. new compared to last Summit: DPDK&collectd support; port failure; integration of Congress (GeraldK, 13:26:37)
    14. maryam will contact her developers to check for the open issues with collectd (GeraldK, 13:31:13)
    15. seems option D is possible (preferred option) (GeraldK, 13:31:45)

  4. "Vitrage demo" (GeraldK, 13:31:54)
    1. ifat_afek explains the plan for the Vitrage demo (GeraldK, 13:32:57)
    2. plan is to use Zabbis; backup is Naggios (GeraldK, 13:33:09)
    3. host down will be notified through Aodh (GeraldK, 13:34:19)
    4. cgoncalved: you are forcing a host down -> shouldn't this be a higher-layer decision? (GeraldK, 13:34:50)
    5. ohad: yes. this is possible. all options are possible. we just need to decide which one to demo (GeraldK, 13:35:17)
    6. PoC will include two hosts; Vitrage UI; simulation of host NIC failure; alarms will not be seen in Vitrage as instances will be migrated; (GeraldK, 13:36:42)
    7. will show the correlations of the different failures in the different entities (GeraldK, 13:37:42)
    8. Ohad: Vitrage knows all the topology: it does not matter whether which failure is simulated as they monitor all of them (GeraldK, 13:38:50)
    9. Gerald asked Vitrage team to make sure the advantage of Vitrage introduction to Doctor (r-mibu, 13:44:10)
    10. Gerald asked to show service availability with video service as the same as congress demo (r-mibu, 13:45:19)
    11. ohad explains that Nokia will go for remote demo; on-site demo is not possible due to several reasons. (GeraldK, 13:46:32)
    12. Gerald proposes to have 2 laptops: 1 for demo control; 1 for presentation of additional material on the demos (GeraldK, 13:49:11)
    13. r-mibu: requests scenario with Doctor framework, i.e. use Consumer to do action, do not use evacuate action; can help to align demo scenarios (GeraldK, 13:50:12)

  5. Design sesssion topics (GeraldK, 13:50:45)
    1. see line 182+ in the Doctor meeting page (GeraldK, 13:51:33)
    2. l184 - https://etherpad.opnfv.org/p/doctor_meetings (r-mibu, 13:52:08)
    3. proposal to create separate page (GeraldK, 13:52:19)
    4. ACTION: ALL to come up with topics you want to discuss in the Design Summit (GeraldK, 13:52:37)

  6. C release tasks (r-mibu, 13:53:58)
    1. tojuvone reports maintenance spec is moved to Ocata (GeraldK, 13:54:43)
    2. cgoncalves reports that Juju charm has to be provided by Doctor team for JOID installer (GeraldK, 13:55:24)
    3. Doctor SB I/F under discussion in Gerrit (GeraldK, 13:55:54)

  7. AoB (r-mibu, 13:58:22)
    1. arrange offline call for Poc demo alignment (GeraldK, 14:00:34)
    2. ACTION: r-mibu to close DOCTOR-37 since the patch has been merged. (yujunz, 14:02:35)


Meeting ended at 14:03:03 UTC (full logs).

Action items

  1. Gerald will reach out to team for poster preparation
  2. ALL to come up with topics you want to discuss in the Design Summit
  3. r-mibu to close DOCTOR-37 since the patch has been merged.


Action items, by person

  1. r-mibu
    1. r-mibu to close DOCTOR-37 since the patch has been merged.
  2. UNASSIGNED
    1. Gerald will reach out to team for poster preparation
    2. ALL to come up with topics you want to discuss in the Design Summit


People present (lines said)

  1. GeraldK (51)
  2. r-mibu (14)
  3. collabot` (6)
  4. Yuanzhen (4)
  5. yujunz (4)
  6. mtahhan (3)
  7. ildikov (2)
  8. tojuvone (1)
  9. cgoncalves (1)
  10. bryan_att (1)
  11. ljlamers (1)
  12. ifat (1)
  13. tommyL (1)


Generated by MeetBot 0.1.4.