#opnfv-doctor: doctor

Meeting started by r-mibu at 13:02:58 UTC (full logs).

Meeting summary

  1. roll call (r-mibu, 13:03:05)
    1. Tomi Juvonen (tojuvone, 13:03:08)
    2. Ryota Mibu (r-mibu, 13:03:10)
    3. Carlos Goncalves (cgoncalves, 13:03:11)
    4. Yujun Zhang (yujunz, 13:03:31)
    5. Gerald (GeraldK, 13:04:49)

  2. E release planning (r-mibu, 13:07:50)
    1. https://etherpad.opnfv.org/p/doctor_e_release_items (r-mibu, 13:08:28)
    2. https://wiki.opnfv.org/display/doctor/Euphrates+Planning (GeraldK, 13:09:55)
    3. ACTION: ryota to report completion of doctor E release planning to david (using summary template) (r-mibu, 13:09:57)

  3. Report from meeting with HA (r-mibu, 13:10:19)
    1. https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-April/015863.html (r-mibu, 13:10:54)
    2. http://docs.opnfv.org/en/stable-danube/submodules/availability/docs/development/overview/index.html (GeraldK, 13:11:56)
    3. http://artifacts.opnfv.org/availability/docs/development_overview/_images/OPNFV_HA_Guest_APIs-Overview_HLD-Guest_Heartbeat-FIGURE-1.png (r-mibu, 13:12:11)
    4. http://artifacts.opnfv.org/availability/docs/development_overview/_images/OPNFV_HA_Guest_APIs-Overview_HLD-Peer_Messaging-FIGURE-2.png (r-mibu, 13:12:24)
    5. two use cases from HA had been presented. the document will be revised based on the discussion. (GeraldK, 13:18:48)

  4. AoB (r-mibu, 13:19:53)
    1. https://review.openstack.org/424340 port-data-plane-status was accepted (GeraldK, 13:20:17)
    2. we can test with those merged code, and can ask installers to backport this feature from pike to ocata (r-mibu, 13:21:05)
    3. ACTION: cgoncalves will create a new Jira ticket for backporting of this feature (GeraldK, 13:21:52)
    4. status of collectd support in OPNFV installers; apex will support soon (r-mibu, 13:26:48)
    5. https://gerrit.opnfv.org/gerrit/#/c/33381/ (dwj, 13:27:45)
    6. Carlos assigned to DOCTOR-101. plan is to add collectd support introduced by the Barometer project (cgoncalves, 13:27:58)
    7. dwj suggests one verify job for python code unit testing and another for doctor function validation (yujunz, 13:30:21)
    8. https://gerrit.opnfv.org/gerrit/#/c/33381/ (GeraldK, 13:30:34)
    9. workaround for experimental job type "recheck-experimental" (yujunz, 13:32:03)
    10. rewrite by python - add tox for test; Wenjuan reported 1) there is a patch set introducing tox, and 2) we can have new job to kick tox (r-mibu, 13:34:34)
    11. ACTION: ryota to create new tox job for doctor (r-mibu, 13:34:51)
    12. Ryota proposed to have some guideline in order to avoid rewrite python code of new codes which will be developed in E release (r-mibu, 13:39:40)
    13. the guideline could be that the asignee/developer of new testing code inform the place in which he/she edit to wenjuan or team (r-mibu, 13:40:43)
    14. so that wenjuan/team can help he/she writing new code with python (r-mibu, 13:41:26)
    15. doctor team agreed the guideline (r-mibu, 13:45:08)


Meeting ended at 15:07:13 UTC (full logs).

Action items

  1. ryota to report completion of doctor E release planning to david (using summary template)
  2. cgoncalves will create a new Jira ticket for backporting of this feature
  3. ryota to create new tox job for doctor


Action items, by person

  1. cgoncalves
    1. cgoncalves will create a new Jira ticket for backporting of this feature
  2. UNASSIGNED
    1. ryota to report completion of doctor E release planning to david (using summary template)
    2. ryota to create new tox job for doctor


People present (lines said)

  1. r-mibu (22)
  2. GeraldK (12)
  3. yujunz (8)
  4. cgoncalves (7)
  5. collabot (3)
  6. tojuvone (2)
  7. dwj (2)


Generated by MeetBot 0.1.4.