#opnfv-functest: Functest weekly meeting September 6th

Meeting started by morgan_orange at 08:00:16 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 08:00:22)
    1. Morgan Richomme (morgan_orange, 08:00:28)
    2. Jose Lausuch (jose_lausuch, 08:00:34)
    3. SerenaFeng (SerenaFeng, 08:00:34)
    4. Juha Kosonen (juhak, 08:00:35)
    5. Viktor Tikkanen (viktor_t, 08:00:38)
    6. Cristina Pauna (Enea) (CristinaPauna, 08:00:40)
    7. agenda https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange, 08:00:57)
    8. raghavendrachari (Raghav, 08:01:04)

  2. Action point follow up (morgan_orange, 08:01:33)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-functest/2016/opnfv-functest.2016-08-30-08.00.html (morgan_orange, 08:01:41)
    2. AP1: morgan_orange SerenaFeng sync with Juraj for dashboard activity (morgan_orange, 08:01:50)
    3. serenaFeng committed first patches last week, discussion to get bitergia contacts (morgan_orange, 08:02:00)
    4. AP2: morgan_richomme re-clean based on David's list (morgan_orange, 08:02:06)
    5. done, last list was clearer, do not forget to indicate teh target version for correction (morgan_orange, 08:02:14)
    6. AP3: morgan_richomme create JIRAs if needed to reflect bug fix activity (morgan_orange, 08:02:21)
    7. done I do not see any missing JIRAs regarding our activities (morgan_orange, 08:02:27)
    8. AP4; morgan_orange check reporting links http://testresults.opnfv.org/reporting/functest/release/colorado/index-status-compass.html (morgan_orange, 08:02:42)
    9. done during last meeting (morgan_orange, 08:02:48)
    10. AP5: SerenaFeng see with parser team if parser must be run on HA mode only (morgan_orange, 08:02:53)
    11. done: noha scenario disabled for parser (virtual resources - often linked to non ha scenario) lacking ressources for parser case (morgan_orange, 08:02:59)
    12. shall we plan in the future also a constarint on the type of pod (as HA can be done in virtual.. the match ha/noha bm/virtual is not systematic)? (morgan_orange, 08:03:11)
    13. AP6: morgan_orange adapt lxd scenario declaration + release note accordingly (morgan_orange, 08:03:24)
    14. done healthcheck excluded, Rally black list mechanism implemented by juhak (morgan_orange, 08:03:43)
    15. https://gerrit.opnfv.org/gerrit/#/c/20361/ (morgan_orange, 08:04:31)
    16. AP7: viktor_t see if for odl_l3 we should exclude test cases (morgan_orange, 08:04:38)
    17. viktor_t mechanism to exclude always failing tests implemented (forgive me to have changed my mind...final decision was to not exclude the test case as it corresponds to a real bugs that prevent Ip allocation...so not very useful scenario) (morgan_orange, 08:05:01)
    18. release note updated to reference odl_l3 bug (morgan_orange, 08:05:17)
    19. AP8: jose_lausuch fix issue of artifacts not pushed in cased of exit -1 (any case failed) (morgan_orange, 08:05:23)
    20. done we have now artifacts whatever the run results. Nice (frightning) error reports from security_scan. (morgan_orange, 08:05:29)
    21. http://artifacts.opnfv.org/logs/functest/lf-pod1/2016-07-16_05-12-54/master/security_scan/192.30.9.5_2016-07-16_05-12-43/report.html (morgan_orange, 08:05:35)
    22. AP9: viktor_t once artifact issue fixed, study odl_l3 tempest errors (morgan_orange, 08:05:40)
    23. see AP7 (morgan_orange, 08:05:45)
    24. AP10: morgan_orange create 2 topics related to new VNF integration (morgan_orange, 08:05:52)
    25. mail sent with several proposals + Serena proposal on htmlization / pdfization, see next scetion for vote (morgan_orange, 08:05:59)
    26. AP11: jose_lausuch morgan_orange check Colorado docker consistancy and fix branch for OPNFV internal repos in Colorado(stable) docker (morgan_orange, 08:06:04)
    27. not done, shall we fix all feature project version to Colorado in Colorado branch only now? (morgan_orange, 08:06:11)
    28. https://docs.docker.com/engine/reference/commandline/build/ (ollivier, 08:11:31)
    29. ACTION: jose_lausuch ollivier find best way to coloradoize our docker and try to keep a master to be able to test changes without breaking colorado gate (morgan_orange, 08:11:35)
    30. ollivier (ollivier, 08:11:47)

  3. Colorado status (morgan_orange, 08:12:13)
    1. scenarios apex (morgan_orange, 08:12:21)
    2. http://testresults.opnfv.org/reporting/functest/release/colorado/index-status-apex.html (morgan_orange, 08:12:27)
    3. first blue balls in Jenkins! i.e. security_scan and copper OK (in HA or with patch as indicated by Tim? to be confirmed) (morgan_orange, 08:12:33)
    4. https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-colorado-daily-colorado/94/ (morgan_orange, 08:12:59)
    5. issues with Tempest/odl_l3 due to ODL bug (will nto be fixed in C), still issues with bgpvn and sfc scenario (morgan_orange, 08:13:10)
    6. ACTION: jose_lausuch sync for apex/bgpvpn (morgan_orange, 08:14:47)
    7. ACTION: jose_lausuch sync for apex/sfc (morgan_orange, 08:15:22)
    8. https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-colorado-daily-colorado/99/console (jose_lausuch, 08:15:40)
    9. ACTION: May-meimei sync for apex/onos and apex/onos-sfc (morgan_orange, 08:17:08)
    10. scenario compass (morgan_orange, 08:18:41)
    11. http://testresults.opnfv.org/reporting/functest/release/colorado/index-status-compass.html (morgan_orange, 08:18:49)
    12. compass/moon issue on ODL identified and documented, work on moon side for tempest and moon tests (morgan_orange, 08:19:18)
    13. compass/odl_l3 idem apex (morgan_orange, 08:19:33)
    14. compass onos/sfc (morgan_orange, 08:19:39)
    15. http://testresults.opnfv.org/test/api/v1/results?case=onos_sfc&last=10&installer=compass&scenario=os-onos-sfc-ha (morgan_orange, 08:19:45)
    16. note same test ok on other scenarios (morgan_orange, 08:19:52)
    17. http://testresults.opnfv.org/test/api/v1/results?case=onos_sfc&last=10 (morgan_orange, 08:19:58)
    18. ACTION: May-meimei sync compass/onos-sfc (morgan_orange, 08:21:25)
    19. fuel scenarios (morgan_orange, 08:21:32)
    20. http://testresults.opnfv.org/reporting/functest/release/colorado/index-status-fuel.html (morgan_orange, 08:21:38)
    21. no more blocking case (except Tempest odl_l3 like for all the installers) (morgan_orange, 08:21:44)
    22. all the scenarios still not fully OK due to some errors in doctor/parser/promise/Rally/bgpvpn but case worked once at least (morgan_orange, 08:21:58)
    23. last 10 parser tests are OK (morgan_orange, 08:22:05)
    24. warning on fuel/doctor as last 3 run seems FAIl (morgan_orange, 08:22:50)
    25. http://testresults.opnfv.org/test/api/v1/results?case=doctor-notification&last=10&installer=fuel (morgan_orange, 08:23:00)
    26. ACTION: SerenaFeng sync fuel/doctor (morgan_orange, 08:23:45)
    27. joid scenarios (morgan_orange, 08:24:05)
    28. no run due to work on INTEL PODs...(no CI resources 15 days before release...) (morgan_orange, 08:24:15)
    29. http://testresults.opnfv.org/reporting/functest/release/colorado/index-status-joid.html (morgan_orange, 08:24:30)
    30. ACTION: viktor_t review scenarios where tempest is not fully sunny (morgan_orange, 08:24:49)
    31. ACTION: juhak review scenarios where rally is not fully sunny (morgan_orange, 08:25:03)
    32. ACTION: morgan_orange test rally black list on lxd scenario (morgan_orange, 08:27:01)
    33. ACTION: morgan_orange add push to DB in odl_sfc (morgan_orange, 08:29:22)
    34. ACTION: SerenaFeng Raghav review Yardstick documentation (morgan_orange, 08:33:56)

  4. Dashboard evolution (morgan_orange, 08:34:50)
    1. ACTION: morgan_orange add CristinaPauna and Alex Avadanii in Functest doc review (morgan_orange, 08:35:32)

  5. internship program (morgan_orange, 08:41:26)
    1. proposals are: (morgan_orange, 08:41:45)
    2. 1: open Source VNF catalog (morgan_orange, 08:41:46)
    3. 2: Functest unit tests (morgan_orange, 08:41:51)
    4. 3: vCDN VNF bootstrap (morgan_orange, 08:41:57)
    5. 4: vPing evolution (morgan_orange, 08:42:02)
    6. 5: VNF integration based on Juju orchestrator (morgan_orange, 08:42:09)
    7. 6: add token to testapi and pdf-ize or html-ize testapi (morgan_orange, 08:42:14)
    8. 7: Automatic reporting evolution (morgan_orange, 08:42:20)
    9. VOTE: Voted on "vote for your 2 favorite subjects?" Results are, 1: 1, 3: 0, 2: 2, 6: 1 (morgan_orange, 08:44:39)
    10. VOTE: Voted on "vote for your favorite topic?" Results are, 3: 1, 2: 1, 6: 3 (morgan_orange, 08:46:16)
    11. VOTE: Voted on "vote for your favorite topic?" Results are, 2: 5 (morgan_orange, 08:47:36)
    12. subject 2 (unit tests) will be publushed in the internship program page (morgan_orange, 08:47:55)
    13. ACTION: morgan_orange pushich topic 2 and 6 (morgan_orange, 08:48:19)

  6. Preparation D release (morgan_orange, 08:48:32)
    1. page for D refactored (morgan_orange, 08:49:33)
    2. https://wiki.opnfv.org/display/functest/Functextnexttaks (morgan_orange, 08:49:51)
    3. figure created regarding the discussion on templating (morgan_orange, 08:50:02)
    4. https://wiki.opnfv.org/download/attachments/2925495/Functest-feature-project-interfaces.png?version=1&modificationDate=1473091940000&api=v2 (morgan_orange, 08:50:05)
    5. ACTION: everybody review and comment D wiki page (morgan_orange, 08:55:14)

  7. AoB (morgan_orange, 08:56:10)
    1. Functets meetup planned during OpenStack Summit Barcelona (morgan_orange, 09:01:41)
    2. if needed regional meetup could be organized in Orange (Lannion or Paris if more convenient) (morgan_orange, 09:02:10)


Meeting ended at 09:02:56 UTC (full logs).

Action items

  1. jose_lausuch ollivier find best way to coloradoize our docker and try to keep a master to be able to test changes without breaking colorado gate
  2. jose_lausuch sync for apex/bgpvpn
  3. jose_lausuch sync for apex/sfc
  4. May-meimei sync for apex/onos and apex/onos-sfc
  5. May-meimei sync compass/onos-sfc
  6. SerenaFeng sync fuel/doctor
  7. viktor_t review scenarios where tempest is not fully sunny
  8. juhak review scenarios where rally is not fully sunny
  9. morgan_orange test rally black list on lxd scenario
  10. morgan_orange add push to DB in odl_sfc
  11. SerenaFeng Raghav review Yardstick documentation
  12. morgan_orange add CristinaPauna and Alex Avadanii in Functest doc review
  13. morgan_orange pushich topic 2 and 6
  14. everybody review and comment D wiki page


Action items, by person

  1. CristinaPauna
    1. morgan_orange add CristinaPauna and Alex Avadanii in Functest doc review
  2. jose_lausuch
    1. jose_lausuch ollivier find best way to coloradoize our docker and try to keep a master to be able to test changes without breaking colorado gate
    2. jose_lausuch sync for apex/bgpvpn
    3. jose_lausuch sync for apex/sfc
  3. juhak
    1. juhak review scenarios where rally is not fully sunny
  4. morgan_orange
    1. morgan_orange test rally black list on lxd scenario
    2. morgan_orange add push to DB in odl_sfc
    3. morgan_orange add CristinaPauna and Alex Avadanii in Functest doc review
    4. morgan_orange pushich topic 2 and 6
  5. ollivier
    1. jose_lausuch ollivier find best way to coloradoize our docker and try to keep a master to be able to test changes without breaking colorado gate
  6. Raghav
    1. SerenaFeng Raghav review Yardstick documentation
  7. SerenaFeng
    1. SerenaFeng sync fuel/doctor
    2. SerenaFeng Raghav review Yardstick documentation
  8. viktor_t
    1. viktor_t review scenarios where tempest is not fully sunny
  9. UNASSIGNED
    1. May-meimei sync for apex/onos and apex/onos-sfc
    2. May-meimei sync compass/onos-sfc
    3. everybody review and comment D wiki page


People present (lines said)

  1. morgan_orange (202)
  2. jose_lausuch (67)
  3. SerenaFeng (23)
  4. collabot (22)
  5. Raghav (9)
  6. juhak (5)
  7. cgoncalves (4)
  8. ollivier (4)
  9. CristinaPauna (2)
  10. viktor_t (1)


Generated by MeetBot 0.1.4.