#opnfv-functest: Functest weekly meeting October 4th

Meeting started by morgan_orange at 07:59:59 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 08:00:12)
    1. Cristina Pauna (enea) (Cristina__, 08:00:21)
    2. Jose Lausuch (jose_lausuch, 08:00:47)
    3. Morgan Richomme (morgan_orange, 08:01:08)
    4. agenda https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange, 08:01:50)
    5. Hideyasu ool (hideyasu_ool, 08:02:03)

  2. action points follow-up (morgan_orange, 08:02:23)
    1. AP1: morgan_orange push presentation on dahsboard in the doc repo (morgan_orange, 08:02:33)
    2. done https://gerrit.opnfv.org/gerrit/#/c/22659/ (morgan_orange, 08:02:38)
    3. AP2: morgan_orange formalize PTL election in wiki (vote planned on the 10th so procedure shall be available 1 week before) (morgan_orange, 08:02:44)
    4. done https://wiki.opnfv.org/display/functest/Functest+admin (morgan_orange, 08:02:51)
    5. AP3: jose_lausuch viktor_t lhinds May-meimei ollivier SerenaFeng juhak Raghav complete etherpad postmortem (morgan_orange, 08:03:13)
    6. https://etherpad.opnfv.org/p/Colorado-Testing-postmortem (morgan_orange, 08:03:21)
    7. I just see some update from yardstick, we will discuss Colorado postmortem in a topic (morgan_orange, 08:03:27)
    8. AP4: hideyasu_ool jose_lausuch sync with SDNVPN (morgan_orange, 08:03:38)
    9. done clarification done by hideyasu (mail) (morgan_orange, 08:03:44)
    10. AP5: morgan_orange contact hongbo to see articulation dovetail tests / functest tests (especially in the VIM section) (morgan_orange, 08:03:52)
    11. done hongbo confirmed they will not redevelop test cases but base their suite on existing suite (wiki was a bit misleading for me) (morgan_orange, 08:04:02)

  3. Colorado post mortem (morgan_orange, 08:05:06)
    1. ACTION: jose_lausuch morgan_orange plan finalization of Colorado postmortem during OpenStack Summit (morgan_orange, 08:06:28)
    2. ACTION: everybody 2 more weeks to complete... (morgan_orange, 08:06:38)
    3. ACTION: morgan_orange jose_lausuch initiate presentation with proposals for the - and -- alreday referenced (morgan_orange, 08:08:02)

  4. Danube: Discussion on internal tescases (morgan_orange, 08:09:18)
    1. https://wiki.opnfv.org/display/functest/Functest+Danube (morgan_orange, 08:10:15)
    2. unit tests should be integrated especially for our own functions (morgan_orange, 08:12:52)
    3. https://jira.opnfv.org/browse/FUNCTEST-336 (morgan_orange, 08:12:54)
    4. intership proposed on Functest unit tests (morgan_orange, 08:14:15)
    5. https://wiki.opnfv.org/display/DEV/Intern-projects-page (morgan_orange, 08:14:18)
    6. https://wiki.opnfv.org/display/DEV/Intern+Project%3A+Functest+unit+tests (morgan_orange, 08:14:28)
    7. new internal tests have also been mentioned: evolution of vPing, vPing + real userdata (not using local drive), security groups (morgan_orange, 08:15:15)
    8. Dovetail defined a vRouter test case that shoudl also be not too difficult to implement (morgan_orange, 08:16:29)
    9. early reflexion on test on power consuption POD audit (morgan_orange, 08:21:05)

  5. Danube: Discussion on refactoring/templating (morgan_orange, 08:21:38)
    1. discussion on a possible evolution of the API with the creation of a scenario table (morgan_orange, 08:31:59)
    2. this table would include the scenario owner, the customTestlist (if tests excluded by the owner / default behavior), the score, the installer supported (morgan_orange, 08:32:28)
    3. the scenario owner could generate a custom list that will generate a yaml file used by the CLI and inside the container (morgan_orange, 08:32:52)
    4. if nothing customized we keep the current behavior (morgan_orange, 08:33:07)
    5. ACTION: morgan_orange refactor Danube page to reflect the introduction of a scenario table in the API (morgan_orange, 08:33:59)
    6. ACTION: morgan_orange ask feature projects already integrated in Functest for feedback on a possible evolution considering Feature project as an object (morgan_orange, 08:42:53)

  6. Danube: Discussion on exception class (morgan_orange, 08:46:03)
    1. for all the test project, list possible error causes and create a class in Releng (morgan_orange, 08:49:30)
    2. could behelpful to have a consistent way to manage error at the test level and avoid wild exit (morgan_orange, 08:49:47)

  7. Meetup (morgan_orange, 08:49:53)
    1. meetup in Lannion canceled (morgan_orange, 08:50:23)
    2. proposal to organize the meetup in Barcelona Tuesday 25th (morgan_orange, 08:50:41)
    3. room has been asked (morgan_orange, 08:50:47)
    4. people who are free can also attend OPNFV meetup in Paris on the 21th (morgan_orange, 08:51:57)
    5. Lannion candidate for a future meetup... (morgan_orange, 08:52:27)

  8. AoB (morgan_orange, 08:52:36)
    1. update o the reporting with d3js for gauge and trend line (morgan_orange, 08:52:48)
    2. export to pdf in progress but js svg not displayed (morgan_orange, 08:52:54)
    3. export to csv also planned (morgan_orange, 08:53:00)
    4. http://testresults.opnfv.org/reporting/functest/release/colorado/index-status-compass.html (morgan_orange, 08:53:18)
    5. installer adapter in the pipe.... (morgan_orange, 08:53:28)
    6. discussion on CI evolution with releng project (morgan_orange, 08:54:06)
    7. https://wiki.opnfv.org/display/INF/CI+Evolution (morgan_orange, 08:54:25)
    8. ACTION: all review CI evolution (morgan_orange, 08:54:32)
    9. CI evolution: mechanism described by Fatih clear, Functest could adapt. (morgan_orange, 09:00:56)
    10. ressources needed and adoption of the procedure by all the installers (morgan_orange, 09:01:08)


Meeting ended at 09:02:14 UTC (full logs).

Action items

  1. jose_lausuch morgan_orange plan finalization of Colorado postmortem during OpenStack Summit
  2. everybody 2 more weeks to complete...
  3. morgan_orange jose_lausuch initiate presentation with proposals for the - and -- alreday referenced
  4. morgan_orange refactor Danube page to reflect the introduction of a scenario table in the API
  5. morgan_orange ask feature projects already integrated in Functest for feedback on a possible evolution considering Feature project as an object
  6. all review CI evolution


Action items, by person

  1. jose_lausuch
    1. jose_lausuch morgan_orange plan finalization of Colorado postmortem during OpenStack Summit
    2. morgan_orange jose_lausuch initiate presentation with proposals for the - and -- alreday referenced
  2. morgan_orange
    1. jose_lausuch morgan_orange plan finalization of Colorado postmortem during OpenStack Summit
    2. morgan_orange jose_lausuch initiate presentation with proposals for the - and -- alreday referenced
    3. morgan_orange refactor Danube page to reflect the introduction of a scenario table in the API
    4. morgan_orange ask feature projects already integrated in Functest for feedback on a possible evolution considering Feature project as an object
  3. UNASSIGNED
    1. everybody 2 more weeks to complete...
    2. all review CI evolution


People present (lines said)

  1. morgan_orange (181)
  2. jose_lausuch (88)
  3. Cristina__ (3)
  4. collabot (3)
  5. hideyasu_ool (2)
  6. Raghav (1)


Generated by MeetBot 0.1.4.