#opnfv-functest: Functest weekly meeting March 14th

Meeting started by morgan_orange at 08:00:15 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 08:00:21)
    1. Morgan Richomme (morgan_orange, 08:00:24)
    2. Cristina Pauna (ENEA) (CristinaPauna, 08:00:34)
    3. Juha Kosonen (juhak, 08:00:39)
    4. Cédric (ollivier, 08:00:42)
    5. leo wang (leo_wang, 08:00:48)
    6. Jun Li (MatthewLi, 08:00:57)
    7. Helen Yao (HelenYao, 08:01:07)
    8. agendat for today => https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange, 08:01:09)
    9. Linda Wang (LindaWang, 08:01:18)

  2. action point follow up (morgan_orange, 08:01:23)
    1. Chris Price (irc only) (ChrisPriceAB, 08:01:28)
    2. AP1, AP2, AP3, AP4 juhak give feedback on tempest_smoke & rallay_sanity error => see next topic (morgan_orange, 08:01:33)
    3. AP5 juhak troubleshooting multisite (morgan_orange, 08:01:38)
    4. AP6: ollivier add a wiki page about review best practices (morgan_orange, 08:01:44)
    5. ACTION: ollivier add a wiki page about review best practices (morgan_orange, 08:02:00)
    6. note a page for Euphrates has been initiated (morgan_orange, 08:02:08)
    7. https://wiki.opnfv.org/display/functest/Functest+Euphrates+page (morgan_orange, 08:02:18)
    8. AP7: morgan_orange ollivier clarify python way for feature projects inhering feature based - see impact on sfc, sdnvpn (morgan_orange, 08:02:45)
    9. done (security_scan not ready for a cleaner integration => , patch merged) (security scanning OK) (morgan_orange, 08:03:15)
    10. AP8: ollivier see what is wrong on odl_l3 scenario => see next topic (morgan_orange, 08:03:21)
    11. AP9: SerenaFeng check testapi fixed are included on testresults.opnfv.org, if not apply them and maybe enable automatic mechanism now.. (morgan_orange, 08:03:26)
    12. done, testapi is now fully automated from releng to testresults.opnfv.org and artifacts => congratulation to Serena and Rohit (morgan_orange, 08:03:32)
    13. AP10: morgan_orange => share the mail with scenario owners (any alias?) (morgan_orange, 08:03:39)
    14. info shared during weekly meeting, I also reported that the wiki page referencing the scenario does not seem fully accurate anymore (morgan_orange, 08:03:44)
    15. AP11 steve and morgan_orange, see if SNAPS smoke is compatible with lxd (probably not...) if not exclude it (morgan_orange, 08:03:50)
    16. done, SNAPS smoke excluded for this scenario, JIRA created for adaptation in Euphrates (morgan_orange, 08:04:00)
    17. AP12 morgan_orange create Danube branch March 10th 2PM CET (morgan_orange, 08:04:06)
    18. branch created by aric on friday (morgan_orange, 08:04:11)
    19. jenkins board modified, but no danube CI run seen so far (morgan_orange, 08:04:20)
    20. only Danube runs come from Cisco labs (not connected to CI but pushing results in DB) (morgan_orange, 08:04:26)
    21. reporting page update (morgan_orange, 08:04:31)
    22. morgan_orange adapt reporting to include Danube version (morgan_orange, 08:04:36)
    23. http://testresults.opnfv.org/reporting/functest/release/danube/index-status-apex.html (morgan_orange, 08:04:41)
    24. AP13: all close the JIRA that are fixed to clarify (morgan_orange, 08:04:46)
    25. still pending... (morgan_orange, 08:04:52)
    26. AP14 morgan_orange clean JIRA for Danube (morgan_orange, 08:04:57)
    27. in progress (morgan_orange, 08:05:01)

  3. Danube status (morgan_orange, 08:05:56)
    1. ACTION: HelenYao generate new functest:stable based on danube (morgan_orange, 08:08:53)
    2. new danube jobs call functest:stable (outdated still based on colorado) (morgan_orange, 08:09:24)
    3. danube Cisco run (not connected to CI) still used latest (morgan_orange, 08:09:36)
    4. as a consequence on danube job we only see fdio scenario today (morgan_orange, 08:10:09)
    5. still needs to consider master results (morgan_orange, 08:10:18)
    6. apex (morgan_orange, 08:11:17)
    7. http://testresults.opnfv.org/reporting/functest/release/master/index-status-apex.html (morgan_orange, 08:11:18)
    8. https://gerrit.opnfv.org/gerrit/#/c/30341/ (pma, 08:13:48)
    9. ACTION: morgan_orange contact bgpvpn team for apex (morgan_orange, 08:14:03)
    10. patch submitted for doctor but no apex run on master since more than 5 days.... (morgan_orange, 08:15:37)
    11. so not possible to test the patch (morgan_orange, 08:15:42)
    12. warning no run on Master during 5 days 10 days before the release....it is a bit hot.. (morgan_orange, 08:16:35)
    13. apex scoring will probably decrease on master due ti lack of CI runs (morgan_orange, 08:17:06)
    14. compass (morgan_orange, 08:17:09)
    15. new openo scenario sucessfully itnegrated (morgan_orange, 08:17:20)
    16. issues with odl scenarios (odl_l2 and odl_l3) (morgan_orange, 08:17:36)
    17. issues also with ocl (but only installer with such sdn controler) (morgan_orange, 08:18:06)
    18. fuel (morgan_orange, 08:18:13)
    19. no run on master since 2 days (morgan_orange, 08:18:30)
    20. http://testresults.opnfv.org/reporting/functest/release/master/index-status-fuel.html (morgan_orange, 08:19:14)
    21. joid (morgan_orange, 08:21:25)
    22. http://testresults.opnfv.org/reporting/functest/release/master/index-status-joid.html (morgan_orange, 08:21:35)
    23. lxd and nosdn scenario stable (only 1 error remaining on rally_sanity for lxd) (morgan_orange, 08:22:03)
    24. odl scenario also failing (morgan_orange, 08:22:10)
    25. no update on Daisy (morgan_orange, 08:25:01)

  4. Danube Documentation (morgan_orange, 08:25:11)
    1. Functest documentation had been updated (first iteration) several weeks ago (morgan_orange, 08:25:37)
    2. as we are approaching we need to do the second iteration (morgan_orange, 08:25:54)
    3. there is still also possibility to including other test prohects and review also their documentation (morgan_orange, 08:26:34)
    4. https://wiki.opnfv.org/pages/viewpage.action?pageId=10289177 (morgan_orange, 08:27:04)
    5. feel free to add your name to review the doc of another project (last time review were very valuable...) (morgan_orange, 08:27:37)
    6. release note to be initated (morgan_orange, 08:28:00)
    7. ACTION: morgan_orange prepare release note (morgan_orange, 08:28:08)
    8. release note will be validated by José (morgan_orange, 08:28:18)

  5. RefStack (morgan_orange, 08:29:34)
    1. https://gerrit.opnfv.org/gerrit/#/c/30225/ (morgan_orange, 08:30:06)
    2. patch ready to be merged, introducing refstack testing as a new test case (i.e. running Refstack suite launched from refstack client) (morgan_orange, 08:30:40)
    3. test case using testBase abstraction, so results pushed to the DB (morgan_orange, 08:30:56)
    4. mail this morning refstack could be fine to consume our testAPI but we need to put all the results in the detaisl section (not only the errors or skipped) (morgan_orange, 08:31:32)
    5. this test will replace defcore created by José but we can try some cycles with both and remove refcore once refstack is fine (morgan_orange, 08:32:06)

  6. weekly jobs (morgan_orange, 08:40:10)
    1. weekly job introduce on fuel nosdn-nofeature master (morgan_orange, 08:40:26)
    2. https://build.opnfv.org/ci/job/fuel-os-nosdn-nofeature-ha-baremetal-weekly-master/ (morgan_orange, 08:41:14)
    3. jobs can be triggered manually from jenkns (morgan_orange, 08:41:23)
    4. such jobs shall allow the testing of VNF on boarding features (morgan_orange, 08:41:35)
    5. cloudify_ims tested (morgan_orange, 08:41:46)
    6. patch merged to avoid exit on vnf tests to see results of orchestra and vrouter (morgan_orange, 08:42:05)
    7. as soon as fuel is back in town we could try to trigger the job to see that (morgan_orange, 08:42:19)

  7. plugfest (morgan_orange, 08:43:50)
    1. https://wiki.opnfv.org/display/EVNT/Plugfest+-+Danube+Release (morgan_orange, 08:44:28)
    2. several functesters will attend (morgan_orange, 08:47:38)
    3. usual job: explain and support functest towards the different SUT (morgan_orange, 08:47:56)
    4. probably discussion on Functest roadmap (morgan_orange, 08:48:06)
    5. ACTION: morgan_orange initiate a wiki page for Functest@plugfest - plan remote demo for stress tests (morgan_orange, 08:51:50)
    6. demo on the Open Source VNF catalogue could be proposed (interesing for the end user) (morgan_orange, 08:52:15)
    7. https://wiki.opnfv.org/display/DEV/VNF+Catalogue (morgan_orange, 08:52:30)

  8. AoB (morgan_orange, 08:52:37)
    1. CFP Beijing Summit (morgan_orange, 08:52:46)
    2. etherpad page initiated to reference possible topics for the testing community (morgan_orange, 08:53:45)
    3. https://etherpad.opnfv.org/p/TestCommunitySummit (morgan_orange, 08:53:47)
    4. page shared on the wg mailing list (no comments/remarks so far) (morgan_orange, 08:54:04)
    5. deadline 27th of March (morgan_orange, 08:54:11)


Meeting ended at 09:02:17 UTC (full logs).

Action items

  1. ollivier add a wiki page about review best practices
  2. HelenYao generate new functest:stable based on danube
  3. morgan_orange contact bgpvpn team for apex
  4. morgan_orange prepare release note
  5. morgan_orange initiate a wiki page for Functest@plugfest - plan remote demo for stress tests


Action items, by person

  1. HelenYao
    1. HelenYao generate new functest:stable based on danube
  2. morgan_orange
    1. morgan_orange contact bgpvpn team for apex
    2. morgan_orange prepare release note
    3. morgan_orange initiate a wiki page for Functest@plugfest - plan remote demo for stress tests
  3. ollivier
    1. ollivier add a wiki page about review best practices


People present (lines said)

  1. morgan_orange (165)
  2. MatthewLi (12)
  3. juhak (11)
  4. HelenYao (10)
  5. ollivier (4)
  6. ChrisPriceAB (4)
  7. collabot` (3)
  8. gabriel_yuyang (3)
  9. LindaWang (1)
  10. pma (1)
  11. hideyasu (1)
  12. CristinaPauna (1)
  13. leo_wang (1)
  14. OPNFV-Gerrit-Bot (1)


Generated by MeetBot 0.1.4.