#opnfv-meeting: OPNFV-TSC

Meeting started by dlenrow at 13:57:46 UTC (full logs).

Meeting summary

    1. Chris Price (ChrisPriceAB, 14:01:21)
    2. Dave Lenrow (dlenrow, 14:01:33)
    3. Wenjing Chu (Wenjing, 14:03:21)
    4. Ray Paik (rpaik, 14:05:42)
    5. DirkKutscher (DirkKutscher, 14:07:07)
    6. Tapio Tallgren (TapioTallgren, 14:07:07)
    7. a popular IRC web client is http://www.irccloud.com, no personal or HP interest here, just FYI (dlenrow, 14:09:55)
    8. Brian Smith (B_Smith_, 14:11:18)
    9. https://wiki.opnfv.org/wiki/tsc (ChrisPriceAB, 14:19:29)
    10. https://wiki.opnfv.org/wiki/tsc (ChrisPriceAB, 14:19:33)
    11. CP proposes to defer approval of previous minutes to next week (dlenrow, 14:20:37)
    12. no additions to agenda (dlenrow, 14:21:13)

  1. project proposals and reviews (dlenrow, 14:21:22)
    1. need to put proposals on main wiki under project proposals (dlenrow, 14:21:45)
    2. project proposals https://wiki.opnfv.org/project_proposals (ChrisPriceAB, 14:22:01)
    3. use template there and send email to discuss to announce added proposal (dlenrow, 14:22:05)
    4. Current four week window for public review/discussion (dlenrow, 14:23:10)
    5. before they can seek approval (dlenrow, 14:23:22)
    6. probably want to revisit duration of public review period (dlenrow, 14:24:33)
    7. Need to set a date for cutoff to join first simult. release (dlenrow, 14:26:08)
    8. we then back out dates for when projects need to get approved (dlenrow, 14:26:30)
    9. approved No objections to vote changing project proposal public review period to 2 weeks instead of 4 (dlenrow, 14:29:27)

  2. upstream community plan (dlenrow, 14:29:55)
    1. CP reminds we were proposing to target stable releases from upstream projects (dlenrow, 14:30:23)
    2. CP reached out to discuss with ODL (dlenrow, 14:30:43)
    3. question asked how do we engage in making upstream changes? (dlenrow, 14:31:48)
    4. CP: suggests we have devs who work in upstream projects and serve OPNFV needs (dlenrow, 14:32:42)
    5. Ashiq: Can we setup sort of liasion with OSS upstream (dlenrow, 14:34:13)
    6. agreement that, although hard to formally do so with OSS projects, we can have point of contact assigned within OPNFV TSC (dlenrow, 14:35:00)
    7. Parviz asks single or group of contacts (dlenrow, 14:36:30)
    8. Ian: if we had group of folks working upstream should they be a project? Have TSC oversight? (dlenrow, 14:38:48)
    9. for example, OpenStack need planning/process to make community-consumable. Work may be non-trivial. (dlenrow, 14:39:54)
    10. Palani: Describes two parts 1) blueprint/planning 2) aligning release dates for features, etc. Need close coordination (dlenrow, 14:42:00)
    11. proposed action item for TSC. Write down timeline for integrating with upstream projects identified to date (dlenrow, 14:43:34)
    12. Palani: Yes we need gap analysis against upstream roadmaps (dlenrow, 14:43:59)
    13. CP starts with OStack and ODL and proposes Juno and Helium as the platform for our 1H2015 first release (dlenrow, 14:44:54)
    14. This means we need to articulate our needs to upstream six months in advance (dlenrow, 14:45:15)
    15. Need solid plan for working with upstream (dlenrow, 14:45:43)
    16. need to start firming up a simultaneous release process so that folks can begin to plan. (dlenrow, 14:46:11)
    17. CP asks for folks with experience to help draft a SR process? (dlenrow, 14:46:33)
    18. Palani volunteers to work but can't start this week. (dlenrow, 14:47:53)
    19. ACTION: Dlenrow to draft SR process wiki page ASAP (dlenrow, 14:49:31)
    20. Need a CI project proposal ASAP (dlenrow, 14:50:09)
    21. ACTION: Ian/Ulrich begin to draft this (dlenrow, 14:51:48)
    22. group is working on testing project proposal (dlenrow, 14:53:07)
    23. CP propose getting initial thoughts on the wiki (dlenrow, 14:53:35)
    24. question where are the proposed activities from community discussion? (dlenrow, 14:54:21)
    25. they are on the wiki (dlenrow, 14:54:27)
    26. reminder project proposal mostly captures scope. There is not need to document implementation plans in detail (dlenrow, 14:56:17)
    27. Agree to start threads to work on these projects-to-be (dlenrow, 14:57:58)
    28. CP will follow up with folks self-identified as willing to work (dlenrow, 14:58:16)
    29. testing has already scheduled a follow up call (dlenrow, 14:58:32)
    30. Once projects are approved, we need to create a project page on wiki and not make changes to proposal pages (dlenrow, 15:00:18)
    31. That is end of published agenda. (dlenrow, 15:01:08)
    32. CP asks for other business? (dlenrow, 15:01:26)
    33. question on results of the lightning round last week (dlenrow, 15:01:58)
    34. test and CI got lots of attention and will become initial projects (dlenrow, 15:02:59)
    35. lots of notes and white boards captured and on Wiki\ (dlenrow, 15:03:16)
    36. question: how do folks get visibility to progress if not already involved in a project (dlenrow, 15:04:39)
    37. Projects will have their own weekly (or similar) calls and IRC channels and info will be on project wiki. Anyone can join any project meeting or read minutes/docs/wiki (dlenrow, 15:06:20)
    38. http://new.livestream.com/accounts/5312056/events/3434564 (ChrisPriceAB, 15:07:05)
    39. http://new.livestream.com/accounts/5312056/events/3434564 (rpaik, 15:07:08)
    40. Ray asks if we also need summary type minutes (dlenrow, 15:10:04)
    41. agree to have summary on wiki (dlenrow, 15:10:39)
    42. do we know what we plan to accomplish with release 1? (dlenrow, 15:11:40)
    43. we don't know enough to define that yet (dlenrow, 15:12:24)


Meeting ended at 15:13:15 UTC (full logs).

Action items

  1. Dlenrow to draft SR process wiki page ASAP
  2. Ian/Ulrich begin to draft this


Action items, by person

  1. dlenrow
    1. Dlenrow to draft SR process wiki page ASAP


People present (lines said)

  1. dlenrow (59)
  2. ChrisPriceAB (8)
  3. collabot (3)
  4. B_Smith_ (2)
  5. DirkKutscher (2)
  6. rpaik (2)
  7. nstpierre (1)
  8. AndChat|71489 (1)
  9. bin_ (1)
  10. Serge (1)
  11. TapioTallgren (1)
  12. Wenjing (1)
  13. chrispriceAB (0)


Generated by MeetBot 0.1.4.