#opnfv-meeting: OPNFV TSC
Meeting started by dlenrow at 14:01:07 UTC
(full logs).
Meeting summary
- 
  - Dave Lenrow (dlenrow,
    14:01:18)
 
  - Chris Price (ChrisPriceAB,
    14:01:32)
 
  - Brian Smith (B_Smith_,
    14:02:29)
 
  - Ashiq Khan (Ashiq_docomo,
    14:04:12)
 
  - Wenjing Chu (Wenjing_,
    14:04:21)
 
  - Bin Hu (bin_,
    14:04:48)
 
  - reminder: all attendance (to establish quorum)
    and votes will be done on IRC. IRC use is mandatory to
    attend. (dlenrow,
    14:05:51)
 
  - pals (pals,
    14:06:21)
 
  - TSC members should show their presence by
    typing "#info member name" on IRC (dlenrow,
    14:07:02)
 
  - Frank joined (frankbrockners,
    14:07:39)
 
  - Uli joined (ulik,
    14:07:59)
 
  - Tom Nadeau via audio only (ChrisPriceAB,
    14:08:22)
 
  - I'll need to leave by 8.30am PT; in case we run
    the full 2hrs, Palani will fill in for me (frankbrockners,
    14:10:08)
 
  - Please note the antitrust and other
    warngings (dlenrow,
    14:10:21)
 
  - https://www.opnfv.org/about/bylaws-and-policies/antitrust-policy-compliance-checklist
    (dlenrow,
    14:10:25)
 
  - chris announces and begins recording of this
    meeting (dlenrow,
    14:10:51)
 
 
- approve last week's minutes (dlenrow, 14:11:04)
  - approved by lack of dissent (dlenrow,
    14:11:14)
 
 
- project proposals (dlenrow, 14:11:25)
  - first project proposal introduced by Uli
    (dlenrow,
    14:14:40)
 
  - https://wiki.opnfv.org/continuous_integration_ci
    (ulik,
    14:14:43)
 
  - Uli volunteers that this is very long and my be
    too much info for proposal, asks for feedback (dlenrow,
    14:19:29)
 
  - dlenrow suggests we try to keep project
    proposal to scope and generality and move deep design/description to
    project work product. (dlenrow,
    14:20:05)
 
  - CP points out that some of content describes
    things that will be provided by LF, and thus not part of CI
    project (dlenrow,
    14:20:36)
 
  - Policy for branching may want to be
    per-project. Is in-scope for TSC development steering, but out of
    scope for CI project (dlenrow,
    14:23:43)
 
  - Bryan Sullivan (bryan_att,
    14:25:08)
 
  - ACTION: Begin work on
    a draft development process draft. Frank, Palani, CP (dlenrow,
    14:26:20)
 
  -  (Thinh_,
    14:27:09)
 
  - ACTION: Schedule a
    call regarding development process  Palani (dlenrow,
    14:27:22)
 
  - Palani points out that  use-case subproject has
    identified some basic use cases and traffic patterns to test. Can
    provide basis for canonical/infra VNFs in OPNFV (dlenrow,
    14:30:57)
 
  - Uli describes possible need for developer smoke
    test that is less involved than larger system/release test
    coverage. (dlenrow,
    14:32:14)
 
  - dlenrow reminds that any gap between CI
    coverage and release coverage will lead to pain. Need to make as
    small as possible (dlenrow,
    14:36:28)
 
  - Discussion about where glue code should live
    before or instead of pushing to upstream projects. (dlenrow,
    14:38:40)
 
  - development process for OPNFV should include
    guidance for how we structure code that needs to build on upstream
    projects (dlenrow,
    14:40:44)
 
  - frank suggests subprojects within development
    process to address different (local integration, test, global
    integration) needs (dlenrow,
    14:43:13)
 
  - frank asks for follow up meeting this week on
    this topic (dlenrow,
    14:44:30)
 
  - ACTION: Uli to
    schedule meeting to discuss dev process around upstream
    co-existence (dlenrow,
    14:44:48)
 
  - Send suggestions to email list to kick off
    upstream dev process discussion (dlenrow,
    14:45:19)
 
  - dlenrow we need to discuss assumption that we
    will continuously pull top of dev tree for upstreams (dlenrow,
    14:46:40)
 
  - palani suggests we need to plan our releases
    (stable, latest, etc.) within OPNFV (dlenrow,
    14:48:53)
 
  - agree to follow up in breakout meetings and
    close discussion of CI project in order to get time on other
    proposals (dlenrow,
    14:50:19)
 
 
- Testing Project Proposals (dlenrow, 14:50:52)
  - there is a thursday AM meeting weekly to
    discuss test project. (dlenrow,
    14:52:58)
 
  - re the test meeting - send a calendar invite to
    the list - that ensures it gets on our calendars best (bryan_att,
    14:53:04)
 
  - ACTION: Pranav Mehta
    to put test meeting info on Wiki (dlenrow,
    14:54:04)
 
  - agree to discuss test project after groups next
    weekly meeting (dlenrow,
    14:54:18)
 
  - parviz suggests that we prioritize discussions
    of work items for weekly agenda. (dlenrow,
    14:57:14)
 
 
- packaging (dlenrow, 15:00:03)
  - CP asks which automation tool (chef, puppet,
    etc)? (dlenrow,
    15:00:19)
 
  - Frank suggests this "continuous deployment" is
    possibly a standalone project scope (dlenrow,
    15:01:11)
 
  - CP points out tradeoffs between choosing a
    packaging tool versus allowing latitude for selection (dlenrow,
    15:01:37)
 
  - CP suggests we add packaging tooling to Uli's
    call this week (dlenrow,
    15:03:00)
 
  - https://wiki.opnfv.org/requirements_projects/resource_management
    (Ashiq_docomo,
    15:04:23)
 
 
- resource management project (dlenrow, 15:04:34)
  - https://wiki.opnfv.org/requirements_projects/resource_management
    (dlenrow,
    15:04:47)
 
  - Ashiq leads discussion on proposal doc
    (dlenrow,
    15:06:10)
 
  - Ashiq points out that this functionality may
    not need to live permanently within OPNFV. Probably moves
    upstream. (dlenrow,
    15:07:58)
 
  - summary calendar scheduling for compute,
    storage, and network resources by exposing NBIs from
    OpenStack (dlenrow,
    15:10:13)
 
  - Project Proposal: List of contributors &
    Committers will remain open until the project approval vote by
    TSC. (dlenrow,
    15:14:45)
 
  - Clarification on founding committers. CP
    restates that these must be long-term, planning to be a significant
    participant. (dlenrow,
    15:16:58)
 
  - Parviz asks what is relationship/requirement to
    cite e.g. ETSI documents in projects/proposals (dlenrow,
    15:17:34)
 
  - Ashiq states that reference in proposal is for
    informational purposes and cites an existing NFV doc in
    support (dlenrow,
    15:18:28)
 
  - https://wiki.opnfv.org/requirements_projects/doctor_fault_mangement_and_maintenance
    (Ashiq_docomo,
    15:19:16)
 
 
- Doctor Project - fault management and maintenance (dlenrow, 15:19:42)
  - https://wiki.opnfv.org/requirements_projects/doctor_fault_mangement_and_maintenance
    (dlenrow,
    15:19:52)
 
  - Ashiq notes that this describes functionality
    missing from OpenStack (dlenrow,
    15:20:38)
 
  - diagrams show block diagram of root cause
    analysis and mapping faults to affected users/VMs, etc. (dlenrow,
    15:21:58)
 
  - detect, inform affected user/tenant,
    instructions on if/how to recover VMs (dlenrow,
    15:22:48)
 
  - Palani asks when/where do we discuss details of
    individual faults and responses. (dlenrow,
    15:25:42)
 
  - Project proposal "Copper (Virtual
    Infrastructure Deployment Policies)" is at
    https://wiki.opnfv.org/requirements_projects/virtual_infrastructure_deployment_policies
    (bryan_att,
    15:29:05)
 
  - ACTION: dlenrow to
    schedule call this week to discuss S/R  planning (dlenrow,
    15:29:12)
 
 
- virtual infra deployment project (dlenrow, 15:29:39)
  - https://wiki.opnfv.org/requirements_projects/virtual_infrastructure_deployment_policies
    (dlenrow,
    15:29:49)
 
  - Bryan introduces policy as means to
    define/deploy VNFs (dlenrow,
    15:31:32)
 
  - propose that we start from use case
    requirements and propose policy means to achieve (dlenrow,
    15:32:41)
 
  - seeking contributors and committers
    (dlenrow,
    15:33:48)
 
  - Question: Is this just a requrements.
    Project? (dlenrow,
    15:38:20)
 
  - discussion about relationship between project
    proposals, requirements, implementation (dlenrow,
    15:38:41)
 
  - dlenrow points out that project scope should be
    much bigger than a single release. Release is a subset of scope in
    something larger. (dlenrow,
    15:39:05)
 
  - IPv6-enabled Vanilla OPNFV project proposal is
    at https://wiki.opnfv.org/ipv6-enabled_vanilla_opnfv (bryan_att,
    15:39:29)
 
 
- Recurring weekly calls on general technical content (dlenrow, 15:39:40)
  - it would be great for us to coordinate
    project-specific calls on the wiki (bryan_att,
    15:40:32)
 
  - https://wiki.opnfv.org/ipv6-enabled_vanilla_opnfv
    (dlenrow,
    15:40:34)
 
  - may I suggest to upload requirement project
    proposals under the /requirement_projects (Ashiq_docomo,
    15:40:56)
 
  - CP asks for volunteer to insure that all
    recurring meetings are maintained on wiki (dlenrow,
    15:41:13)
 
  - ACTION: bin to
    organize wiki meeting list (dlenrow,
    15:41:50)
 
  - posting project proposal to wiki and sending
    email announcing to TSC officially starts the two week public review
    period for a proposal (dlenrow,
    15:43:13)
 
  - ACTION: CP to call
    meetign and propose project structure back to TSC (dlenrow,
    15:44:18)
 
 
- release naming convention (dlenrow, 15:44:37)
  - palani say Ray has created poll to gather
    feedback for release naming themes. (dlenrow,
    15:45:35)
 
  - ACTION: Ray will
    email list to announce URL and open the voting window. Plan to post
    tomorrow and leave open for a week. (dlenrow,
    15:46:10)
 
  - AGREED: to start
    release name theme voting with the five candidates: cities,
    gemstones, rivers, nobel prize winners, mountains? (dlenrow,
    15:50:32)
 
  - Vote is open to everyone. Not limited to TSC
    members or companies, etc. (dlenrow,
    15:51:39)
 
 
- Open Agenda (dlenrow, 15:51:49)
  - Ray asks about need for GoToMeeting
    setup/accounts for other meetings and recurring calls. Currently
    cannot run simultaneous meetings due to license. (dlenrow,
    15:52:36)
 
  - proposes getting more accounts and delegating
    admin controls to community. (dlenrow,
    15:53:44)
 
  - CP suggests in short term we avoid concurrent
    meetings. (dlenrow,
    15:53:59)
 
  - try not to use corporate conferencing
    resources, invitations, etc. to prevent apparent corporate
    bias (dlenrow,
    15:55:15)
 
  - Thinh_: Thanks for helping with minutes.
    (dlenrow,
    15:56:00)
 
  - Asks status of liaison. Points out we have
    opportunity to interact at NFV 8 and should plan for same
    (dlenrow,
    15:56:49)
 
  - CP states we don't have a SPOC for liaison
    yet. (dlenrow,
    15:57:29)
 
  - noted that board level liaising probably also
    going on. Need to sync (dlenrow,
    15:57:55)
 
  - asks what is our official dependency on ETSI
    NFV SIG? Need to clarify? (dlenrow,
    15:58:16)
 
  - ACTION: CP to put
    liaison discussion on agenda for next week (dlenrow,
    15:58:43)
 
  - Daylight savings change in Europe coming up.
    Europe go one hour earlier on last Sunday October, one week before
    USA. Don't be fooled! (dlenrow,
    15:59:43)
 
 
Meeting ended at 16:00:02 UTC
(full logs).
Action items
  - Begin work on a draft development process draft. Frank, Palani, CP
 
  - Schedule a call regarding development process  Palani
 
  - Uli to schedule meeting to discuss dev process around upstream co-existence
 
  - Pranav Mehta to put test meeting info on Wiki
 
  - dlenrow to schedule call this week to discuss S/R  planning
 
  - bin to organize wiki meeting list
 
  - CP to call meetign and propose project structure back to TSC
 
  - Ray will email list to announce URL and open the voting window. Plan to post tomorrow and leave open for a week.
 
  - CP to put liaison discussion on agenda for next week
 
Action items, by person
  -  dlenrow 
    - dlenrow to schedule call this week to discuss S/R  planning
 
  
 
  - UNASSIGNED
    - Begin work on a draft development process draft. Frank, Palani, CP
 
    - Schedule a call regarding development process  Palani
 
    - Uli to schedule meeting to discuss dev process around upstream co-existence
 
    - Pranav Mehta to put test meeting info on Wiki
 
    - bin to organize wiki meeting list
 
    - CP to call meetign and propose project structure back to TSC
 
    - Ray will email list to announce URL and open the voting window. Plan to post tomorrow and leave open for a week.
 
    - CP to put liaison discussion on agenda for next week
 
  
 
People present (lines said)
  - dlenrow (93)
 
  - bryan_att (6)
 
  - ChrisPriceAB (6)
 
  - Ashiq_docomo (5)
 
  - frankbrockners (3)
 
  - TapioT (3)
 
  - pals (3)
 
  - ulik (3)
 
  - Thinh_ (2)
 
  - morgan_orange (2)
 
  - bin_ (2)
 
  - collabot` (2)
 
  - Wenjing_ (2)
 
  - arnaud_orange (1)
 
  - MikeBugenhagen (1)
 
  - B_Smith_ (1)
 
Generated by MeetBot 0.1.4.