#opnfv-meeting: OPNFV TSC Meeting

Meeting started by ChrisPriceAB at 14:01:44 UTC (full logs).

Meeting summary

    1. Ashiq Khan (ashiq_, 14:02:00)

  1. TSC members roll call (ChrisPriceAB, 14:02:03)
    1. Chris Price (ChrisPriceAB, 14:02:25)
    2. Steve Gordon (proxy for Chris Wright) (sgordon_, 14:05:01)
    3. Wenjing Chu (Wenjing, 14:05:06)
    4. Serge Manning (Serge_, 14:05:09)
    5. Frank Brockners (frankbrockners, 14:05:11)
    6. Uli Kleber (ulik, 14:05:12)
    7. Pranav Mehta (Pranav, 14:05:17)
    8. Brian Smith (B_Smith, 14:05:21)
    9. Palani (Palani, 14:05:33)
    10. dlenrow (dlenrow, 14:08:36)
    11. CP to add to agenda: discussion of releasing FOSS vs non-FOSS VNFs (dlenrow, 14:10:23)

  2. OpenStack metup in Paris. (ChrisPriceAB, 14:10:58)
    1. NFV sub-team activities are planned in the open stack conference. (ChrisPriceAB, 14:12:54)
    2. discussion of ways to sync OPNFV with OpenStack NFV discussions at Paris and beyond (dlenrow, 14:13:25)
    3. multiple folks point out existence of NFV tracks at Paris (dlenrow, 14:13:45)
    4. http://kilodesignsummit.sched.org/event/b3ccf1464e335b703fc126f068142792 (sgordon_, 14:13:51)
    5. http://kilodesignsummit.sched.org/event/aa14a2bd2a4c1afa1aa24a60c3131fcc (sgordon_, 14:14:00)
    6. https://wiki.openstack.org/wiki/Teams/NFV (sgordon_, 14:14:05)
    7. links from sgordon to Paris sessions he's aware of above (dlenrow, 14:14:24)
    8. Wed eve and Thurs morning are times we should join OpenStack community sessions (dlenrow, 14:15:28)
    9. CP proposes OPNFV pre-meeting (dlenrow, 14:15:54)
    10. dlenrow try to get room and send invite to list for Tues or Wed AM premeeting (dlenrow, 14:16:37)
    11. ACTION: dlenrow get room and send invite (dlenrow, 14:17:15)
    12. question about remote participation in premeeting (dlenrow, 14:17:55)
    13. and more importantly is the meeting open to remote non registered attendance? (bryan_att, 14:18:07)
    14. likely etherpad and IRC only at summit. (dlenrow, 14:18:25)
    15. we can try to get GTM working too (dlenrow, 14:20:23)
    16. HELP: (Pranav, 14:21:44)
    17. should be able to use the new GTM account that we just setup if needed (rpaik, 14:21:54)
    18. asks is this instead of or in addition to TSC call next tuesday (dlenrow, 14:22:02)
    19. clarification We will have a TSC meeting at regular time and in addititon another meeting of folks that are attending F2F (dlenrow, 14:24:02)
    20. both meetings will try to have common room at summit and include remote folks with all available tools (IRC, etherpad, GTM) (dlenrow, 14:24:32)
    21. Uli updates that we agreed to keep project proposal short and simple. Problem statement. Push lots of detail to project work items later. (dlenrow, 14:25:46)
    22. Offers to show new, concise project proposal draft (dlenrow, 14:26:15)
    23. https://wiki.opnfv.org/wiki/call_to_continue_ci_project_proposal (rpaik, 14:27:38)
    24. ACTION: Uli to rearrange existing doc so we he can submit and start 2 week public review period. Thursday 10/30 deadline. (dlenrow, 14:32:23)
    25. dlenrow asks if this is time to discuss parallel progress on CI prototyping and experimentation (dlenrow, 14:35:19)
    26. CP suggests we discuss on mail lists to keep agenda moving (dlenrow, 14:35:39)
    27. Frank points out we can build a non-official sandbox where folks can do work without waiting on official OPNFV infrastructure (dlenrow, 14:36:21)
    28. CP asks rpaik about LF ability to create infrastructure sandbox to allow collaboration. (dlenrow, 14:37:08)
    29. ACTION: rpaik to inquire about lead times in LF and report to lists (dlenrow, 14:37:26)
    30. CP suggests we continue on the lists. (dlenrow, 14:38:52)
    31. Trevor provides update on test subgroup (dlenrow, 14:39:41)
    32. first weekly call started last week. Thursday 7AM Pacific is recurring time. Notes on wiiki (dlenrow, 14:40:12)
    33. 4 streams of work (dlenrow, 14:40:20)
    34. test bed infras Orange/CableLabs are drafting proposal based on studying similar communities. First cut of doc late next week (dlenrow, 14:41:32)
    35. HW/SW definition of the reference platform: Using what's available today. Made proposal for hosted Infra. Working on proposal. (dlenrow, 14:42:45)
    36. System under test HW/SW proposal based on available parts. (dlenrow, 14:43:36)
    37. IT Testbed Tooling Dell has made a proposal addressing CI and test interface, also proposed toolset and getting community input (dlenrow, 14:44:23)
    38. Use Cases: Palani/Cisco leading macro/micro benchmarking and initial use cases identified.. Proposing 4 major use cases from ETSI (dlenrow, 14:45:27)
    39. working from ETSI cases: virtual provider edge, Virtual PCE, CDN, home gateway. Also identified VNF candidates (dlenrow, 14:46:14)
    40. Palani adds he needs to resolve policy regarding VNF targets for testing (FOSS, non-FOSS) (dlenrow, 14:47:01)
    41. CP asks how we structure repo/infra for each of the use cases? (dlenrow, 14:49:03)
    42. Virtual PCE above should have been Virtual EPC (not to be confused with virtual CPE) (dlenrow, 14:50:16)
    43. discussion of structuring tests/use-cases. (dlenrow, 14:51:10)
    44. Trevor suggests that eventually we propose to TSC (dlenrow, 14:52:12)
    45. Pranav suggests that use-case repo could be different from other Test infra repo (dlenrow, 14:53:12)
    46. Pavani has done some work towards some of these use cases and can provide some suggestions. (dlenrow, 14:54:19)
    47. Pavani says he's headed towards split/distributed EPC because that's how most deployments will work (dlenrow, 14:54:55)
    48. Parviz asks when/if TSC will be asked to approve specifics (dlenrow, 14:56:02)
    49. Pranav points out this is just discussion. Proposal should include this when brought for approval (dlenrow, 14:57:07)
    50. dlenrow reminds that project proposal is mostly about scope. Solving the specific problems in scope becomes work product of project. Need to get proposals queued for approval (dlenrow, 14:57:47)
    51. Bin asks about US daylight savings change. Meeting is pinned to US Pacific TZ and will follow DST rules there. (dlenrow, 14:59:07)
    52. dlenrow asks if there is a schedule to post the test project proposal for review. CP says no deadline yet. (dlenrow, 15:01:35)
    53. Palani clarafies that Use cases and test infra need to be two different projects. CP assume we'll get more than one project from (dlenrow, 15:02:14)
    54. Parviz 1) Do we plan to have VNFs in release 1.0 (dlenrow, 15:02:46)
    55. CP we won't release VNFS or Mano components (dlenrow, 15:03:08)

  3. simultaneous release process (ChrisPriceAB, 15:05:14)
    1. dlenrow states the discussion on simultaneous release was agreed to focus on the release rpocess and delegate the perifferal problems to other projects and processes to solve. (ChrisPriceAB, 15:05:55)
    2. the simultaneous release process is planned to fulfill a 6 month release cadence (ChrisPriceAB, 15:06:23)
    3. the proposal is available on the WiKi indicating dates and process. (ChrisPriceAB, 15:06:49)
    4. dlenrow taking outcome of SR discussion meeting and and build draft. (dlenrow, 15:08:11)
    5. ACTION: dlenrow to upload the process to the WiKi (ChrisPriceAB, 15:08:19)
    6. ACTION: dlenrow to post draft SR document to wiki (dlenrow, 15:08:27)
    7. ACTION: dlenrow to post draft SR document to wiki Thursdayt 10/30 (dlenrow, 15:08:56)
    8. 2015.1 ("Kilo") release: Apr 23 (sgordon_, 15:10:24)
    9. CP reminds current board commitment is V 1.0 release March 2015. Another date we've discussed is May 2015. (dlenrow, 15:10:31)
    10. End of may would be after OpenStack Kilo and ODL Lithium (dlenrow, 15:11:03)
    11. CP asks for discussion of goals for delivering V 1.0 (dlenrow, 15:11:40)
    12. Pranav asks if we have created table based on upstream dates that show possible release windows. (dlenrow, 15:12:29)
    13. CP took action last week and this is in progress. (dlenrow, 15:12:46)
    14. frankbrockners reminds we agreed to walk before run approach. Asks can we all agree that we do little more than pull upstreams together and show packaging and infra (dlenrow, 15:14:07)
    15. points out above would be fairly independent of upstream schedules? (dlenrow, 15:14:29)
    16. still need to pick date for "walk". frankbrockners doesn't feel we have sufficient info to pick a hard date yet (dlenrow, 15:15:23)
    17. Pranav wants to talk about what it means to "walk" (dlenrow, 15:15:59)
    18. frankbrockners suggest first release point at stable upstreams (dlenrow, 15:16:26)
    19. CP points out that we will have to hold patches to even walk and thus non-trivial to "walk" (dlenrow, 15:17:08)
    20. kernelcdub notes that we can still deliver stuff outside of SRs (dlenrow, 15:18:55)
    21. CP notes that dlenrow SR proposal needs to address stable updates. (dlenrow, 15:19:18)
    22. kernelcdub adds that we can release pieces "piecemeal" (dlenrow, 15:19:44)
    23. Summary on dates: CP we can't yet define a date. BOD date hasn't been confirmed or denied by TSC. Need more info/progress (dlenrow, 15:20:53)
    24. https://lists.opnfv.org/mailman/private/opnfv-tech-discuss/2014-October/000128.html (sgordon_, 15:25:08)
    25. Tapio's on list response regarding critical functionality for NFV (sgordon_, 15:25:22)
    26. https://wiki.openstack.org/wiki/Teams/NFV#Development_Efforts (Tapio_, 15:25:59)
    27. https://wiki.openstack.org/wiki/Teams/NFV#Development_Efforts (sgordon_, 15:26:07)
    28. http://nfv.russellbryant.net/ (Tapio_, 15:26:27)
    29. Possible Kilo requirements?: CPU pinning, large pages support, enhanced NUMA awareness, VLAN trunking to VM (sgordon_, 15:26:44)
    30. How can OPNFV work with upstream communities on requirements and ultimately feature roadmaps (sgordon_, 15:27:11)
    31. Ashiq suggests having formal liasion for upstream projects (rpaik, 15:28:01)
    32. cdub suggests bringing OPNFV developer resources along with requirements to upstream projects (sgordon_, 15:30:22)
    33. requirements for being included in the build/ci system? (sgordon_, 15:37:43)
    34. Can look at both FOSS & proprietary VNFs. For proprietary VNFs, we need to consider issues around licensing, performanace data, etc. (rpaik, 15:43:39)

  4. release naming poll (ChrisPriceAB, 15:47:25)
    1. the poll has been open for a while, will close at the end of this week. (ChrisPriceAB, 15:47:44)
    2. the top two options are quite close on voting. (ChrisPriceAB, 15:48:01)
    3. ACTION: Test & Perf sub-team to make recommendations on VNFs (rpaik, 15:48:08)
    4. the use of an [ACTION REQUIRED] tag is proposed to be used when sending e-mail to the lists requiring action from list members (ChrisPriceAB, 15:51:20)

  5. goto meeting account for tSC (ChrisPriceAB, 15:52:48)
    1. we have a new GoTo meeting account for use in technical and TSC discussions. (ChrisPriceAB, 15:53:10)
    2. Ray has the username and password that can be requested for meeting organisers when running GoTo meetings (ChrisPriceAB, 15:53:33)
    3. meetings cannot overlap due to restrictions on the account. (ChrisPriceAB, 15:54:00)
    4. do we have a master meeting schedule on the wiki? (bryan_att, 15:54:19)

  6. Any other business (ChrisPriceAB, 15:54:21)
    1. Ashiq raises the topic of reaching out to and working with upstream communities. (ChrisPriceAB, 15:54:40)
    2. OpenStack NFV subteam meeting tomorrow at 1600 UTC (sgordon_, 15:55:39)
    3. Guidelines should be described in the development process. Palani has established a meeting call to begin to work on that between 07:00 - 08:00 PST tomorrow (ChrisPriceAB, 15:55:46)
    4. https://wiki.openstack.org/wiki/Teams/NFV#Agenda_for_next_meeting (sgordon_, 15:56:01)
    5. if we could get those leading project meetings to update it, I can create a calendar page on the wiki to capture meetings (bryan_att, 15:56:51)
    6. tomorrow's NFV subteam meeting largely focused on summit planning/finalization (sgordon_, 15:57:00)


Meeting ended at 15:58:33 UTC (full logs).

Action items

  1. dlenrow get room and send invite
  2. Uli to rearrange existing doc so we he can submit and start 2 week public review period. Thursday 10/30 deadline.
  3. rpaik to inquire about lead times in LF and report to lists
  4. dlenrow to upload the process to the WiKi
  5. dlenrow to post draft SR document to wiki
  6. dlenrow to post draft SR document to wiki Thursdayt 10/30
  7. Test & Perf sub-team to make recommendations on VNFs


Action items, by person

  1. dlenrow
    1. dlenrow get room and send invite
    2. dlenrow to upload the process to the WiKi
    3. dlenrow to post draft SR document to wiki
    4. dlenrow to post draft SR document to wiki Thursdayt 10/30
  2. rpaik
    1. rpaik to inquire about lead times in LF and report to lists
  3. UNASSIGNED
    1. Uli to rearrange existing doc so we he can submit and start 2 week public review period. Thursday 10/30 deadline.
    2. Test & Perf sub-team to make recommendations on VNFs


People present (lines said)

  1. dlenrow (80)
  2. ChrisPriceAB (30)
  3. sgordon_ (17)
  4. rpaik (8)
  5. cdub (6)
  6. bryan_att (5)
  7. dneary (4)
  8. collabot (4)
  9. Pranav (3)
  10. Tapio_ (2)
  11. ulik (2)
  12. frankbrockners (1)
  13. ashiq_ (1)
  14. Palani (1)
  15. Serge_ (1)
  16. Wenjing (1)
  17. B_Smith (1)


Generated by MeetBot 0.1.4.