#opnfv-meeting: OPNFV TSC

Meeting started by dlenrow at 15:08:11 UTC (full logs).

Meeting summary

  1. role call (dlenrow, 15:08:21)
    1. dlenrow (dlenrow, 15:08:26)
    2. Chris Price (ChrisPriceAB, 15:08:27)
    3. Frank Brockners (frankbrockners, 15:08:37)
    4. uli (uli__, 15:09:26)
    5. Tapio Tallgren (Nokia) (TapioT, 15:10:19)
    6. Thinh Nguyenphu (Nokia) (Thinh_, 15:11:22)
    7. Andrea (dlenrow, 15:12:00)
    8. Pranav Mehta (Pranav, 15:12:27)
    9. Bin (AT&T) (bin_, 15:12:35)
    10. minutes from last meeting approved by lack of opposition (dlenrow, 15:13:01)
    11. board meeting summary added to today's agenda (dlenrow, 15:13:49)
    12. https://etherpad.opnfv.org/ (aricg, 15:16:17)
    13. https://jenkins.opendaylight.org/controller/ (aricg, 15:16:17)
    14. https://gerrit.opnfv.org/gerrit/#/ (aricg, 15:16:17)
    15. https://jira.opnfv.org/secure/Dashboard.jspa (aricg, 15:16:17)
    16. https://lists.opnfv.org/ (aricg, 15:16:17)
    17. https://ask.opnfv.org/questions/ (aricg, 15:16:19)

  2. project status (dlenrow, 15:17:24)
    1. CP notes that in community discussion question was raised why we have a login/password. (dlenrow, 15:19:26)
    2. idea was to prevent spammers (dlenrow, 15:19:52)
    3. discussion of ways to make access easier (dlenrow, 15:20:11)
    4. ACTION: aric to investigate removing password protection on OPNFV Etherpad (dlenrow, 15:22:17)
    5. Hui (rpaik, 15:23:13)
    6. Uli asks whether there is a way to discover Etherpads, answer no. You need to know of them ahead of time (dlenrow, 15:23:39)
    7. jenkins is setup, correct link to reach it is https://build.opnfv.org/ci/ (dlenrow, 15:25:05)
    8. gerrit is setup, link is https://gerrit.opnfv.org/gerrit/#/ (dlenrow, 15:25:50)
    9. Etherpad is https://etherpad.opnfv.org/ (dlenrow, 15:26:14)
    10. CP reminds that we need a getting started guide for devs in OPNFV that describes how to start using all these tools (dlenrow, 15:26:54)
    11. gerrit is where we do/manage code reviews (dlenrow, 15:27:28)
    12. opnfv-helpdesk@rt.linuxfoundation.org for opening tickets (rpaik, 15:27:35)
    13. Jira is setup https://jira.opnfv.org/secure/Dashboard.jspa (dlenrow, 15:27:49)
    14. question from Pals about how/where we run tools that need specific OS e.g. Linux (dlenrow, 15:30:22)
    15. fbrockners points out that compute/memory requirements for OPNFV dev may not fit on laptops very well. (dlenrow, 15:31:06)
    16. discussion about getting pool of development systems with needed resources to support devs logging in remotely (dlenrow, 15:32:31)
    17. aric suggess we might be able to do on google compute (dlenrow, 15:32:48)
    18. ACTION: palani and Aric to propose a solution (dlenrow, 15:33:09)
    19. discussion of which linux distro to include in our OPNFV OStack distro (dlenrow, 15:39:22)
    20. Tom N suggests OpenStack on Ubuntu is the only combination that is easy to use and non-commercial (dlenrow, 15:40:29)
    21. clarify above non-commercial means free, main trunk (dlenrow, 15:41:15)
    22. devstack is an easy way to get started for developers (if they have 8g+ of RAM) it supports Ubuntu 14.04 (Trusty), Fedora 20 and CentOS/RHEL 6.5 (aricg, 15:41:50)
    23. CP points out that long term we need to support many linux distros (dlenrow, 15:42:15)
    24. general agreement that if a commercial distro helped us get rel 1.0 out the door, (dlenrow, 15:42:54)
    25. TN points out that we agreed that we won't release any commercial stuff among our artifacts (dlenrow, 15:43:50)
    26. Frank suggests we post to the list that we plan to use Ubuntu and see if community objects (dlenrow, 15:44:20)
    27. ACTION: fbrockners email list regarding Ubuntu selection proposal (dlenrow, 15:44:52)
    28. Tapio asks did we agree to use packstack? (dlenrow, 15:46:37)
    29. fbrockners suggests that toolchain and linux distro are coupled and we need to have more discussion about the choices (dlenrow, 15:47:38)
    30. We have prevously discussed making the packaging tool an upstream project that we pull in (dlenrow, 15:48:11)
    31. agreement that we need more discussion on packaging tool (dlenrow, 15:48:52)
    32. question re: what does ODL do. answer: Karafe which is java specific and won't solve our multi-language project requirements (dlenrow, 15:50:06)
    33. CP suggests we create a wiki page for a dev sandbox and make Palani project lead (dlenrow, 15:51:29)
    34. ACTION: palani to create wiki page for dev sandbox,, will be project lead, Contributors welcome, contact pals (dlenrow, 15:52:19)
    35. ACTION: CP to start the wiki for dev sandbox. (dlenrow, 15:52:40)
    36. dlenrow found tool that converts doc/pdf to wiki language so we don't have to learn it (dlenrow, 15:53:38)

  3. Ray's list of topics (dlenrow, 15:54:27)
    1. question re: open mail list archives to anyone, even if not subscribed to list? (dlenrow, 15:55:07)
    2. CP points out that if we send a link to somebody outside the community, they can't follow without subscribing. (dlenrow, 15:55:44)
    3. Agreed by lack of objection to open archives to anyone (not by official vote) (dlenrow, 15:56:29)
    4. ACTION: CP to send email to list informing that we plan to open the archives to all. (dlenrow, 15:56:59)
    5. agreed not to decide now on opening archives, will wait for response to CP email from community (dlenrow, 15:57:21)
    6. Q: Do we want to have a meetup event at LF collaboration event Feb 18-20 in Sonoma. ? (dlenrow, 15:59:30)
    7. note: conflicts with Chinese Lunar New Year, this would be one of 4 per year. (dlenrow, 16:00:05)
    8. question is there a better time or venue for 1Q2014? (dlenrow, 16:01:01)
    9. M-P suggests we colocate with ETSI, in Prague, 2/24-27 (dlenrow, 16:02:52)
    10. ACTION: ray to compose email describing 1Q2015 hackfest options and get community input. (dlenrow, 16:04:04)
    11. CP points out that if we get free room/venue from LF in Sonoma, there's no reason not to have hackfest and folks in CA might as well have F2F (dlenrow, 16:04:55)
    12. pramesh@linuxfoundation.org (rpaik, 16:07:46)
    13. anyone planning to blog re: OStack summit? Anyone interested in doing so should contact pramesh@linuxfoundation.org (dlenrow, 16:08:34)
    14. marie-paul to check about Prague availability and contact vanessa Herick (dlenrow, 16:09:27)
    15. Vanessa’s email @LF vheric@linuxfoundation.org (rpaik, 16:10:55)
    16. Time of OPNFV TSC call is not convenient for Asia. There have been some complaints. Proposing 6AM pacific on tuesdays. (dlenrow, 16:10:59)
    17. ACTION: ray to propose this new time to the TSC list and ask for feedback (dlenrow, 16:13:13)

  4. CI project update (dlenrow, 16:13:45)
    1. Uli hasn't gotten much feedback. Needs more responses. before he can progress. (dlenrow, 16:14:48)
    2. Need to advertise the location of project proposals so that folks look. (dlenrow, 16:15:33)
    3. CP suggests a meeting (GTM) to discuss/review CI Proposal (dlenrow, 16:16:12)
    4. CP reminds process: put proposal on wiki, email to TSC list, two week public review, (dlenrow, 16:17:09)
    5. dlenrow asks does lack of CI Project approval keep us from progressing the CI work? (dlenrow, 16:17:37)
    6. CP no hard reason, but generally we need to start getting projects formalized ASAP (dlenrow, 16:18:13)
    7. ACTION: Uli to setup meeting to review CI proposal. (dlenrow, 16:19:32)
    8. CP reminds we need to know who can commit developers to work on CI (dlenrow, 16:20:18)
    9. Uli states that he expects/hopes HP, ericsson, RH, provide resources (dlenrow, 16:21:21)
    10. CP encourages folks to research their resource commitment plans. We need contributors/committers (dlenrow, 16:22:06)
    11. marie-paul asks whether LF will provide the sandbox Infrastructure (dlenrow, 16:22:33)

  5. other project status (dlenrow, 16:23:46)
    1. Uli reminds we have two projects that should begin 2 week review period (dlenrow, 16:24:47)
    2. parser project and IPV6 project are ready for this. (dlenrow, 16:25:20)
    3. policy project not ready quite, resource reservation project also not there yet (dlenrow, 16:25:50)
    4. call this week hope to get these two ready to start review (dlenrow, 16:26:10)
    5. ACTION: Uli to make sure emails get sent to start clock on the review period (dlenrow, 16:29:20)
    6. Bin's weekly thursday calls will continue to provide venue to review project proposals (dlenrow, 16:29:50)
    7. pals asks should he create a project around benchmarking for well known use cases (dlenrow, 16:34:34)
    8. we agree to discuss on lists and at next TSC. Need a general approach to defining/mapping projects to work we do (dlenrow, 16:37:06)
    9. Need to resolve the questions about what we make a project ASAP (dlenrow, 16:39:05)
    10. clarify requirements for creating project. 1) email to TSC announcing project proposal and begin (minimum) two weeks public review 2) email to TSC asking to approve a project that has had at least two weeks public review (dlenrow, 16:41:00)
    11. reminder, if your project doesn't need LF infra setup (e.g. requirements project) work can begin without project approval (dlenrow, 16:42:33)
    12. Even for documentation projects we want git/gerrit/etc. so we plan to create a repo for all projects. (dlenrow, 16:44:31)
    13. no decision taken on moving project proposals from wiki to source conrol tools (dlenrow, 16:47:32)
    14. ACTION: CP to share slides he presented to the BOD (dlenrow, 16:47:53)

  6. OPNFV BOD summary (dlenrow, 16:48:09)
    1. CP presented three categories of projects, upstream, transient, OPNFV (dlenrow, 16:48:46)
    2. CP updated on some tool choices and project proposals (dlenrow, 16:49:13)
    3. CP informed BOD that we need more headcount assigned, more community engagement (dlenrow, 16:49:45)
    4. CP informed BOD that we need and are working on upstream project timing and implications for our relese (dlenrow, 16:50:29)
    5. Uli asks should we start to decide what use cases to try and support in first release. (dlenrow, 16:52:16)
    6. CP points out we need to get an SR process in place before we can decide this (dlenrow, 16:52:39)

  7. OStack summit activity (dlenrow, 16:55:19)
    1. working on making sure we cover NFV OS sessions. (dlenrow, 16:56:17)
    2. ACTION: Tapio to work with aric and Jonne Soininen to start wiki and writeup of developers beginner guide (dlenrow, 16:57:05)


Meeting ended at 16:57:44 UTC (full logs).

Action items

  1. aric to investigate removing password protection on OPNFV Etherpad
  2. palani and Aric to propose a solution
  3. fbrockners email list regarding Ubuntu selection proposal
  4. palani to create wiki page for dev sandbox,, will be project lead, Contributors welcome, contact pals
  5. CP to start the wiki for dev sandbox.
  6. CP to send email to list informing that we plan to open the archives to all.
  7. ray to compose email describing 1Q2015 hackfest options and get community input.
  8. ray to propose this new time to the TSC list and ask for feedback
  9. Uli to setup meeting to review CI proposal.
  10. Uli to make sure emails get sent to start clock on the review period
  11. CP to share slides he presented to the BOD
  12. Tapio to work with aric and Jonne Soininen to start wiki and writeup of developers beginner guide


Action items, by person

  1. pals
    1. palani to create wiki page for dev sandbox,, will be project lead, Contributors welcome, contact pals
  2. UNASSIGNED
    1. aric to investigate removing password protection on OPNFV Etherpad
    2. palani and Aric to propose a solution
    3. fbrockners email list regarding Ubuntu selection proposal
    4. CP to start the wiki for dev sandbox.
    5. CP to send email to list informing that we plan to open the archives to all.
    6. ray to compose email describing 1Q2015 hackfest options and get community input.
    7. ray to propose this new time to the TSC list and ask for feedback
    8. Uli to setup meeting to review CI proposal.
    9. Uli to make sure emails get sent to start clock on the review period
    10. CP to share slides he presented to the BOD
    11. Tapio to work with aric and Jonne Soininen to start wiki and writeup of developers beginner guide


People present (lines said)

  1. dlenrow (98)
  2. aricg (13)
  3. TapioT (8)
  4. rpaik (5)
  5. frankbrockners (4)
  6. uli__ (3)
  7. Pranav (2)
  8. ChrisPriceAB (2)
  9. collabot (2)
  10. Thinh_ (1)
  11. pals (1)
  12. bin_ (1)


Generated by MeetBot 0.1.4.