#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 14:59:12 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 14:59:44)
    1. Chris Price (ChrisPriceAB, 14:59:55)
    2. Trevor Cooper (trevor_intel, 15:01:01)
    3. Aric Gardner (aricg, 15:01:15)
    4. Bryan Sullivan (bryan_att, 15:01:20)
    5. Wenjing Chu (Wenjing, 15:02:05)
    6. dlenrow (dlenrow, 15:02:36)
    7. Frank Brockners (frankbrockners, 15:02:42)
    8. Pranav Mehta (Pranav, 15:02:57)
    9. Ashiq (Ashiq, 15:03:01)
    10. Uli Kleber (uli___, 15:03:19)
    11. palani (palani, 15:03:43)
    12. Julien (julien_ZTE, 15:04:04)

  2. approve minutes (dlenrow, 15:04:49)
    1. approved by lack of objection (dlenrow, 15:05:30)

  3. agenda bashing (dlenrow, 15:05:44)
    1. events, board alternate, SR, are highlights (dlenrow, 15:07:33)

  4. events (dlenrow, 15:07:48)
    1. Bin (bin_, 15:07:51)
    2. ray shares events table from wiki (dlenrow, 15:08:05)
    3. Morgan (morgan_orange, 15:08:14)
    4. Margaret (margaret__, 15:08:26)

  5. proposed events for 2015 (ChrisPriceAB, 15:08:30)
    1. https://wiki.opnfv.org/start (dlenrow, 15:08:31)
    2. table is on wiki main page linked above (dlenrow, 15:08:49)
    3. Chris Wright (cdub, 15:08:54)
    4. events co-located with 2 x OpenStack Summit, ODL summit SDN/OF world congress, LF, ETSI, events (dlenrow, 15:10:57)
    5. OPNFV Summit Q4, USA, TBD (dlenrow, 15:11:14)
    6. Chris asks whether budget includes outreach beyond 4 x hackfests? (dlenrow, 15:11:49)
    7. discuss marketing, facitlities, food, etc, room at venue? Ray says this is in TSC budget, but can get help elsewhere in LF. (dlenrow, 15:12:53)
    8. OS Paris we didn't have OPNFV room/venue, we go vendor room time donated (dlenrow, 15:13:18)
    9. CP wants meetups and such to be covered as well to build community (dlenrow, 15:13:49)
    10. Ray/CP discuss Prague logistics. Expect some overlap with ETSI NFV #9 that same week. two day overlap? (dlenrow, 15:15:00)
    11. Tapio Tallgren (TapioTallgren, 15:18:38)
    12. debate about overlap logistics. bryan_att doesn't want overlap to make participants choos (dlenrow, 15:20:06)
    13. ETSI doesn't start until Tuesday. Margaret__ suggests we get lots of work done for OPNFV on Monday and then some overlap tuesday. (dlenrow, 15:20:49)
    14. CP summarizes Mon/Tues appears to be best target for OPNFV hackfest (dlenrow, 15:21:09)
    15. Ray will try to target Monday/Tuesday. Less technical overlap. (dlenrow, 15:23:13)
    16. More concern about Tuesday/Friday AM Plenary. Calling this a personal choice. Too many competing issues later in week. (dlenrow, 15:24:44)
    17. we need to ensure there is remote attendance possible at the TSC meeting - when can we get confirmation of that - e.g. Ray to take an action item for that (bryan_att, 15:24:58)
    18. ACTION: ray to setup registration to understand who plans to come. Work w/ ETSI to coordinate (dlenrow, 15:25:14)
    19. further event discussion to the lists (dlenrow, 15:25:34)

  6. board alternate (dlenrow, 15:25:41)
    1. CP as chair is TSC contact to the board, attend BOD meetings (dlenrow, 15:26:00)
    2. the Board decided there were no alternates, I thought (bryan_att, 15:26:25)
    3. Board would like alternate for case where CP can't attend (dlenrow, 15:26:29)
    4. CP proposes fbrockners as board alternate. Asks what is process for selecting alternate (dlenrow, 15:27:38)
    5. uli reminds we discussed vice chair pre-creation and had no conclusion (dlenrow, 15:30:05)
    6. two approaches: discretion of TSC Chair, or TSC elects this person (dlenrow, 15:30:29)
    7. proposal Chair appoints, TSC vote approves (dlenrow, 15:31:17)
    8. CP formally recommends Frank Brockners (dlenrow, 15:33:05)
    9. frank approved unanimously (dlenrow, 15:33:57)
    10. clarify alternate attends if/when TSC chair can't attend BOD meeting (dlenrow, 15:34:36)

  7. SR (dlenrow, 15:34:47)
    1. Uli requests CP share TSC report to BOD prior to next BOD Meeting next MOnday (dlenrow, 15:35:58)
    2. ACTION: CP to share his report to BOD later this week (dlenrow, 15:36:12)
    3. Uli reports on Liaison letter from M-P to ETSI. Margaret_ clarifies we're just seeking Colo and don't need liaison for ETSI #9 (dlenrow, 15:37:17)
    4. question as to whether HP/Prodip offered space to host at ETSI (dlenrow, 15:37:50)
    5. Susana clarifies ETSI is not formally interacting with OPNFV at Prague. Margaret_ clarifies separate registration and attendance for colocated events (dlenrow, 15:39:26)
    6. Susana reminds there are IPR issues related to formal joint-meetings (dlenrow, 15:39:47)

  8. Simultaneous release discussion (ChrisPriceAB, 15:40:32)
  9. Project Approvals (ChrisPriceAB, 15:42:04)
    1. ACTION: dlenrow to schedule a SR meeting ASAP this week. Will give brief update of SR status if time allows at end of this (dlenrow, 15:43:18)
    2. CP clarifies that creating project and having project join SR are not the same process (dlenrow, 15:44:12)
    3. review of IPv6 project (ChrisPriceAB, 15:44:37)
    4. https://wiki.opnfv.org/ipv6-enabled_vanilla_opnfv (ChrisPriceAB, 15:44:41)
    5. Bin presents the IPV6 project (dlenrow, 15:45:42)
    6. project is gap analysis against upstreams and support for same. Define auto and manual config processes (dlenrow, 15:46:33)
    7. deliverables are installable package, install scripts/tools, and process documentation for manual configs (dlenrow, 15:47:52)
    8. suggests that gap analysis could be a phase 2 or another project (dlenrow, 15:49:01)
    9. Uli asks will scripts be upstreamed or live in OPNFV repo long term? (dlenrow, 15:49:28)
    10. answer will depend on ability to get things accepted upstream. Will evolve over time. Goal is upstream. (dlenrow, 15:50:22)
    11. dlenrow suggests we might want general scope to work on IPV6, rather than fine segmentation of IPV6 project work (dlenrow, 15:51:50)
    12. pals asks relationship to overall platform installer for OPNFV. Don't want proliferation of fine-grain installers (dlenrow, 15:52:41)
    13. bin says happy to integrate into higher level tools. Details TBD as part of project work products. (dlenrow, 15:54:00)
    14. pals suggests that for gaps found, we design integration via language (e.g. puppet) to be part of overall installer (dlenrow, 15:54:38)
    15. bin agrees. Approach is to find where is best to insert V6 gap coverage (dlenrow, 15:55:25)
    16. CP summarizes intent is to build an OPNFV that does V6 properly. Wants proposal to emphasize dependency base platform (dlenrow, 15:56:24)
    17. CP asks if integration and test the correct category to put in? Is it more of an upstream ? (dlenrow, 15:57:32)
    18. cdub also questions which category this belongs in (dlenrow, 15:57:49)
    19. bin says analysis needed to know how and where work will occur. Happy to switch category if there is strong recommendation (dlenrow, 15:58:50)
    20. CP says it feels like a requirements project. fbrockners explains why it is hard to categorize. Asks what is outcome? doc & reqs? or lots of tests and validation (dlenrow, 16:00:22)
    21. bin says goal is both (dlenrow, 16:00:32)
    22. CP asks about duration/life-cycle. Is this 3 mo effort or a bigger bucket of work with 3 mo. first increment? (dlenrow, 16:02:28)
    23. bin suggests expand scope to IPV6 for OPNFV overall. Not micro-segmented within V6 (dlenrow, 16:03:01)
    24. plan to have a conditional vote to approve (dlenrow, 16:06:44)
    25. Not clear we can state exactly what conditional changes we are voting against. (dlenrow, 16:09:05)
    26. question of how/whether to approve now. (dlenrow, 16:09:17)
    27. CP wants to see changes before approving. (dlenrow, 16:09:39)
    28. proposal is to have final approval achieved after changes are agreed on list. Voting would occur on list. (dlenrow, 16:10:04)
    29. bin reports real-time changes to proposal on wiki. CP to start vote based on same. (dlenrow, 16:12:40)
    30. Congratulations on being first approved project in OPNFV (dlenrow, 16:13:39)
    31. unanimous +1s from all who voted (dlenrow, 16:13:52)
    32. ACTION: rpaik takes an action to ensure we are able to use voting on the meetbot moving forward (ChrisPriceAB, 16:14:35)

  10. doctor project (dlenrow, 16:15:18)
    1. Ashik shares slide to describe project. Need to upload and #link. (dlenrow, 16:18:13)
    2. ACTION: Ashiq to upload slides presented to TSC to OPNFV wiki (dlenrow, 16:18:42)
    3. https://wiki.opnfv.org/requirements_projects/doctor_fault_mangement_and_maintenance (Gerald, 16:19:59)
    4. describes plan to drive upstream changes via blueprints, etc. Will meet SR train post first release (dlenrow, 16:24:32)
    5. question about how this relates to the high availability project? Is there overlapping scope? (dlenrow, 16:31:18)
    6. Ashiq clarifies that scope is all faults, not just compute domain. DRL ask for this to be stated CLEARLY in project proposal. It's in there, but you have to look for it currently (dlenrow, 16:32:16)
    7. discussion of how to make HA and doctor complementary, etc. (dlenrow, 16:34:25)
    8. fbrockner suggests that we not try to restrict possible duplication this early in life-cycle (dlenrow, 16:36:25)
    9. qiao Fu wants to avoid overlap initially. (dlenrow, 16:37:57)
    10. uli suggests that project collaboration can clear up overlap issues (dlenrow, 16:38:35)
    11. Ashiq reminds we agreed to allow overlap in incubation projects at founding (dlenrow, 16:39:05)
    12. pals argues alignment and reuse. (dlenrow, 16:39:30)
    13. qiao Fu wants to avoid overlap initially. (dlenrow, 16:42:24)
    14. cdub has problems with 3-fold scope under single project. Expected some top-level, versus sub-project arrangement (dlenrow, 16:44:16)
    15. asks if we've departed from what some folks understood. (dlenrow, 16:46:07)
    16. suggestion is to do a requirements project around this and then derive implementation projects based on results (dlenrow, 16:46:39)
    17. CP suggests we try to approve a requirements project. (dlenrow, 16:49:55)
    18. dlenrow asks don't we need to see a draft of the modifications we are being asked to vote on? (dlenrow, 16:50:17)
    19. fbrockners suggests we get crisper on scope/motivation and try to avoid describing implementation to solve. (dlenrow, 16:51:18)
    20. uli asks do all projects need a requirements project first to justify them? (dlenrow, 16:52:44)
    21. CP says not this is result of broad scope of doctor in current form. (dlenrow, 16:53:09)
    22. CP asks can we vote now or need to defer? (dlenrow, 16:53:28)
    23. Ashiq wants to know if he is prevented from making project with upstreams until project is approved (dlenrow, 16:54:28)
    24. cdub suggests that process should not be allowed to slow such work and upstream discussions. (dlenrow, 16:54:55)
    25. Ashiq offers to edit proposal to describe a requirements project for future approval. Can do project work in parallel (dlenrow, 16:56:17)
    26. cdub suggests subcommittee/interrum-forum to prepare a proposal to bring to next TSC for process for working through lifecycle in OPNFV (dlenrow, 16:58:48)
    27. ACTION: cdub to mail list and invite folks to work on life-cycle proposal (dlenrow, 16:59:49)


Meeting ended at 17:52:11 UTC (full logs).

Action items

  1. ray to setup registration to understand who plans to come. Work w/ ETSI to coordinate
  2. CP to share his report to BOD later this week
  3. dlenrow to schedule a SR meeting ASAP this week. Will give brief update of SR status if time allows at end of this
  4. rpaik takes an action to ensure we are able to use voting on the meetbot moving forward
  5. Ashiq to upload slides presented to TSC to OPNFV wiki
  6. cdub to mail list and invite folks to work on life-cycle proposal


Action items, by person

  1. Ashiq
    1. Ashiq to upload slides presented to TSC to OPNFV wiki
  2. cdub
    1. cdub to mail list and invite folks to work on life-cycle proposal
  3. dlenrow
    1. dlenrow to schedule a SR meeting ASAP this week. Will give brief update of SR status if time allows at end of this
  4. rpaik
    1. rpaik takes an action to ensure we are able to use voting on the meetbot moving forward
  5. UNASSIGNED
    1. ray to setup registration to understand who plans to come. Work w/ ETSI to coordinate
    2. CP to share his report to BOD later this week


People present (lines said)

  1. dlenrow (112)
  2. ChrisPriceAB (19)
  3. cdub (11)
  4. collabot (9)
  5. frankbrockners (9)
  6. TapioT (5)
  7. bryan_att (4)
  8. osanchez (4)
  9. Ashiq (4)
  10. Hui (3)
  11. Pranav (3)
  12. uli___ (3)
  13. Wenjing (3)
  14. Gerald (2)
  15. palani (1)
  16. Torsten__ (1)
  17. julien_ZTE (1)
  18. aricg (1)
  19. morgan_orange (1)
  20. bin_ (1)
  21. rpaik (1)
  22. trevor_intel (1)
  23. margaret__ (1)
  24. TapioTallgren (1)
  25. fbrockners (0)


Generated by MeetBot 0.1.4.