#opnfv-meeting: project proposal dicussion

Meeting started by cdub at 16:05:15 UTC (full logs).

Meeting summary

    1. Frank Brockners (frankbrockners, 16:05:48)
    2. Carlos Goncalves (cgoncalves, 16:05:55)
    3. Chris Price (ChrisPriceAB, 16:06:05)
    4. Chris Wright (cdub, 16:06:07)
    5. : Gerald Kunzmann, Bertrand Souville (DOCOMO) (Gerald, 16:06:17)
    6. Ryota Mibu (r-mibu_, 16:07:00)
    7. Uli Kleber (uli_, 16:07:53)
    8. cdub describes the intention of the meeting as a venue to discuss our project definition methodology now that we have begun to work as a community on creating projects (ChrisPriceAB, 16:08:47)
    9. cdub highlights an issue that there are not many projects defining the development components in upstream communities (ChrisPriceAB, 16:09:47)
    10. Wenjing Chu (Wenjing, 16:10:37)
    11. Pranav states agreement that we should invest some time to promote and create projects in this area (ChrisPriceAB, 16:10:50)
    12. frankbrockners states that this may be natural as we are early in the process of OPNFV formation. Anticipates that once we are more mature the nature of the projects may also change. (ChrisPriceAB, 16:11:35)
    13. Tapio Tallgren (TapioT, 16:11:41)
    14. dlenrow (dlenrow, 16:11:50)
    15. cdub asks if there are examples of potential improvements to project type definitions (ChrisPriceAB, 16:14:21)
    16. Gerald indicates that more clarity to the process will help the community understand how they should approach proposing projects. (ChrisPriceAB, 16:14:58)
    17. fbrockners indicates that a smaller scope to projects in the proposal phase will make it much easier to approve and create a clearer structure (ChrisPriceAB, 16:16:01)
    18. cdub agrees that concise scope is helpful in execution. Asks if there are concrete examples of things we can do to the project proposal process. (ChrisPriceAB, 16:17:04)
    19. fbrockers states that having projects that fit only one category would help define what that project will set out to do. (ChrisPriceAB, 16:17:44)
    20. frankbrockners indicates that requesting a draft release plan as a component of the project review would help create clarity on the intention of the project (ChrisPriceAB, 16:18:40)
    21. Parvis asks how a project would fit into one of the catergories. (ChrisPriceAB, 16:18:59)
    22. franbrockners describes the project lifecycle document description of the project categories (ChrisPriceAB, 16:19:26)
    23. some useful links (cdub, 16:24:42)
    24. a question was raised if we should allow multiple projects to be constructed under one project (ChrisPriceAB, 16:24:46)
    25. https://www.opnfv.org/developers/technical-project-governance/project-lifecycle project lifecycle (cdub, 16:25:07)
    26. according to our current project project lifecycle this is not how we expect execution to be done (ChrisPriceAB, 16:25:20)
    27. cdub describes an aversion to process (ChrisPriceAB, 16:26:53)
    28. cdub states our processes should provide value, some infrastructure to govern activity without undue process is required. (ChrisPriceAB, 16:27:56)
    29. frankbrockers states our process should help people engage, smaller projects with clear scope provide a greater chance of producing an outcome in a timely manner (ChrisPriceAB, 16:28:58)
    30. frankbronckers indicates out project structure is created to allow people with different skills to engage in the project in understood areas. (ChrisPriceAB, 16:30:08)
    31. all of these pieces could potentially be combined into one project that would coordinate and produce all these components. (ChrisPriceAB, 16:30:53)
    32. Parvis states we should make the project categories more concrete. They should highlight areas that might combine sub-projects as potentially one project for approval. (ChrisPriceAB, 16:32:15)
    33. lenrow reminds us that we should review during the 2wk review period (cdub, 16:33:53)
    34. Parviz says the table template for a proposal is missing (cdub, 16:37:00)
    35. https://wiki.opnfv.org/oscar/project_proposal OCSCAR proposal (cdub, 16:37:07)
    36. Gerald suggests as follow-up to lenrow's reminder that during the 2wk period no comments == auto accept (cdub, 16:38:02)
    37. cdub agrees that 2wk review process isn't useful if we don't review, need to incentivize TSC members to do review (cdub, 16:39:44)
    38. ChrisPriceAB TSC members need to review, can bring this up in next TSC call (cdub, 16:40:37)
    39. https://wiki.opnfv.org/project_proposals/template proposal template (cdub, 16:43:29)
    40. lenrow, chrisprice, cdub, pranav and frankbrockers will make initial edits (cdub, 16:45:55)
    41. and propose those in upcoming TSC call (cdub, 16:46:07)
    42. cdub proposes make small edits to existing process (like adding "or" to the project type list in proposal template) (cdub, 16:46:47)
    43. cdub need to capture either 4 different templates or details w/in a single template that make it clear which parts apply to which proposal type (cdub, 16:52:27)
    44. dlenrow do we think our most basic projects (CI and test) would meet the "only one category" test? (cdub, 16:53:29)
    45. cdub suggests that would be a collaborative development process, others agree (cdub, 16:53:45)
    46. ChrisPrice suggests that proposal should help identify project needs from infratstructure (cdub, 16:54:34)
    47. lack of clarity on what those needs might be beyond git/gerrit, but worth documenting (cdub, 16:56:39)
    48. Praviz asks where do we capture version numbers for sw components? (cdub, 16:58:35)
    49. agreed, we don't have mechanism for capturing this...tribal knowledge has suggested helium(odl) hydrogen(openstack) (cdub, 17:00:41)
    50. ACTION: cdub to help small team make the simple edits to existing templates (cdub, 17:02:46)
    51. ACTION: ChrisPrice to remind TSC members to review before TSC calls (during 2wk review) (cdub, 17:03:12)
    52. ACTION: cdub will keep soliciting for input on how to make larger scoped changes to the process (cdub, 17:03:42)


Meeting ended at 17:03:49 UTC (full logs).

Action items

  1. cdub to help small team make the simple edits to existing templates
  2. ChrisPrice to remind TSC members to review before TSC calls (during 2wk review)
  3. cdub will keep soliciting for input on how to make larger scoped changes to the process


Action items, by person

  1. cdub
    1. cdub to help small team make the simple edits to existing templates
    2. cdub will keep soliciting for input on how to make larger scoped changes to the process


People present (lines said)

  1. cdub (29)
  2. ChrisPriceAB (24)
  3. Gerald (4)
  4. frankbrockners (3)
  5. collabot (3)
  6. dlenrow (2)
  7. TapioT (1)
  8. cgoncalves (1)
  9. r-mibu_ (1)
  10. aricg (1)
  11. uli_ (1)
  12. Wenjing (1)


Generated by MeetBot 0.1.4.