#opnfv-meeting: OPNFV TSC - project review

Meeting started by ChrisPriceAB at 14:00:52 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 14:01:09)
    1. Chris Price (ChrisPriceAB, 14:01:15)
    2. Tapio Tallgren (TapioT, 14:01:17)
    3. Dirk Kutscher (dku, 14:01:37)
    4. Ashiq Khan (Ashiq, 14:02:24)
    5. Uli Kleber (uli_, 14:03:28)
    6. Frank Brockners (frankbrockners, 14:03:43)
    7. Pranav Mehta (Pranav, 14:04:41)
    8. dlenrow (dlenrow, 14:05:05)
    9. (ghellmann, 14:05:10)

  2. Resource management project review (ChrisPriceAB, 14:08:28)
    1. https://wiki.opnfv.org/requirements_projects/resource_management (ChrisPriceAB, 14:08:48)
    2. Bryan Sullivan (bryan_att, 14:09:34)
    3. palani (palani, 14:10:22)
    4. Ashiq describes the current issue around resource reservation in OpenStack, that it is not possible to reserve resources for future asignment (ChrisPriceAB, 14:11:09)
    5. Hui (rpaik, 14:13:04)
    6. Andrea__ (rpaik, 14:13:25)
    7. ghellmann (ghellmann, 14:15:23)
    8. Pranav asks if there will be investigations into the security aspects of reserving resources with specific security profiles (ChrisPriceAB, 14:16:14)
    9. Ashiq describes that such criteria may be used for mapping. (ChrisPriceAB, 14:16:45)
    10. A discussion ensues on how policies and the underlying implementation can be resolved in the requirements projects. Bryan describes there is a need for collaboration between the policy and resource reservation projects. (ChrisPriceAB, 14:18:17)
    11. Mike Bugenhagen asks which network capability abstractions and service requirement abstractions will be documented in this project. (I think) (ChrisPriceAB, 14:19:25)
    12. A discussion ensues on the policy project... (ChrisPriceAB, 14:20:27)
    13. clarification ensues that the reservation lifecycle abstractions will need to be captured clearly in this project. (ChrisPriceAB, 14:21:52)
    14. julien_ZTE (rpaik, 14:22:07)
    15. cdub (rpaik, 14:22:38)
    16. Bryan indicates that the capabilities provided in this project may be able to be purposed to identify reource wateage. (ChrisPriceAB, 14:23:03)
    17. resource wasteage (ChrisPriceAB, 14:23:11)
    18. Ashiq indicates that this is not addressed in the scope of this project (ChrisPriceAB, 14:23:25)
    19. frankbrockners describes that use case descriptions would be beneficial to clarify the proposal. ( as a recoomendation ) (ChrisPriceAB, 14:29:05)
    20. another suggestion to add email addresses of committers/contributors (rpaik, 14:29:19)
    21. there is a clarification that this covers network/storage/compute resources. (ChrisPriceAB, 14:29:29)
    22. the promise project has been approved for creation by the TSC. (ChrisPriceAB, 14:32:48)

  3. Project review for copper project (ChrisPriceAB, 14:33:04)
    1. https://wiki.opnfv.org/requirements_projects/virtual_infrastructure_deployment_policies (bryan_att, 14:33:11)
    2. Bryan describes the copper project's goal is to determine when a resource has been allocated/deallocated according to a decision. (focused on policy driven decisions) (ChrisPriceAB, 14:34:53)
    3. the project shall perform gap analysis of existing capabilities and identify areas fr improvement or further development (ChrisPriceAB, 14:35:36)
    4. event collection is a component of the project scope that may provide additional value. (ChrisPriceAB, 14:37:09)
    5. topics to be covered are; what is available today and is it sufficient, how are cross component policies coordinated. (ChrisPriceAB, 14:38:59)
    6. bryan describes that a publish/subscribe model for modelling data will enable automated policy functions to be realized. (ChrisPriceAB, 14:42:26)
    7. Bryan clarifies that the contributors on the project would fill the role of committer for project creation. (ChrisPriceAB, 14:46:53)
    8. frankbrockners indicates that a clarification on the output of the project and project committers is required. (ChrisPriceAB, 14:49:36)
    9. Ashiq indicates that a policy realization is deployment specific and asks if the project will attempt to define policies or define policy object types. (ChrisPriceAB, 14:50:38)
    10. bryan answers that the project will define the policy object types rather than deployment specific policies. (ChrisPriceAB, 14:51:17)
    11. Bryan is asked if this is an assesment of the current state, or if this will address known NFV policy goals. (ChrisPriceAB, 14:51:47)
    12. bryan responds that an assesment will be made and the goal is to establish NFV based policy solutions. (ChrisPriceAB, 14:52:20)
    13. bryan_att please add a contibuor of my colleague "tand.delong@zte.com.cn" (julien_ZTE, 14:53:48)
    14. ACTION: Bryan to update the committer/contributor list and deliverables for review on Tuesdays TSC call for a final vote. (ChrisPriceAB, 14:55:49)


Meeting ended at 14:55:56 UTC (full logs).

Action items

  1. Bryan to update the committer/contributor list and deliverables for review on Tuesdays TSC call for a final vote.


People present (lines said)

  1. ChrisPriceAB (42)
  2. collabot (7)
  3. rpaik (5)
  4. dlenrow (3)
  5. bryan_att (3)
  6. ghellmann (3)
  7. Ashiq (3)
  8. Pranav (2)
  9. frankbrockners (2)
  10. TapioT (2)
  11. Gerald (2)
  12. uli_ (2)
  13. dku (2)
  14. julien_ZTE (2)
  15. palani (1)
  16. Hui (1)
  17. ImranK (1)


Generated by MeetBot 0.1.4.