#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 15:02:43 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 15:02:48)
    1. Chris Price (ChrisPriceAB, 15:02:56)
    2. Uli Kleber (uli_, 15:03:10)
    3. Bryan Sullivan (bryan_att, 15:03:11)
    4. Wenjing Chu (Wenjing, 15:03:12)
    5. Frank Brockners (frankbrockners, 15:03:19)
    6. Moiz Arif (moizarif, 15:03:31)
    7. dlenrow (dlenrow, 15:03:33)
    8. Ashiq (Ashiq, 15:03:47)
    9. Tapio Tallgren (TapioT, 15:05:45)
    10. julien_ZTE (rpaik, 15:05:59)

  2. approve previous minutes (dlenrow, 15:06:38)
    1. Palani (Palani, 15:06:46)
    2. minutes approved by lack of dissent (dlenrow, 15:06:50)

  3. Agenda Bashing (ChrisPriceAB, 15:06:58)
    1. Hui (rpaik, 15:07:16)
    2. look at holiday meeting schedule for end of year (dlenrow, 15:07:25)
    3. want to discuss how we map OPNFV projects to upstream relatives (dlenrow, 15:07:57)
    4. Trevor Cooper (Intel) (trevor_intel, 15:09:26)

  4. holiday/end-of-year scheduling (dlenrow, 15:10:06)
    1. suggest Dec 16 as last TSC meeting prior to January. (dlenrow, 15:10:45)
    2. agree to meet 16th, CP propose we not meet on 23 due to peoples time-off (dlenrow, 15:11:28)
    3. CP suggest we be prepared for Dec 18 TSC call if needed for progress/approvals (dlenrow, 15:11:56)
    4. CP suggest next TSC meeting occur Jan 6. Holiday in Italy (dlenrow, 15:12:20)
    5. Andrea (rpaik, 15:13:08)
    6. Andrea__ can't attend Jan 6, but can get proxy. Germany also conflicts (dlenrow, 15:13:18)
    7. Frankbrockners suggests we switch to alternate date week of Jan 6. (dlenrow, 15:13:35)
    8. Dirk Kutscher (dku, 15:13:49)
    9. propose Thursday Jan 8 as first TSC call of new year. (dlenrow, 15:14:00)
    10. Considering taking testing meeting time slot at 7AM PT. (dlenrow, 15:14:42)
    11. agreed 7-9 PT Thursday Jan 8 is first TSC call of 2015 (dlenrow, 15:15:04)
    12. agreed 7-9 AM PT Thursday Jan 8 is first TSC call of 2015 (dlenrow, 15:15:18)
    13. AGREED: 7-9 AM PT Thursday Jan 8 is first TSC call of 2015 (dlenrow, 15:15:30)
    14. agreed Greg Hall ( For Tom Nadeau ) (ghall, 15:15:41)
    15. ACTION: Ray to update the wiki w.r.t. Jan. 8th TSC call (rpaik, 15:15:54)
    16. AGREED: 7-9 AM PT Thursday Dec 18 is last call of of 2014 (dlenrow, 15:16:04)

  5. collabortive developement projects (ChrisPriceAB, 15:16:09)
    1. two primary approaches considered. Project is a use case and engages as needed upstream. Or Project is an upstream proxy/liaison and map to upstream. (dlenrow, 15:17:29)
    2. are the collab development projects intended to be a SPOC for upstream contribution? Or will other projects be able to commit directly? (bryan_att, 15:17:47)
    3. need to decide as community how these "collaborative" projects will be structured (dlenrow, 15:17:49)
    4. CP says one issue to consider is duration of projects persistent or transient. (dlenrow, 15:20:27)
    5. Bryan_ATT asks about exclusivity of upstream mapped projects (dlenrow, 15:20:53)
    6. Andrea suggests May be we can arrange by use case aggregating those that work on the same components of the upstream projects (dlenrow, 15:26:14)
    7. Ashiq asks what is meant by use case? CP describes a feature spread across multiple upstreams (dlenrow, 15:26:51)
    8. by features makes more sense to me, e.g. policy and the facillities (event pub/sub) that enable it (bryan_att, 15:27:11)
    9. please use the term feature or function rather than use case... (bryan_att, 15:27:49)
    10. Mike Lynch has suggested that use case orientation might allow better architectural control. CP suggests that this could lead to fragmented architecture upstream, reliant on upstream decisions. (dlenrow, 15:27:58)
    11. Mike warns we want to become more than just a bunch of upstream artifacts. CP asks who are committers on those control points? (dlenrow, 15:28:35)
    12. can you define "control points"? (bryan_att, 15:28:42)
    13. Mike suggests we need a big picture architecture (owned by TSC) to inform the per-use-case approach (dlenrow, 15:29:12)
    14. basic issue is bottom-up vs top-town control/influence on the platform/system we build (dlenrow, 15:29:50)
    15. Mike advocating more TSC input into a system arch (dlenrow, 15:30:07)
    16. CP suggests we continue discussin on mail lists. Not converging on a solution here. (dlenrow, 15:31:12)
    17. CP reminds that when collaborative projects come up for creation review we need to have this figured out: How do we interact upstream? (dlenrow, 15:31:51)
    18. FrankBrockners suggests the first collab project headed for creation should be the pilot and use context to figure this out. (dlenrow, 15:32:47)
    19. dlenrow asks what is first collab in queue. Can we get them to volunteer to propose a way to interact upstream. (dlenrow, 15:34:51)
    20. CP reminds that Telco KPI coming up for creation today and we can discuss more in that time slot (dlenrow, 15:35:22)
    21. Julien_ZTE asks clarification about where code/committing will live. CP clarifies mostly upstream. (dlenrow, 15:37:13)

  6. committer check for Octopus (dlenrow, 15:37:28)
    1. https://wiki.opnfv.org/octopus/project_proposal (ChrisPriceAB, 15:37:38)
    2. Final committer list for creation available (dlenrow, 15:37:55)
    3. Uli suggest approval projects should be listed in some wiki pages (julien_ZTE, 15:41:48)
    4. Octopus Committer list on wiki updated with 2x HP committers (dlenrow, 15:43:45)
    5. ACTION: Uli to further organize projects so it is clear what is approved, pending, etc. (dlenrow, 15:44:16)
    6. CP reminds that projects don't go on main project page until approved. Keep proposed/unapproved off main project page (dlenrow, 15:44:56)
    7. I still don't know how to run the vote... (dlenrow, 15:46:50)
    8. AGREED: Octopus project approved for creation (dlenrow, 15:47:05)
    9. Parviz Yegani (Parviz, 15:48:05)

  7. approval and committer check for Infra policy project (dlenrow, 15:48:24)
    1. dlenrow and Staffan Blau to be added as committer, NEC also one to add. We're editing wiki in realtime now (dlenrow, 15:50:38)
    2. ZTE is interested in copper, and I will check wheter we can put more resources in this project. (julien_ZTE, 15:51:15)
    3. final edits get us two more committers and another contributor during call. (dlenrow, 15:51:37)
    4. previous vote cancelled. We needed to add one more committer (dlenrow, 15:53:55)
    5. AGREED: Copper approved for creation (dlenrow, 15:55:46)

  8. new project creation reviews (dlenrow, 15:56:03)
    1. https://wiki.opnfv.org/requirements_projects/high_availability_for_vnfs (ChrisPriceAB, 15:56:38)

  9. HA project (dlenrow, 15:57:06)
    1. https://wiki.opnfv.org/requirements_projects/high_availability_for_vnfs (ChrisPriceAB, 15:57:30)
    2. early deliverables are gap analysis and report/survey of use cases and HA approaches (dlenrow, 16:00:15)
    3. later work to define HA APIs derived from req.s. Also work on capabilities exchange APIs for diverse hardware/state (dlenrow, 16:01:18)
    4. analyze existing OpenStack HA work and consider extensions and enhancements. (dlenrow, 16:01:44)
    5. discussion of API requirements vs creating info models. CP proposes we change language to specify API requirements. Change made on proposal page. (dlenrow, 16:09:29)
    6. Parviz concerned that ETSI spec referenced may be too broad of scope (dlenrow, 16:20:44)
    7. Following the discussion, the proposal got updated to speak of "requirements for HA API" (not define HA API), removed the "maintainer" from list of contributors and committers, added "study HA for SDN controller" to the scope (frankbrockners, 16:22:43)
    8. https://wiki.opnfv.org/requirements_projects/high_availability_for_opnfv (frankbrockners, 16:26:39)
    9. +1 (bryan_att, 16:28:05)
    10. AGREED: HA for OPNFV approved for creation (dlenrow, 16:28:32)

  10. project bootstrap/get-started (dlenrow, 16:28:54)
    1. https://wiki.opnfv.org/get_started/get_started_project_proposal (ChrisPriceAB, 16:29:07)
    2. Basic setup to deploy platform and run a couple of VNFs in a standard config as a starting point for dev/integration. (dlenrow, 16:30:39)
    3. We have access to systems and folks are starting to make things work. (dlenrow, 16:31:02)
    4. Need to approve and execute as this is the foundation to build all our deliverables. Big diverse group of contributors and committers. (dlenrow, 16:31:45)
    5. planning to have something working for Rel 1.0 in March 2015 (dlenrow, 16:32:01)
    6. the point of the project is not about VNFs, but about the framework, so I don't understand why there is so much focus on VNFs in this discussion. (bryan_att, 16:36:06)
    7. usijng CentOS as Linux foundation for now... (dlenrow, 16:38:12)
    8. we can add Bin Hu as a contributor now or later (bryan_att, 16:38:37)
    9. AGREED: Bootstrap/get-started approved for creation (dlenrow, 16:39:51)
    10. FrankBrockners reminds that this is moving fast and communication occurs daily on IRC. Meeting info on Wiki. Webex as needed (dlenrow, 16:40:38)

  11. project proposal Telco KPI (dlenrow, 16:41:30)
    1. https://wiki.opnfv.org/collaborative_development_projects/opnfv_telco_kpi_monitoring (dlenrow, 16:41:48)
    2. project name & repository name repository suggested for the project (rpaik, 17:01:56)
    3. plan to adjust repo name, project name, and then vote (without extensive discussion) next TSC call (dlenrow, 17:02:12)


Meeting ended at 17:02:24 UTC (full logs).

Action items

  1. Ray to update the wiki w.r.t. Jan. 8th TSC call
  2. Uli to further organize projects so it is clear what is approved, pending, etc.


People present (lines said)

  1. dlenrow (91)
  2. ChrisPriceAB (24)
  3. frankbrockners (15)
  4. bryan_att (12)
  5. Andrea__ (12)
  6. julien_ZTE (9)
  7. collabot (7)
  8. Ashiq (7)
  9. Hui (6)
  10. TapioT (6)
  11. Wenjing (6)
  12. dku (6)
  13. uli_ (5)
  14. rpaik (5)
  15. Trevor_ (2)
  16. ghall (2)
  17. Parviz (2)
  18. r-mibu_ (1)
  19. moizarif (1)
  20. Palani (1)
  21. cgoncalves (1)
  22. fuqiao (1)
  23. aricg (1)
  24. trevor_intel (1)
  25. Susana_ (1)


Generated by MeetBot 0.1.4.